summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-09 23:00:55 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-09 23:02:10 -0400
commit2f13af6b351d09119f3264bae39ef185eedf145b (patch)
treeb06c96eec461d4dcb3154b8989d0bd566e4bf331 /net-proxy/sshuttle
parentRevert "sys-boot/grub: do not force multislot use flag on" (diff)
downloadgentoo-2f13af6b351d09119f3264bae39ef185eedf145b.tar.gz
gentoo-2f13af6b351d09119f3264bae39ef185eedf145b.tar.bz2
gentoo-2f13af6b351d09119f3264bae39ef185eedf145b.zip
net-proxy/sshuttle: version bump to 0.78.1
Diffstat (limited to 'net-proxy/sshuttle')
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/sshuttle-0.78.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index bb119f64130b..a4b01bdf2c8d 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1 +1,2 @@
DIST sshuttle-0.78.0.tar.gz 63391 SHA256 6bd80d48f73eb04d4449a8aa636081704107cfdef05980b3b02166ff44e419a2 SHA512 e4ecb09e79905c1be6d3d7935863231c54bd68144fbb1ca38af29d5efb35c42261db4319368d5c83474ed9714859b04012c9ad4108a77d283a0a041356f90cbd WHIRLPOOL 9f7c0ea7be81b4605ee4e9c14be1bc309fc273cc367be348a64f04569e5505888a12350e0ac07415edc541539dfdc3c3a5c6ac90421189dd6c6567ccc2131b37
+DIST sshuttle-0.78.1.tar.gz 67173 SHA256 03a71648ce476de06a075bd9a972492d494b414ae51304bf535b80ff22be2d3c SHA512 506b01f20d152e97a41c93299f47d6bba4d7f9fda11e066aca3d79426be68790ff30a3a081ea05ca538aba921ed69e711b672fcfd9084aba6bdae6498beb7e8d WHIRLPOOL d356bf17ba5f6f01351dc316745af3fd07237160340f675e1ecef52d73cb15caf4c5eee65d1ed56ea4008081623362688957f268da30d487d5aa6be02632ddda
diff --git a/net-proxy/sshuttle/sshuttle-0.78.1.ebuild b/net-proxy/sshuttle/sshuttle-0.78.1.ebuild
new file mode 100644
index 000000000000..cb4996503944
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.78.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5} )
+
+inherit linux-info distutils-r1
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.python.org/pypi/sshuttle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-firewall/iptables
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
+
+python_prepare_all() {
+ # don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die "Tests fail under ${EPYTHON}"
+}