summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/airpwn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/airpwn')
-rw-r--r--net-wireless/airpwn/Manifest1
-rw-r--r--net-wireless/airpwn/airpwn-1.4-r2.ebuild45
-rw-r--r--net-wireless/airpwn/metadata.xml13
3 files changed, 59 insertions, 0 deletions
diff --git a/net-wireless/airpwn/Manifest b/net-wireless/airpwn/Manifest
new file mode 100644
index 000000000000..eb77af35a0b3
--- /dev/null
+++ b/net-wireless/airpwn/Manifest
@@ -0,0 +1 @@
+DIST airpwn-1.4.tgz 910109 SHA256 f689cd5a9038832cb0aaefa18cae0c282a6bfbeea38819cf47f306f14344e164 SHA512 c849740848289005eb2a72b09bbfade6bf078a3ff93d39300f6a65d328c527bbafbb2a325f2813064612f91a2da20a2daacb8508497e8410ad0befc4e28331e5 WHIRLPOOL f3e7f18578e8c19dd033567851abd9af3a5bd9b0c76bc60010b654735d8632fa02eb942350afbd9015b4b8ef25e9b3dd9e01f30c38358658e5b22a89a3c9b259
diff --git a/net-wireless/airpwn/airpwn-1.4-r2.ebuild b/net-wireless/airpwn/airpwn-1.4-r2.ebuild
new file mode 100644
index 000000000000..a8ca79f238d7
--- /dev/null
+++ b/net-wireless/airpwn/airpwn-1.4-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic python-single-r1
+
+DESCRIPTION="Tool for generic packet injection on 802.11"
+HOMEPAGE="http://airpwn.sf.net"
+SRC_URI="mirror://sourceforge/airpwn/$P.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+examples"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/libpcre
+ dev-libs/openssl:0=
+ net-libs/libnet:1.1=
+ net-libs/libpcap
+ net-wireless/lorcon-old"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf
+ sed -i "s/python2.4/${EPYTHON}/g" conf.h || die
+ sed -i "s|-lorcon -lpthread -lpcre -lpcap -lnet|-lorcon -lpthread -lpcre -lpcap -lnet -lcrypto -l${EPYTHON}|g" Makefile || die
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ ecvs_clean
+ sed -i "s#content/#/usr/share/${PN}/content/#" conf/* || die
+ doins -r conf content
+ fi
+}
diff --git a/net-wireless/airpwn/metadata.xml b/net-wireless/airpwn/metadata.xml
new file mode 100644
index 000000000000..a44f7d6df373
--- /dev/null
+++ b/net-wireless/airpwn/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">airpwn</remote-id>
+ </upstream>
+</pkgmetadata>