summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/crackle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/crackle')
-rw-r--r--net-wireless/crackle/Manifest1
-rw-r--r--net-wireless/crackle/crackle-0.1.ebuild29
-rw-r--r--net-wireless/crackle/files/flags.patch20
-rw-r--r--net-wireless/crackle/metadata.xml10
4 files changed, 60 insertions, 0 deletions
diff --git a/net-wireless/crackle/Manifest b/net-wireless/crackle/Manifest
new file mode 100644
index 000000000000..7db449d8bb9f
--- /dev/null
+++ b/net-wireless/crackle/Manifest
@@ -0,0 +1 @@
+DIST crackle-0.1.tgz 27015 SHA256 07e31b5a67451b1d3baa3cde81cf5c945fd258df5b3df84fb12f01aaead4d5d6 SHA512 e60341e1fae6a3212028714a7bdba2c8f65d4b92d3d670194954df0e11e1f69a1bb6a5bcbdd5c4db54774cfe60955d50fbd2bfaff5fa615bf253f57283cfa17b WHIRLPOOL 837e3526d438b58473190e9e6f23e42e7f2d1b8d372b4aa3eeb47b245ac305e9e1f3fb49e03c648b802ecd128a5c88079026271dd8d07fdf50542040b19169e6
diff --git a/net-wireless/crackle/crackle-0.1.ebuild b/net-wireless/crackle/crackle-0.1.ebuild
new file mode 100644
index 000000000000..708032aa5091
--- /dev/null
+++ b/net-wireless/crackle/crackle-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Crackle cracks BLE Encryption (AKA Bluetooth Smart)"
+HOMEPAGE="http://lacklustre.net/projects/crackle/"
+SRC_URI="http://lacklustre.net/projects/crackle/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/flags.patch
+}
+
+src_install() {
+ dobin crackle
+}
diff --git a/net-wireless/crackle/files/flags.patch b/net-wireless/crackle/files/flags.patch
new file mode 100644
index 000000000000..c1c0bd570d36
--- /dev/null
+++ b/net-wireless/crackle/files/flags.patch
@@ -0,0 +1,20 @@
+diff -Naur crackle-0.1/Makefile crackle-0.1-patched/Makefile
+--- crackle-0.1/Makefile 2013-02-15 01:04:24.000000000 -0500
++++ crackle-0.1-patched/Makefile 2014-03-05 11:30:20.907003818 -0500
+@@ -4,13 +4,13 @@
+
+ OBJS = crackle.o aes.o aes-ccm.o aes-enc.o test.o
+
+-CFLAGS = -Wall -Werror -g
+-LDFLAGS = -lpcap
++CFLAGS ?= -Wall -Werror -g
++LDFLAGS ?=
+
+ all: crackle
+
+ crackle: $(OBJS)
+- $(CC) -o crackle $(OBJS) $(LDFLAGS)
++ $(CC) $(CFLAGS) -o crackle $(OBJS) -lpcap $(LDFLAGS)
+
+ install: crackle
+ $(INSTALL) -m 0755 crackle $(INSTALL_DIR)
diff --git a/net-wireless/crackle/metadata.xml b/net-wireless/crackle/metadata.xml
new file mode 100644
index 000000000000..4b6b68191d89
--- /dev/null
+++ b/net-wireless/crackle/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>