summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-08-14 14:42:36 -0400
committerRick Farina <zerochaos@gentoo.org>2020-08-14 14:42:43 -0400
commit0f83c6364d17a554e424109d5ff9511ade25c3cc (patch)
tree2c9fe8c66af101da37d7fa400e7083775b0a8778 /net-wireless/gr-iqbal
parentdev-util/meson: sync live (diff)
downloadgentoo-0f83c6364d17a554e424109d5ff9511ade25c3cc.tar.gz
gentoo-0f83c6364d17a554e424109d5ff9511ade25c3cc.tar.bz2
gentoo-0f83c6364d17a554e424109d5ff9511ade25c3cc.zip
net-wireless/gr-iqbal: update eclass use
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/gr-iqbal')
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild6
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
index 716aaa6176fc..d8b2cae1cdd9 100644
--- a/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8})
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
DESCRIPTION="gnuradio I/Q balancing"
HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
@@ -32,10 +32,10 @@ src_configure() {
local mycmakeargs=(
-DENABLE_DOXYGEN="$(usex doc)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_optimize "${ED}/$(python_get_sitedir)"
}
diff --git a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
index 716aaa6176fc..d8b2cae1cdd9 100644
--- a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
+++ b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8})
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
DESCRIPTION="gnuradio I/Q balancing"
HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
@@ -32,10 +32,10 @@ src_configure() {
local mycmakeargs=(
-DENABLE_DOXYGEN="$(usex doc)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_optimize "${ED}/$(python_get_sitedir)"
}