summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-09-02 09:41:21 -0400
committerRick Farina <zerochaos@gentoo.org>2020-09-02 09:41:30 -0400
commite44a672eb716ebd26b435e2d9960f157e2546c5b (patch)
tree90cb308efb88770d275da0169c5fb80964293db3 /net-wireless/kismet
parentmedia-gfx/word_cloud: Version bump to 1.8.0. (diff)
downloadgentoo-e44a672eb716ebd26b435e2d9960f157e2546c5b.tar.gz
gentoo-e44a672eb716ebd26b435e2d9960f157e2546c5b.tar.bz2
gentoo-e44a672eb716ebd26b435e2d9960f157e2546c5b.zip
net-wireless/kismet: restore improperly removed version
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/kismet')
-rw-r--r--net-wireless/kismet/Manifest1
-rw-r--r--net-wireless/kismet/kismet-2016.07.1-r2.ebuild164
-rw-r--r--net-wireless/kismet/metadata.xml9
3 files changed, 174 insertions, 0 deletions
diff --git a/net-wireless/kismet/Manifest b/net-wireless/kismet/Manifest
index c44b6a5b8c63..c5035f6b4b2d 100644
--- a/net-wireless/kismet/Manifest
+++ b/net-wireless/kismet/Manifest
@@ -1,2 +1,3 @@
+DIST kismet-2016-07-R1.tar.xz 709364 BLAKE2B 5b667a02b517bd413d569f40df1f2a2e1158357c602fa807d712870543a7fade25077f449c07c023ad1d2150870352aa754484846d8c2a0d9f027113bb57c1fc SHA512 88891a0cd5ef94a4815d259e433f946f52552c125e05a5d8ac447d04e6090f2bd92f8bd8573440f0dfe446b29233bef81d9889e53170757ad0116ddfc2cb8416
DIST kismet-2020-04-R3.tar.xz 3159552 BLAKE2B 458c40dea530008295d46aadaf15699a0fd9025bb572cb23e94f059f31bba2835dedd9c39725d0183e84d31c326c2769450ce0b8bee7e7ca3bb7ac9dd82f4cc6 SHA512 585def7f19f479c6049cbc24e3886276d816f584fcb2070009cd90e35b33630d3e544145abf5f8b1eae87ec571a213ed9cb9f6b81345257c9bf1332d5bb319c2
DIST kismet-2020-09-R1.tar.xz 8694804 BLAKE2B 1389486809024179c3be71a8b26cdb460f483e1af0dd7cda9d36450d10e4df16536f23db3b5ca3fd6b65b0c48514c96e5cb37ec71425a8f087d58e7a89bed137 SHA512 e687c76b9e94d973245f61d6fc59a1a05a06ba9c765f7661a183d14d0228676359a7d7798bac9f3b493a5c311e53785c54fd9f0d12bf6cdc4d43919bad167327
diff --git a/net-wireless/kismet/kismet-2016.07.1-r2.ebuild b/net-wireless/kismet/kismet-2016.07.1-r2.ebuild
new file mode 100644
index 000000000000..17f5963fa10c
--- /dev/null
+++ b/net-wireless/kismet/kismet-2016.07.1-r2.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib user
+
+MY_P=${P/\./-}
+MY_P=${MY_P/./-R}
+S=${WORKDIR}/${MY_P}
+
+SRC_URI="https://www.kismetwireless.net/code/${MY_P}.tar.xz"
+KEYWORDS="amd64 arm ~arm64 ~ppc x86"
+
+DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
+HOMEPAGE="https://www.kismetwireless.net"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="+client +pcre speech +plugin-autowep +plugin-btscan plugin-dot15d4 +plugin-ptw +plugin-spectools +plugin-syslog +ruby selinux +suid"
+
+CDEPEND="net-wireless/wireless-tools
+ kernel_linux? ( sys-libs/libcap
+ dev-libs/libnl:3
+ net-libs/libpcap
+ )
+ pcre? ( dev-libs/libpcre )
+ suid? ( sys-libs/libcap )
+ client? ( sys-libs/ncurses:0= )
+ !arm? ( speech? ( app-accessibility/flite ) )
+ plugin-btscan? ( net-wireless/bluez )
+ plugin-dot15d4? ( virtual/libusb:0 )
+ plugin-spectools? ( net-wireless/spectools )
+ plugin-ptw? ( dev-libs/openssl:= )
+"
+
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+
+RDEPEND="${CDEPEND}
+ ruby? ( dev-lang/ruby:* )
+ selinux? ( sec-policy/selinux-kismet )
+"
+
+src_prepare() {
+ sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
+ conf/kismet.conf.in
+
+ # Don't strip and set correct mangrp
+ sed -i -e 's| -s||g' \
+ -e 's|@mangrp@|root|g' Makefile.in
+
+ epatch "${FILESDIR}/${P}-ruby-fixes.patch"
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable client) \
+ $(use_enable pcre)
+}
+
+src_compile() {
+ emake
+
+ if use plugin-autowep; then
+ cd "${S}"/restricted-plugin-autowep
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-btscan; then
+ cd "${S}"/plugin-btscan
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-dot15d4; then
+ cd "${S}"/plugin-dot15d4
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-ptw; then
+ cd "${S}"/restricted-plugin-ptw
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-spectools; then
+ cd "${S}"/plugin-spectools
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-syslog; then
+ cd "${S}"/plugin-syslog
+ KIS_SRC_DIR="${S}" emake
+ fi
+}
+
+src_install() {
+ if use plugin-autowep; then
+ cd "${S}"/restricted-plugin-autowep
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-btscan; then
+ cd "${S}"/plugin-btscan
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-dot15d4; then
+ cd "${S}"/plugin-dot15d4
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-ptw; then
+ cd "${S}"/restricted-plugin-ptw
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-spectools; then
+ cd "${S}"/plugin-spectools
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-syslog; then
+ cd "${S}"/plugin-syslog
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use ruby; then
+ cd "${S}"/ruby
+ dobin *.rb
+ fi
+
+ cd "${S}"
+ emake DESTDIR="${D}" commoninstall
+
+ ##dragorn would prefer I set fire to my head than do this, but it works
+ ##all external kismet plugins (read: kismet-ubertooth) must be rebuilt when kismet is
+ ##is there an automatic way to force this?
+ # install headers for external plugins
+ insinto /usr/include/kismet
+ doins *.h
+ doins Makefile.inc
+ #todo write a plugin finder that tells you what needs to be rebuilt when kismet is updated, etc
+
+ dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore
+ newinitd "${FILESDIR}"/${PN}.initd kismet
+ newconfd "${FILESDIR}"/${PN}.confd kismet
+
+ insinto /etc
+ doins conf/kismet{,_drone}.conf
+
+ if use suid; then
+ dobin kismet_capture
+ fi
+}
+
+pkg_preinst() {
+ if use suid; then
+ enewgroup kismet
+ fowners root:kismet /usr/bin/kismet_capture
+ # Need to set the permissions after chowning.
+ # See chown(2)
+ fperms 4550 /usr/bin/kismet_capture
+ elog "Kismet has been installed with a setuid-root helper binary"
+ elog "to enable minimal-root operation. Users need to be part of"
+ elog "the 'kismet' group to perform captures from physical devices."
+ fi
+ if ! use suid; then
+ ewarn "It is highly discouraged to run a sniffer as root,"
+ ewarn "Please consider enabling the suid use flag and adding"
+ ewarn "your user to the kismet group."
+ fi
+}
diff --git a/net-wireless/kismet/metadata.xml b/net-wireless/kismet/metadata.xml
index c596280be249..f9a1efd46a10 100644
--- a/net-wireless/kismet/metadata.xml
+++ b/net-wireless/kismet/metadata.xml
@@ -6,6 +6,7 @@
<name>Rick Farina</name>
</maintainer>
<use>
+ <flag name="client">Build the ncurses-based user interface</flag>
<flag name="libusb">Support libusb based capture sources such as mousejack, cc2540(ble), and nrf51822(ble)</flag>
<flag name="suid">
Install a setuid root helper binary with limited functionality;
@@ -13,7 +14,15 @@
reducing security risks
</flag>
<flag name="pcre">Build with pcre support</flag>
+ <flag name="speech">Audio support using <pkg>app-accessibility/flite</pkg></flag>
+ <flag name="plugin-autowep">Build the autowep plugin</flag>
+ <flag name="plugin-btscan">Build the btscan plugin</flag>
+ <flag name="plugin-dot15d4">Build the dot15d4 plugin</flag>
+ <flag name="plugin-ptw">Build the ptw plugin</flag>
+ <flag name="plugin-spectools">Build the spectools plugin. This uses <pkg>net-wireless/spectools</pkg></flag>
+ <flag name="plugin-syslog">Build the syslog plugin.</flag>
<flag name="rtlsdr">Enable rtlsdr based kismet capture sources</flag>
+ <flag name="ruby">Build extras which are written in ruby, example plugins and the like.</flag>
<flag name="ubertooth">Enable capture source for ubertooth to sniff bluetooth low energy</flag>
</use>
</pkgmetadata>