summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/orinoco-usb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/orinoco-usb')
-rw-r--r--net-wireless/orinoco-usb/metadata.xml5
-rw-r--r--net-wireless/orinoco-usb/orinoco-usb-9999.ebuild42
2 files changed, 47 insertions, 0 deletions
diff --git a/net-wireless/orinoco-usb/metadata.xml b/net-wireless/orinoco-usb/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/net-wireless/orinoco-usb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-wireless/orinoco-usb/orinoco-usb-9999.ebuild b/net-wireless/orinoco-usb/orinoco-usb-9999.ebuild
new file mode 100644
index 000000000000..9c8daca9f5aa
--- /dev/null
+++ b/net-wireless/orinoco-usb/orinoco-usb-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod subversion
+
+ESVN_REPO_URI="http://orinoco.svn.sourceforge.net/svnroot/orinoco/branches/usb"
+
+DESCRIPTION="ORiNOCO IEEE 802.11 wireless LAN driver"
+HOMEPAGE="http://www.nongnu.org/orinoco/"
+SRC_URI=""
+
+LICENSE="GPL-2 MPL-1.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!net-wireless/orinoco-sn
+ net-wireless/wireless-tools
+ net-wireless/orinoco-fwutils"
+
+BUILD_TARGETS="all"
+
+CONFIG_CHECK="FW_LOADER WIRELESS_EXT USB"
+ERROR_FW_LOADER="${P} requires support for loading firmware (CONFIG_FWLOADER)."
+ERROR_WIRELESS_EXT="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_WIRELESS_EXT)."
+ERROR_USB="${P} requires USB support (CONFIG_USB)."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 21; then
+ eerror "${P} requires kernel 2.6.21 or above."
+ die "Kernel version too old."
+ fi
+
+ MOD_PATH="/net/wireless"
+ MODULE_NAMES="orinoco(${MOD_PATH}:) orinoco_usb(${MOD_PATH}:)"
+ BUILD_PARAMS="KERNEL_PATH=${KV_OUT_DIR}"
+}
+
+# Don't have modified install in order to provide docs, since docs are too old