summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-06-12 10:20:08 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-12 10:20:50 -0400
commit0d91ca6832027ca0f8271b57509e331402e8649d (patch)
tree99c851af6a7ad984ff8f8acbbb46d9004280759d /net-wireless/ubertooth
parentdev-python/ujson: Port to py3.9, fix tests (diff)
downloadgentoo-0d91ca6832027ca0f8271b57509e331402e8649d.tar.gz
gentoo-0d91ca6832027ca0f8271b57509e331402e8649d.tar.bz2
gentoo-0d91ca6832027ca0f8271b57509e331402e8649d.zip
net-wireless/ubertooth: fix bug #706598
thanks to Jonas Stein https://github.com/greatscottgadgets/ubertooth/issues/408 https://github.com/greatscottgadgets/ubertooth/pull/409 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/ubertooth')
-rw-r--r--net-wireless/ubertooth/files/ubertooth-2018.12.1-gcc-10.patch23
-rw-r--r--net-wireless/ubertooth/ubertooth-2018.12.1.ebuild12
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild10
3 files changed, 35 insertions, 10 deletions
diff --git a/net-wireless/ubertooth/files/ubertooth-2018.12.1-gcc-10.patch b/net-wireless/ubertooth/files/ubertooth-2018.12.1-gcc-10.patch
new file mode 100644
index 000000000000..b4f25e6b0b8c
--- /dev/null
+++ b/net-wireless/ubertooth/files/ubertooth-2018.12.1-gcc-10.patch
@@ -0,0 +1,23 @@
+From abc1d87631c71fb5bf3be4b81327c66292d852ca Mon Sep 17 00:00:00 2001
+From: Jonas Stein <news@jonasstein.de>
+Date: Sat, 6 Jun 2020 21:11:38 +0200
+Subject: [PATCH] extern packet_counter_max to compile with gcc-10
+
+Fixes: https://github.com/greatscottgadgets/ubertooth/issues/408
+---
+ host/libubertooth/src/ubertooth_callback.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libubertooth/src/ubertooth_callback.c b/libubertooth/src/ubertooth_callback.c
+index a36e3512..adb9934f 100644
+--- a/libubertooth/src/ubertooth_callback.c
++++ b/libubertooth/src/ubertooth_callback.c
+@@ -27,7 +27,7 @@
+
+ #include "ubertooth_callback.h"
+
+-unsigned int packet_counter_max;
++extern unsigned int packet_counter_max;
+
+ static int8_t cc2400_rssi_to_dbm( const int8_t rssi )
+ {
diff --git a/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild b/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
index 845ee09d3793..32189828f352 100644
--- a/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
+++ b/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils udev
+inherit cmake udev
HOMEPAGE="http://ubertooth.sourceforge.net/"
@@ -34,6 +34,8 @@ DESCRIPTION="open source wireless development platform suitable for Bluetooth ex
#readd firmware building, but do it right
#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+PATCHES=( "${FILESDIR}"/"${P}"-gcc-10.patch )
+
src_configure() {
local mycmakeargs=(
-DUSE_BLUEZ=$(usex bluez)
@@ -47,11 +49,11 @@ src_configure() {
-DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/${PN}
pushd "${WORKDIR}/${PN}-${MY_PV}" || die
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index 845ee09d3793..4a9603a7e8d4 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils udev
+inherit cmake udev
HOMEPAGE="http://ubertooth.sourceforge.net/"
@@ -47,11 +47,11 @@ src_configure() {
-DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/${PN}
pushd "${WORKDIR}/${PN}-${MY_PV}" || die