summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/cdsclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/cdsclient')
-rw-r--r--sci-astronomy/cdsclient/Manifest1
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild41
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-makefile.patch102
-rw-r--r--sci-astronomy/cdsclient/metadata.xml11
4 files changed, 155 insertions, 0 deletions
diff --git a/sci-astronomy/cdsclient/Manifest b/sci-astronomy/cdsclient/Manifest
new file mode 100644
index 000000000000..5eff80fecc70
--- /dev/null
+++ b/sci-astronomy/cdsclient/Manifest
@@ -0,0 +1 @@
+DIST cdsclient-3.72.tar.gz 99642 SHA256 517bb13a52c528858faac63f4b3a8180998f71d9fc33e0de9d2480aadd935045 SHA512 88d4b35c05b3565e74ad1bb7e593231486580c58901f90d4a7cc5295d11578b30a4e61579aa1125a4879c940104ed3087d9f97fc8170c01342f09f2b720bd32e WHIRLPOOL ee00668a77fc589dd7d4a3f31ddebdab42d6d2e48e25df2bf42f7ceb9a32543f6af2c643ba96db5ed27f25aea2b209551a54b17720476276de9d84c0a270c2e9
diff --git a/sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild b/sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild
new file mode 100644
index 000000000000..9b085f9a2f36
--- /dev/null
+++ b/sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator
+
+# upstream versioning wrong: 3.71 is really 3.7.1
+MYP="${PN}-$(delete_version_separator 2)"
+
+DESCRIPTION="Collection of scripts to access the CDS databases"
+HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
+SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="mirror bindist"
+DEPEND=""
+RDEPEND="app-shells/tcsh"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-makefile.patch
+ # remove non standard "mantex" page
+ sed -i -e 's/aclient.tex//' configure || die
+}
+
+src_install() {
+ local bindir="${EPREFIX}/usr/bin/${PN}"
+ emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
+ cat <<-EOF > 99${PN}
+ PATH=${bindir}
+ ROOTPATH=${bindir}
+ EOF
+ doenvd 99${PN}
+}
diff --git a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
new file mode 100644
index 000000000000..3f5e5fe58e9a
--- /dev/null
+++ b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
@@ -0,0 +1,102 @@
+--- Makefile.in.orig 2013-07-08 09:45:42.667070273 -0700
++++ Makefile.in 2013-07-08 09:46:43.928417641 -0700
+@@ -29,17 +29,17 @@
+ #################################################################
+ #PREFIX = /usr/local
+ #PREFIX = $(HOME)
+-PREFIX = @prefix@
++PREFIX = $(DESTDIR)@prefix@
+ PACKAGE = cdsclient
+ VERSION = @version@
+ DISTRIB = $(PACKAGE)-$(VERSION)
+ #################################################################
+
+ INCDIR = $(PREFIX)/include
+-LIBDIR = $(PREFIX)/lib
++LIBDIR = $(DESTDIR)/@libdir@
+ BINDIR = $(PREFIX)/bin
+ SHSDIR = $(PREFIX)/bin
+-MANDIR = $(PREFIX)/man
++MANDIR = $(PREFIX)/share/man
+ ###########
+ # NOTE: The definition below is required only on SOLARIS
+ # Comment the following line if required
+@@ -60,7 +60,7 @@
+ DEBUG =
+ C_OPT = -O
+ SYS =
+-CFLAGS = $(C_OPT) $(DEBUG) $(SYS) -I.
++
+
+ # FILES --------------------------------
+ VERFILE = $(PREFIX)/versions
+@@ -98,7 +98,7 @@
+ # RULES --------------------------------
+ .SUFFIXES: .o .c
+ .c.o:
+- $(CC) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) -I. -c $<
+
+ # DEPENDENCIES --------------------------------
+
+@@ -117,41 +117,41 @@
+ # rm -f $$f; ln finducac2 $$f; done
+
+ aclient: aclient.o $(OBJ)
+- $(CC) $@.o $(OBJ) $(LIBSYS) -o $@
+- $(STRIP) $@
++ $(CC) $(LDFLAGS) $@.o $(OBJ) $(LIBSYS) -o $@
++
+
+ wwwget: wwwget.c
+- $(CC) wwwget.c $(LIBSYS) -o $@
+- $(STRIP) $@
++ $(CC) $(CFLAGS) $(LDFLAGS) wwwget.c $(LIBSYS) -o $@
++
+
+ doc: sk.tex man.tex aclient.tex
+ latex man.tex
+
+-install: $(EXPORT_INSTALL) install_shs install_info
++install: $(EXPORT_INSTALL) install_shs
+ rm -rf *.cache
+
+ export_install: install_bin install_man
+
+ install_man: $(MAN)
+ if [ -d $(MANDIR) ]; then echo $(MANDIR) exists; \
+- else mkdir $(MANDIR); fi
++ else mkdir -p $(MANDIR); fi
+ for f in $(MAN); do \
+ e=`echo $$f | cut -d. -f2`; \
+ if [ -d $(MANDIR)/man$$e ] ; then echo $(MANDIR)/man$$e exists ; \
+- else mkdir $(MANDIR)/man$$e ; fi ; \
++ else mkdir -p $(MANDIR)/man$$e ; fi ; \
+ $(COPY) $$f $(MANDIR)/man$$e ; \
+ done
+
+ install_h: $(INC)
+- test -d $(INCDIR) || mkdir $(INCDIR)
++ test -d $(INCDIR) || mkdir -p $(INCDIR)
+ $(COPY) $(INC) $(INCDIR)
+
+ install_bin: $(BIN)
+- test -d $(BINDIR) || mkdir $(BINDIR)
++ test -d $(BINDIR) || mkdir -p $(BINDIR)
+ $(COPY) $(BIN) $(BINDIR)
+
+ install_shs: Makefile
+- test -d $(SHSDIR) || mkdir $(SHSDIR)
++ test -d $(SHSDIR) || mkdir -p $(SHSDIR)
+ ractools=""; test -r $(RACatCDS) && ractools=$(RACatCDS)/*; \
+ test -z "$$ractools" || ls -l $$ractools; \
+ cdsutil="$(SHSatCDS)"; test -z "$(atCDS)" && cdsutil=""; \
+@@ -189,7 +189,7 @@
+ $(MAKE) clean
+ -test -d /tmp/$(DISTRIB) && rm -rf /tmp/$(DISTRIB)
+ autoconf
+- mkdir /tmp/$(DISTRIB)
++ mkdir -p /tmp/$(DISTRIB)
+ cp -p $(SHS) Makefile.in configure /tmp/$(DISTRIB)
+ test -z "$(atCDS)" || cp -p $(SHSatCDS) /tmp/$(DISTRIB)
+
diff --git a/sci-astronomy/cdsclient/metadata.xml b/sci-astronomy/cdsclient/metadata.xml
new file mode 100644
index 000000000000..a084fd41b97b
--- /dev/null
+++ b/sci-astronomy/cdsclient/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ The cdsclient package is a set of C and csh routines which can be
+ built on Unix stations or PCs running Linux, which once compiled allow
+ to query some databases located at Centre de Donnees astronomiques
+ de Strasbourg (CDS) or on mirrors over the network.
+</longdescription>
+</pkgmetadata>