summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-26 18:12:46 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-27 03:14:25 +0000
commit878c84ae5cb567acaf8a04821436e57bbba59512 (patch)
tree34798511fafd23cac1c0d44717be8f41eac7a203 /sci-astronomy/cdsclient
parentdev-python/flask-socketio: remove old versions (diff)
downloadgentoo-878c84ae5cb567acaf8a04821436e57bbba59512.tar.gz
gentoo-878c84ae5cb567acaf8a04821436e57bbba59512.tar.bz2
gentoo-878c84ae5cb567acaf8a04821436e57bbba59512.zip
sci-astronomy/cdsclient: Version bump and cleanup
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/cdsclient')
-rw-r--r--sci-astronomy/cdsclient/Manifest2
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild (renamed from sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild)9
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-makefile.patch40
3 files changed, 28 insertions, 23 deletions
diff --git a/sci-astronomy/cdsclient/Manifest b/sci-astronomy/cdsclient/Manifest
index 5eff80fecc70..33ac3483caa3 100644
--- a/sci-astronomy/cdsclient/Manifest
+++ b/sci-astronomy/cdsclient/Manifest
@@ -1 +1 @@
-DIST cdsclient-3.72.tar.gz 99642 SHA256 517bb13a52c528858faac63f4b3a8180998f71d9fc33e0de9d2480aadd935045 SHA512 88d4b35c05b3565e74ad1bb7e593231486580c58901f90d4a7cc5295d11578b30a4e61579aa1125a4879c940104ed3087d9f97fc8170c01342f09f2b720bd32e WHIRLPOOL ee00668a77fc589dd7d4a3f31ddebdab42d6d2e48e25df2bf42f7ceb9a32543f6af2c643ba96db5ed27f25aea2b209551a54b17720476276de9d84c0a270c2e9
+DIST cdsclient-3.81.tar.gz 122719 SHA256 d74dca1d450e2c8f187e3d7c4952ac480a8913da799f5522a42ea7d5075e339d SHA512 3fcf7a902dfddb3583ff34eedbcddd6a5641bf9c87d234159090378436ac370313ea311d3fee6e202ee84b3fe4065ef45a46a15b5d996e05afd1418e617c20ea WHIRLPOOL 350a5d3bff06fbe15105b9f60c4d8266dda15974b32f01b19ec8aca05fb1e830298dc9f885088f58d4ddf6685da84579db908a68f15fe7bb64165684a2d8cd58
diff --git a/sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild
index 9b085f9a2f36..15584088baff 100644
--- a/sci-astronomy/cdsclient/cdsclient-3.7.2.ebuild
+++ b/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils versionator
@@ -24,10 +24,11 @@ RDEPEND="app-shells/tcsh"
S="${WORKDIR}/${MYP}"
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-makefile.patch
+ default
# remove non standard "mantex" page
- sed -i -e 's/aclient.tex//' configure || die
+ sed -e 's/aclient.tex//' -i configure || die
}
src_install() {
diff --git a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
index 3f5e5fe58e9a..6d135a622056 100644
--- a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
+++ b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2013-07-08 09:45:42.667070273 -0700
-+++ Makefile.in 2013-07-08 09:46:43.928417641 -0700
-@@ -29,17 +29,17 @@
+--- cdsclient-3.81/Makefile.in.orig 2016-02-26 17:33:14.217750589 +0000
++++ cdsclient-3.81/Makefile.in 2016-02-26 17:38:22.463875411 +0000
+@@ -31,17 +31,17 @@
#################################################################
#PREFIX = /usr/local
#PREFIX = $(HOME)
@@ -21,7 +21,13 @@
###########
# NOTE: The definition below is required only on SOLARIS
# Comment the following line if required
-@@ -60,7 +60,7 @@
+@@ -57,12 +57,13 @@
+ COPY = cp -p
+ RM = rm
+ AWK = @AWK@
++MKDIR = mkdir -p
+
+ # C options --------------------------------
DEBUG =
C_OPT = -O
SYS =
@@ -30,7 +36,7 @@
# FILES --------------------------------
VERFILE = $(PREFIX)/versions
-@@ -98,7 +98,7 @@
+@@ -102,7 +103,7 @@
# RULES --------------------------------
.SUFFIXES: .o .c
.c.o:
@@ -39,20 +45,18 @@
# DEPENDENCIES --------------------------------
-@@ -117,41 +117,41 @@
+@@ -121,41 +122,39 @@
# rm -f $$f; ln finducac2 $$f; done
aclient: aclient.o $(OBJ)
- $(CC) $@.o $(OBJ) $(LIBSYS) -o $@
- $(STRIP) $@
+ $(CC) $(LDFLAGS) $@.o $(OBJ) $(LIBSYS) -o $@
-+
wwwget: wwwget.c
- $(CC) wwwget.c $(LIBSYS) -o $@
- $(STRIP) $@
+ $(CC) $(CFLAGS) $(LDFLAGS) wwwget.c $(LIBSYS) -o $@
-+
doc: sk.tex man.tex aclient.tex
latex man.tex
@@ -66,37 +70,37 @@
install_man: $(MAN)
if [ -d $(MANDIR) ]; then echo $(MANDIR) exists; \
- else mkdir $(MANDIR); fi
-+ else mkdir -p $(MANDIR); fi
++ else $(MKDIR) $(MANDIR); fi
for f in $(MAN); do \
e=`echo $$f | cut -d. -f2`; \
if [ -d $(MANDIR)/man$$e ] ; then echo $(MANDIR)/man$$e exists ; \
- else mkdir $(MANDIR)/man$$e ; fi ; \
-+ else mkdir -p $(MANDIR)/man$$e ; fi ; \
++ else $(MKDIR) $(MANDIR)/man$$e ; fi ; \
$(COPY) $$f $(MANDIR)/man$$e ; \
done
install_h: $(INC)
- test -d $(INCDIR) || mkdir $(INCDIR)
-+ test -d $(INCDIR) || mkdir -p $(INCDIR)
++ test -d $(INCDIR) || $(MKDIR) $(INCDIR)
$(COPY) $(INC) $(INCDIR)
install_bin: $(BIN)
- test -d $(BINDIR) || mkdir $(BINDIR)
-+ test -d $(BINDIR) || mkdir -p $(BINDIR)
++ test -d $(BINDIR) || $(MKDIR) $(BINDIR)
$(COPY) $(BIN) $(BINDIR)
install_shs: Makefile
- test -d $(SHSDIR) || mkdir $(SHSDIR)
-+ test -d $(SHSDIR) || mkdir -p $(SHSDIR)
++ test -d $(SHSDIR) || $(MKDIR) $(SHSDIR)
ractools=""; test -r $(RACatCDS) && ractools=$(RACatCDS)/*; \
test -z "$$ractools" || ls -l $$ractools; \
cdsutil="$(SHSatCDS)"; test -z "$(atCDS)" && cdsutil=""; \
-@@ -189,7 +189,7 @@
+@@ -195,7 +194,7 @@
$(MAKE) clean
-test -d /tmp/$(DISTRIB) && rm -rf /tmp/$(DISTRIB)
autoconf
- mkdir /tmp/$(DISTRIB)
-+ mkdir -p /tmp/$(DISTRIB)
- cp -p $(SHS) Makefile.in configure /tmp/$(DISTRIB)
- test -z "$(atCDS)" || cp -p $(SHSatCDS) /tmp/$(DISTRIB)
-
++ $(MKDIR) /tmp/$(DISTRIB)
+ cp -p COPYRIGHT /ftp/pub/sw/COPYING /tmp/$(DISTRIB)
+ for f in $(SHS) Makefile.in configure; do cp -p $$f /tmp/$(DISTRIB); \
+ add_license $$f > /tmp/$(DISTRIB)/$$f; done