summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-02-24 19:41:48 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-03-08 16:13:09 +0200
commit49f0eeee961ff1ae0abc636c942f2df69160b8ee (patch)
tree23ab8d514cc16c911f4f1f838580e2de0be6d4d3 /sci-astronomy
parentdev-libs/libbytesize: support python3_11 in libbytesize-2.7.ebuild (diff)
downloadgentoo-49f0eeee961ff1ae0abc636c942f2df69160b8ee.tar.gz
gentoo-49f0eeee961ff1ae0abc636c942f2df69160b8ee.tar.bz2
gentoo-49f0eeee961ff1ae0abc636c942f2df69160b8ee.zip
sci-astronomy/siril: add 1.2.0beta1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/siril/Manifest1
-rw-r--r--sci-astronomy/siril/files/siril-1.2-execinfo.patch46
-rw-r--r--sci-astronomy/siril/files/siril-1.2-htmesh.patch57
-rw-r--r--sci-astronomy/siril/files/siril-1.2-prototypes.patch41
-rw-r--r--sci-astronomy/siril/siril-1.2.0_beta1.ebuild91
-rw-r--r--sci-astronomy/siril/siril-9999.ebuild7
6 files changed, 241 insertions, 2 deletions
diff --git a/sci-astronomy/siril/Manifest b/sci-astronomy/siril/Manifest
index d4becddf7d18..fd8857b936e7 100644
--- a/sci-astronomy/siril/Manifest
+++ b/sci-astronomy/siril/Manifest
@@ -1,2 +1,3 @@
DIST siril-1.0.5.tar.bz2 2893026 BLAKE2B f8a726962893e90b12c3dfef507652ab7b40ea0be2128ac29d056acb30e827ef35e6671788a8c254d9ea64cc39c8dae00c1e532ed3d6b3a1396ca92da333fe05 SHA512 f2bd614cf14b6b35f458dd75ba4e64db17d051fc9ac36c12e8b1ecdc4c79a19c6427464f3ebb946de80e00d66ed82451f36405c0a7d806332e1b2ce7a835891f
DIST siril-1.0.6.tar.bz2 2893872 BLAKE2B 1f254dcb774c4bfb14fee4626d40e6eeedf866a7a96dca98502cd84e66b973c2201b1f88e2efcb89ce3401b13bd87a319b2ff11e7ba100d0689c9df429d01957 SHA512 afb5f1768a5884adcc13f2afd6fa386d836df5a1385b916df9df8da1fb464e0c8738123fb485ed92c749e596c744d5252a66444b840223488a0860e9324c4e9d
+DIST siril-1.2.0-beta1.tar.bz2 3869827 BLAKE2B 4ba624e917234f389f3ac1f2baf7519aacf4da6494ff437491103491dcac60ff146665faf0daf700a4d2e375d098b3b9af75c60975b882600ab96700a4dff166 SHA512 e259f46e2792d59f53d1e9e5fd3b33c6a912a9c19b53c4d84a803f153e1c5c4395f2fb413a21887330f41e06b7d62996162e65e73774faadb47ff7edc9f4150d
diff --git a/sci-astronomy/siril/files/siril-1.2-execinfo.patch b/sci-astronomy/siril/files/siril-1.2-execinfo.patch
new file mode 100644
index 000000000000..82f29b290f63
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-execinfo.patch
@@ -0,0 +1,46 @@
+From 6f959a02d27fb507cda1898a3aa785766e77d404 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Mon, 27 Feb 2023 17:34:43 +0100
+Subject: [PATCH] fix HAVE_EXECINFO_H logic
+Bug: https://bugs.gentoo.org/898108
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/442
+
+---
+ src/core/signals.c | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/core/signals.c b/src/core/signals.c
+index 42b369d6..d4745909 100644
+--- a/src/core/signals.c
++++ b/src/core/signals.c
+@@ -55,13 +55,7 @@ static void signal_handled(int s) {
+ g_printf(ANSI_COLOR_RED"%s"ANSI_COLOR_RESET"\n", visit);
+ }
+
+-#if (!defined _WIN32 && defined HAVE_EXECINFO_H)
+- void *stack[STACK_DEPTH];
+-
+- size_t size = backtrace(stack, sizeof(stack) / sizeof(void*));
+-
+- backtrace_symbols_fd(stack, size, fileno((FILE*) stdout));
+-#else
++#ifdef _WIN32
+ unsigned int i;
+ void *stack[STACK_DEPTH];
+ unsigned short size;
+@@ -84,6 +78,12 @@ static void signal_handled(int s) {
+ }
+
+ free(symbol);
++#elif HAVE_EXECINFO_H
++ void *stack[STACK_DEPTH];
++
++ size_t size = backtrace(stack, sizeof(stack) / sizeof(void*));
++
++ backtrace_symbols_fd(stack, size, fileno((FILE*) stdout));
+ #endif
+ }
+ undo_flush();
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/files/siril-1.2-htmesh.patch b/sci-astronomy/siril/files/siril-1.2-htmesh.patch
new file mode 100644
index 000000000000..83f389267c40
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-htmesh.patch
@@ -0,0 +1,57 @@
+From 915d01b7e94ff0a597685976838ab707917428db Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Fri, 24 Feb 2023 19:00:52 +0100
+Subject: [PATCH] Don't install bundled htmesh static library system wide.
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/438
+
+---
+ subprojects/htmesh/CMakeLists.txt | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/subprojects/htmesh/CMakeLists.txt b/subprojects/htmesh/CMakeLists.txt
+index 5c197a9e..189acd3e 100644
+--- a/subprojects/htmesh/CMakeLists.txt
++++ b/subprojects/htmesh/CMakeLists.txt
+@@ -49,9 +49,10 @@ set_target_properties(htmesh PROPERTIES
+ VERSION 1.0.0
+ SOVERSION 1)
+
+-if (NOT ANDROID)
+- install(TARGETS htmesh ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
+-endif ()
++# It is not necessary to install the static library as we just link against it.
++#if (NOT ANDROID)
++# install(TARGETS htmesh ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
++#endif ()
+
+ # If you wish to compile the HTMesh perl wrapper, uncomment this, rebuild and copy the library into /usr/lib/, because we will use it as a shared object. See README in the perl wrapper directory (kstars/kstars/data/tools/HTMesh-*) for more details.
+ #set_property(TARGET htmesh PROPERTY POSITION_INDEPENDENT_CODE YES)
+--
+2.39.2
+
+From 42a12b852f4146aa104350587c456a35501a9707 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Fri, 24 Feb 2023 18:40:26 +0100
+Subject: [PATCH] Fix typo in htmesh build configuration
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/437
+
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 886f3697..1ed39a98 100644
+--- a/meson.build
++++ b/meson.build
+@@ -270,7 +270,7 @@ endif
+ htmesh_dep = sub_proj.dependency('htmesh')
+ htmesh_inc = sub_proj.include_directories('htmesh')
+ else
+- siril_cpp_flag += '-DHAVE_LIBRTPROCESS'
++ siril_cpp_flag += '-DHAVE_HTMESH'
+ endif
+
+ ## Optional dependencies
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/files/siril-1.2-prototypes.patch b/sci-astronomy/siril/files/siril-1.2-prototypes.patch
new file mode 100644
index 000000000000..8b72fef41b49
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-prototypes.patch
@@ -0,0 +1,41 @@
+From 6c06d62579234e1d0030bad985a9cfcf7249b5d7 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Mon, 27 Feb 2023 17:49:41 +0100
+Subject: [PATCH 1/2] fix prototypes for functions with parameters
+Bug: https://bugs.gentoo.org/898108
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/443
+
+---
+ src/core/processing.h | 2 +-
+ src/gui/save_dialog.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/core/processing.h b/src/core/processing.h
+index 1eba970b..89f24bd3 100644
+--- a/src/core/processing.h
++++ b/src/core/processing.h
+@@ -162,7 +162,7 @@ void wait_for_script_thread();
+ gboolean end_generic(gpointer arg);
+ guint siril_add_idle(GSourceFunc idle_function, gpointer data);
+
+-struct generic_seq_args *create_default_seqargs();
++struct generic_seq_args *create_default_seqargs(sequence *seq);
+
+ int check_threading(threading_type *threads);
+ int limit_threading(threading_type *threads, int min_iterations_per_thread, size_t total_iterations);
+diff --git a/src/gui/save_dialog.h b/src/gui/save_dialog.h
+index c724abb1..586a2ca3 100644
+--- a/src/gui/save_dialog.h
++++ b/src/gui/save_dialog.h
+@@ -20,7 +20,7 @@ enum {
+ };
+
+ void on_header_save_as_button_clicked();
+-void on_header_snapshot_button_clicked();
++void on_header_snapshot_button_clicked(gboolean clipboard);
+ void on_header_save_button_clicked();
+
+ #endif /* SRC_GUI_SAVE_DIALOG_H_ */
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/siril-1.2.0_beta1.ebuild b/sci-astronomy/siril/siril-1.2.0_beta1.ebuild
new file mode 100644
index 000000000000..6ff7d1f45806
--- /dev/null
+++ b/sci-astronomy/siril/siril-1.2.0_beta1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature toolchain-funcs xdg
+
+DESCRIPTION="A free astronomical image processing software"
+HOMEPAGE="https://www.siril.org/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/free-astro/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/free-astro/siril/-/archive/${PV/_/-}/${PN}-${PV/_/-}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+LICENSE="GPL-3+ Boost-1.0"
+SLOT="0"
+IUSE="curl ffmpeg heif jpeg libconfig openmp png raw tiff wcs"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/json-glib-1.2.6
+ dev-libs/sleef:=
+ >=media-gfx/exiv2-0.25
+ media-libs/librtprocess:=
+ >=media-libs/opencv-4.4.0:=
+ sci-libs/cfitsio
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.20.0:3
+ curl? ( net-misc/curl )
+ ffmpeg? ( media-video/ffmpeg:= )
+ heif? ( media-libs/libheif )
+ libconfig? ( >=dev-libs/libconfig-1.4[cxx] )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.6.0 )
+ raw? ( media-libs/libraw )
+ tiff? ( media-libs/tiff:= )
+ wcs? ( >=sci-astronomy/wcslib-7.7 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docfiles.patch"
+ "${FILESDIR}/${PN}-$(ver_cut 1-2)-htmesh.patch"
+ "${FILESDIR}/${PN}-$(ver_cut 1-2)-execinfo.patch"
+ "${FILESDIR}/${PN}-$(ver_cut 1-2)-prototypes.patch"
+)
+
+DOCS=( README.md NEWS ChangeLog AUTHORS )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dffms2=false
+ -Dcriterion=false
+ $(meson_use ffmpeg)
+ $(meson_use heif libheif)
+ $(meson_use jpeg libjpeg)
+ $(meson_use libconfig)
+ $(meson_use openmp)
+ $(meson_use png libpng)
+ $(meson_use raw libraw)
+ $(meson_use tiff libtiff)
+ $(meson_use wcs wcslib)
+ $(usex curl -Denable-libcurl=yes -Denable-libcurl=no)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ optfeature "gnuplot support" sci-visualization/gnuplot
+}
diff --git a/sci-astronomy/siril/siril-9999.ebuild b/sci-astronomy/siril/siril-9999.ebuild
index 40c1b926aa34..eeffd9b1d7ed 100644
--- a/sci-astronomy/siril/siril-9999.ebuild
+++ b/sci-astronomy/siril/siril-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://gitlab.com/free-astro/${PN}.git"
else
SRC_URI="https://gitlab.com/free-astro/siril/-/archive/${PV/_/-}/${PN}-${PV/_/-}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-${PV/_/-}"
fi
@@ -24,6 +24,7 @@ IUSE="curl ffmpeg heif jpeg libconfig openmp png raw tiff wcs"
DEPEND="
>=dev-libs/glib-2.56.0:2
>=dev-libs/json-glib-1.2.6
+ dev-libs/sleef:=
>=media-gfx/exiv2-0.25
media-libs/librtprocess:=
>=media-libs/opencv-4.4.0:=
@@ -45,6 +46,7 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+BDEPEND="x11-base/xorg-proto"
PATCHES=(
"${FILESDIR}/${PN}-docfiles.patch"
@@ -80,6 +82,7 @@ src_configure() {
pkg_postinst() {
xdg_desktop_database_update
+ xdg_icon_cache_update
xdg_mimeinfo_database_update
optfeature "gnuplot support" sci-visualization/gnuplot
}