summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-02-27 18:20:56 +0100
committerSam James <sam@gentoo.org>2023-03-25 04:06:10 +0000
commit5721e7de2e4933b397da2c74b20f599575f6c763 (patch)
treebd4d7442a3f07fcbd1db0bc1d35a3dca3c867798 /sci-astronomy
parentsci-astronomy/siril: fix build without OpenMP (diff)
downloadgentoo-5721e7de2e4933b397da2c74b20f599575f6c763.tar.gz
gentoo-5721e7de2e4933b397da2c74b20f599575f6c763.tar.bz2
gentoo-5721e7de2e4933b397da2c74b20f599575f6c763.zip
sci-astronomy/siril: fix build with MUSL
Closes: https://bugs.gentoo.org/898108 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/29837 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/siril/files/siril-1.0-execinfo-r2.patch46
-rw-r--r--sci-astronomy/siril/files/siril-1.0-prototypes.patch41
-rw-r--r--sci-astronomy/siril/siril-1.0.6-r2.ebuild1
3 files changed, 88 insertions, 0 deletions
diff --git a/sci-astronomy/siril/files/siril-1.0-execinfo-r2.patch b/sci-astronomy/siril/files/siril-1.0-execinfo-r2.patch
index ffef786d0d8e..55ce90558b64 100644
--- a/sci-astronomy/siril/files/siril-1.0-execinfo-r2.patch
+++ b/sci-astronomy/siril/files/siril-1.0-execinfo-r2.patch
@@ -6,6 +6,8 @@ Date: Thu Aug 4 00:27:08 2022 +0200
Bug: https://bugs.gentoo.org/873016
Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/284
+Bug: https://bugs.gentoo.org/898108
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/442
diff --git a/src/core/signals.c b/src/core/signals.c
index 74100b3a..0eefd460 100644
@@ -43,3 +45,47 @@ index 0eefd460..bbce5fa7 100644
#include <signal.h>
#ifdef _WIN32
#include <windows.h>
+From 6f959a02d27fb507cda1898a3aa785766e77d404 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Mon, 27 Feb 2023 17:34:43 +0100
+Subject: [PATCH] fix HAVE_EXECINFO_H logic
+
+---
+ src/core/signals.c | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/core/signals.c b/src/core/signals.c
+index 42b369d6..d4745909 100644
+--- a/src/core/signals.c
++++ b/src/core/signals.c
+@@ -55,13 +55,7 @@ static void signal_handled(int s) {
+ g_printf(ANSI_COLOR_RED"%s"ANSI_COLOR_RESET"\n", visit);
+ }
+
+-#if (!defined _WIN32 && defined HAVE_EXECINFO_H)
+- void *stack[STACK_DEPTH];
+-
+- size_t size = backtrace(stack, sizeof(stack) / sizeof(void*));
+-
+- backtrace_symbols_fd(stack, size, fileno((FILE*) stdout));
+-#else
++#ifdef _WIN32
+ unsigned int i;
+ void *stack[STACK_DEPTH];
+ unsigned short size;
+@@ -84,6 +78,12 @@ static void signal_handled(int s) {
+ }
+
+ free(symbol);
++#elif HAVE_EXECINFO_H
++ void *stack[STACK_DEPTH];
++
++ size_t size = backtrace(stack, sizeof(stack) / sizeof(void*));
++
++ backtrace_symbols_fd(stack, size, fileno((FILE*) stdout));
+ #endif
+ }
+ undo_flush();
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/files/siril-1.0-prototypes.patch b/sci-astronomy/siril/files/siril-1.0-prototypes.patch
new file mode 100644
index 000000000000..8b72fef41b49
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.0-prototypes.patch
@@ -0,0 +1,41 @@
+From 6c06d62579234e1d0030bad985a9cfcf7249b5d7 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Mon, 27 Feb 2023 17:49:41 +0100
+Subject: [PATCH 1/2] fix prototypes for functions with parameters
+Bug: https://bugs.gentoo.org/898108
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/443
+
+---
+ src/core/processing.h | 2 +-
+ src/gui/save_dialog.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/core/processing.h b/src/core/processing.h
+index 1eba970b..89f24bd3 100644
+--- a/src/core/processing.h
++++ b/src/core/processing.h
+@@ -162,7 +162,7 @@ void wait_for_script_thread();
+ gboolean end_generic(gpointer arg);
+ guint siril_add_idle(GSourceFunc idle_function, gpointer data);
+
+-struct generic_seq_args *create_default_seqargs();
++struct generic_seq_args *create_default_seqargs(sequence *seq);
+
+ int check_threading(threading_type *threads);
+ int limit_threading(threading_type *threads, int min_iterations_per_thread, size_t total_iterations);
+diff --git a/src/gui/save_dialog.h b/src/gui/save_dialog.h
+index c724abb1..586a2ca3 100644
+--- a/src/gui/save_dialog.h
++++ b/src/gui/save_dialog.h
+@@ -20,7 +20,7 @@ enum {
+ };
+
+ void on_header_save_as_button_clicked();
+-void on_header_snapshot_button_clicked();
++void on_header_snapshot_button_clicked(gboolean clipboard);
+ void on_header_save_button_clicked();
+
+ #endif /* SRC_GUI_SAVE_DIALOG_H_ */
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/siril-1.0.6-r2.ebuild b/sci-astronomy/siril/siril-1.0.6-r2.ebuild
index 5de589b0f985..81e303d7c5dd 100644
--- a/sci-astronomy/siril/siril-1.0.6-r2.ebuild
+++ b/sci-astronomy/siril/siril-1.0.6-r2.ebuild
@@ -51,6 +51,7 @@ PATCHES=(
"${FILESDIR}/${PN}-docfiles.patch"
"${FILESDIR}/${PN}-$(ver_cut 1-2)-dependencies.patch"
"${FILESDIR}/${PN}-$(ver_cut 1-2)-execinfo-r2.patch"
+ "${FILESDIR}/${PN}-$(ver_cut 1-2)-prototypes.patch"
)
DOCS=( README.md NEWS ChangeLog AUTHORS )