summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-03-28 22:43:04 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-03-30 11:03:13 +0200
commit8c4364f44958e7e4edbc3fb36511567199dd3c1e (patch)
tree6557fb4701032d2d5a6102369b02f53abbe38589 /sci-astronomy
parentnet-libs/libnma: add slot op on app-crypt/gcr (diff)
downloadgentoo-8c4364f44958e7e4edbc3fb36511567199dd3c1e.tar.gz
gentoo-8c4364f44958e7e4edbc3fb36511567199dd3c1e.tar.bz2
gentoo-8c4364f44958e7e4edbc3fb36511567199dd3c1e.zip
sci-astronomy/calcmysky: add 0.3.0
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/calcmysky/Manifest1
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.3.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
index 90a19e9a9852..17e08322ce3f 100644
--- a/sci-astronomy/calcmysky/Manifest
+++ b/sci-astronomy/calcmysky/Manifest
@@ -1 +1,2 @@
DIST calcmysky-0.2.1.tar.gz 2161314 BLAKE2B b0aa1abc75f59c9c16429749bb8669e49e17e3dc7716bb78f472a9181c7d77a2c82c2f3800529f620604f233f88855908b0b55d824bf259d0912e157b9537faf SHA512 3915b965ee656b259ce7f158dfdd3c9c11a6c3ff907307899ae55e88ad6c1ccfbec8e0a1f784f5232fb0cb2c8300422fa25b8b1d4d11639d3ebb8c76d67059e5
+DIST calcmysky-0.3.0.tar.gz 2164140 BLAKE2B 18d904ad0ed2ec81d705005fa3fea4e66d7250ff2c46bd563e14c783768760d6cc55ea3376682298d5290516ea3b9bf170da8546da5eafc2d2603e597220d9d4 SHA512 529e9cd3d1e71e5ba3e910e9af44e5ddf1af105b499948325401faa9e0cf7911d8ef003570f5bb5395ff6954c37ae6fd7242eb1300f78636232d745012d495ef
diff --git a/sci-astronomy/calcmysky/calcmysky-0.3.0.ebuild b/sci-astronomy/calcmysky/calcmysky-0.3.0.ebuild
new file mode 100644
index 000000000000..addd6360ca5c
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/15"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}