summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-07-03 22:21:33 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-07-26 10:42:20 +0300
commitb9c4dcec6f94dcac98e69407020c059fa68da600 (patch)
tree06e7a6d63646a60d317f271a24d6ff3c00556c0c /sci-astronomy
parentsci-astronomy/calcmysky: drop 0.2.1 (diff)
downloadgentoo-b9c4dcec6f94dcac98e69407020c059fa68da600.tar.gz
gentoo-b9c4dcec6f94dcac98e69407020c059fa68da600.tar.bz2
gentoo-b9c4dcec6f94dcac98e69407020c059fa68da600.zip
sci-astronomy/calcmysky: add 0.3.1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/calcmysky/Manifest1
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.3.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
index ad314b2cc976..7dd9b9fbeb6a 100644
--- a/sci-astronomy/calcmysky/Manifest
+++ b/sci-astronomy/calcmysky/Manifest
@@ -1 +1,2 @@
DIST calcmysky-0.3.0.tar.gz 2164140 BLAKE2B 18d904ad0ed2ec81d705005fa3fea4e66d7250ff2c46bd563e14c783768760d6cc55ea3376682298d5290516ea3b9bf170da8546da5eafc2d2603e597220d9d4 SHA512 529e9cd3d1e71e5ba3e910e9af44e5ddf1af105b499948325401faa9e0cf7911d8ef003570f5bb5395ff6954c37ae6fd7242eb1300f78636232d745012d495ef
+DIST calcmysky-0.3.1.tar.gz 2166487 BLAKE2B d1e2bf0a5a2118e3679427e705f5265c9d6c8962adb58b4a5a6464252ee10fcba396758ef3a1a8c1e57b2291a076bc034e4231ea21a6fc464eda3c5ffd376bc1 SHA512 3038feffdf3a61d49d39304b72f1c2809ea5e3a835c4b3c1603162802afc3d27af6cdfd63eb3286e9e614850b73e338e1cc2cf6a6e915ea968194c0a7a9a56eb
diff --git a/sci-astronomy/calcmysky/calcmysky-0.3.1.ebuild b/sci-astronomy/calcmysky/calcmysky-0.3.1.ebuild
new file mode 100644
index 000000000000..addd6360ca5c
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.3.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/15"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}