summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:23:57 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 13:48:36 +0000
commitf8c042ae7c7ae2e8bf7a96f1a0e1ae373b6436b8 (patch)
treecfd22d3ba2580c654c166128fac7ac53d0c80886 /sci-astronomy
parentdev-lang/swi-prolog: bump 7.5 development version (diff)
downloadgentoo-f8c042ae7c7ae2e8bf7a96f1a0e1ae373b6436b8.tar.gz
gentoo-f8c042ae7c7ae2e8bf7a96f1a0e1ae373b6436b8.tar.bz2
gentoo-f8c042ae7c7ae2e8bf7a96f1a0e1ae373b6436b8.zip
sci-astronomy/montage: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/montage/Manifest1
-rw-r--r--sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch35
-rw-r--r--sci-astronomy/montage/montage-5.0.ebuild67
3 files changed, 103 insertions, 0 deletions
diff --git a/sci-astronomy/montage/Manifest b/sci-astronomy/montage/Manifest
index 06c81c3914c4..49c8a0f4c247 100644
--- a/sci-astronomy/montage/Manifest
+++ b/sci-astronomy/montage/Manifest
@@ -1 +1,2 @@
+DIST Montage_v5.0.tar.gz 14663443 SHA256 72e034adb77c8a05ac40daf9d1923c66e94faa0b08d3d441256d9058fbc2aa34 SHA512 1396c7f846db4844d2e861622d152f2115ad4c684da02bb14116dfe3d01b559feaf29572663d0dfd234aa50843afaca3bb072d9127fbb2b539a14327c48499ae WHIRLPOOL f5fc9d93d88c95ff079932d9e5f0ed61a0f30bec6bd2df5e50abfce6b171cee1b2b3e6dbed2ad1e65a7c69531b4475d62840b14f299ceffa6e65788cd9812579
DIST montage-4.1.tar.gz 38542751 SHA256 12e463c30de190d6e8e215ef19ee787010194190e3df5ea579b6f3647804a5b4 SHA512 a4e6572c0ce04ca950cb425e2589d85609d037e57c575d4efa67b277cecf5e54a2e6d307914ee99997baaba7c5bdd43c72b1e1893111eacc065785689bfc17fb WHIRLPOOL bfd136b52a9c7b0bdceaaa0110b0476e8cb991c64ab4b646b60250e57f282fbe40c9795cef804b15caf29e0628dcb16157af11a1aa4f7e4f7c66c91f969f6484
diff --git a/sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch b/sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch
new file mode 100644
index 000000000000..42fd94950b84
--- /dev/null
+++ b/sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch
@@ -0,0 +1,35 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Thu, 22 Dec 2016 14:24:44 +0100
+Subject: Fix freetype include path
+
+---
+ MontageLib/Viewer/mViewer_graphics.c | 2 +-
+ util/Viewer/graphics.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/MontageLib/Viewer/mViewer_graphics.c b/MontageLib/Viewer/mViewer_graphics.c
+index 932ca5f..a50281d 100644
+--- a/MontageLib/Viewer/mViewer_graphics.c
++++ b/MontageLib/Viewer/mViewer_graphics.c
+@@ -1,7 +1,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <freetype2/ft2build.h>
+-#include <freetype.h>
++#include FT_FREETYPE_H
+
+ void mViewer_labeledCurve (char *face_path, int fontsize, int showLine,
+ double *xcurve, double *ycurve, int npt,
+diff --git a/util/Viewer/graphics.c b/util/Viewer/graphics.c
+index 6bb7d8d..f7a5215 100644
+--- a/util/Viewer/graphics.c
++++ b/util/Viewer/graphics.c
+@@ -1,7 +1,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <freetype2/ft2build.h>
+-#include <freetype.h>
++#include FT_FREETYPE_H
+
+ void labeled_curve (char *face_path, int fontsize, int showLine,
+ double *xcurve, double *ycurve, int npt,
diff --git a/sci-astronomy/montage/montage-5.0.ebuild b/sci-astronomy/montage/montage-5.0.ebuild
new file mode 100644
index 000000000000..91e67534e2fc
--- /dev/null
+++ b/sci-astronomy/montage/montage-5.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+MYPN=Montage
+
+DESCRIPTION="Toolkit for assembling FITS images into mosaics"
+HOMEPAGE="http://montage.ipac.caltech.edu/"
+SRC_URI="http://montage.ipac.caltech.edu/download/${MYPN}_v${PV}.tar.gz"
+
+LICENSE="BSD GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+IUSE="doc mpi"
+
+RDEPEND="
+ media-libs/freetype:2=
+ sci-astronomy/wcstools:0=
+ sci-libs/cfitsio:0=
+ virtual/jpeg:0
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1-fix_format_errors.patch
+ "${FILESDIR}"/${PN}-4.1-initdistdata.patch
+ "${FILESDIR}"/${PN}-5.0-fix_freetype_incude.patch
+)
+
+S="${WORKDIR}/${MYPN}"
+
+src_prepare() {
+ default
+ sed -e '/cfitsio/d' \
+ -e '/wcssubs/d' \
+ -e '/jpeg/d' \
+ -e '/freetype/d' \
+ -i lib/src/Makefile || die
+
+ tc-export CC AR
+
+ find . -name Makefile\* | xargs sed -i \
+ -e "/^CC.*=/s:\(gcc\|cc\):$(tc-getCC):g" \
+ -e "/^CFLAGS.*=/s:-g:${CFLAGS} $($(tc-getPKG_CONFIG) --cflags wcstools):g" \
+ -e "s:-I../../lib/freetype/include :$($(tc-getPKG_CONFIG) --cflags freetype2):g" \
+ -e 's:$(CC) -o:$(CC) $(LDFLAGS) -o:g' \
+ -e "s:-lwcs:$($(tc-getPKG_CONFIG) --libs wcstools):g" \
+ -e "s:-lcfitsio:$($(tc-getPKG_CONFIG) --libs cfitsio):g" \
+ -e 's:-lnsl::g' \
+ -e "s:ar q:$(tc-getAR) q:g" || die
+
+ if use mpi; then
+ sed -e 's:# MPICC:MPICC:' \
+ -e 's:# BINS:BINS:' \
+ -i Montage/Makefile.* || die
+ fi
+}
+
+src_install () {
+ dobin bin/*
+ dodoc README* ChangeHistory
+ use doc && dodoc -r man/*
+}