summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/ApE
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/ApE')
-rw-r--r--sci-biology/ApE/ApE-2.0.7-r1.ebuild54
-rw-r--r--sci-biology/ApE/Manifest1
-rw-r--r--sci-biology/ApE/metadata.xml10
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-biology/ApE/ApE-2.0.7-r1.ebuild b/sci-biology/ApE/ApE-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..c76b28f8893a
--- /dev/null
+++ b/sci-biology/ApE/ApE-2.0.7-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A Plasmid Editor"
+HOMEPAGE="http://www.biology.utah.edu/jorgensen/wayned/ape/"
+SRC_URI="http://www.biology.utah.edu/jorgensen/wayned/ape/Download/Linux/ApE_linux_current.zip -> ${P}.zip"
+
+LICENSE="ApE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ dev-lang/tcl:0
+ dev-lang/tk:0"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/ApE Linux/"
+
+src_compile() { :; }
+
+src_install() {
+ cat >> "${T}/ApE" <<- "EOF"
+ #!/bin/bash
+ cmdArgs=""
+
+ # AppMain.tcl searches files relative to the directory where it resides.
+ # Add absolute path to file here, if necessary.
+ for rfpath in "$@"; do
+ afpath="$PWD/${rfpath}"
+ if test -r "${afpath}"; then
+ cmdArgs="${cmdArgs} \"${afpath}\"";
+ else
+ cmdArgs="${cmdArgs} \"${rfpath}\"";
+ fi
+ done
+
+ eval exec tclsh "\"/usr/share/ApE-2.0.7/AppMain.tcl\"" "${cmdArgs}"
+ EOF
+
+ dobin "${T}/ApE"
+ insinto "/usr/share/${P}"
+ doins -r "${WORKDIR}"/ApE\ Linux/*
+ make_desktop_entry ${PN} ${PN} \
+ "/usr/share/${P}/Accessory Files/Icons and images/monkey_icon.gif" \
+ "Science"
+}
diff --git a/sci-biology/ApE/Manifest b/sci-biology/ApE/Manifest
new file mode 100644
index 000000000000..c8bc584062a7
--- /dev/null
+++ b/sci-biology/ApE/Manifest
@@ -0,0 +1 @@
+DIST ApE-2.0.7.zip 318454 SHA256 9d718562ef250b68dfad1de7d4179540fc04c001b0fdc5e9bd70f3605561bc32 SHA512 073e3f96badf4888c10a7c7eb453a3775d5bb9136b0bd836d37d1be784847f887e0c68b37325f430eebfb90c2d94021f10d4e8ede92de89b1ab1ddc1ffdbc254 WHIRLPOOL d13e8a997c36f8e7ac951a17c195a714a243292f9a99f524758b09b1fdc9f436b11cf1124ac1a3527ff70aa8cc6dc9ac516a910246f9f6e4f8376c78e8b44013
diff --git a/sci-biology/ApE/metadata.xml b/sci-biology/ApE/metadata.xml
new file mode 100644
index 000000000000..4252fbfae02e
--- /dev/null
+++ b/sci-biology/ApE/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>