summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/elph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/elph')
-rw-r--r--sci-biology/elph/Manifest2
-rw-r--r--sci-biology/elph/elph-0.1.5.ebuild37
-rw-r--r--sci-biology/elph/elph-1.0.1.ebuild28
-rw-r--r--sci-biology/elph/files/elph-0.1.4-usage.patch133
-rw-r--r--sci-biology/elph/files/elph-0.1.5-usage.patch133
-rw-r--r--sci-biology/elph/metadata.xml12
6 files changed, 345 insertions, 0 deletions
diff --git a/sci-biology/elph/Manifest b/sci-biology/elph/Manifest
new file mode 100644
index 000000000000..60015030796d
--- /dev/null
+++ b/sci-biology/elph/Manifest
@@ -0,0 +1,2 @@
+DIST ELPH-0.1.5.tar.gz 153150 RMD160 7e60e2cf9a99cb435768cebbcd1506164e8a901c SHA1 1a3820c851ac0d021c9696ba1fd4eec819d82dbc SHA256 6ffa160f85cb2569bdf869cb0514dc624afcef4f2d8a36efbd1228d1a16cf361
+DIST ELPH-1.0.1.tar.gz 113476 RMD160 854bc34aba30f1c7493536e1b2e36dd8143af7e7 SHA1 9c8bf6ac54ade29daa15dc07aeeb94747626298a SHA256 6d944401d2457d75815a34dbb5780f05df569eb1edfd00909b33c4c4c4ff40b9
diff --git a/sci-biology/elph/elph-0.1.5.ebuild b/sci-biology/elph/elph-0.1.5.ebuild
new file mode 100644
index 000000000000..5fc361ace8fd
--- /dev/null
+++ b/sci-biology/elph/elph-0.1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Estimated Locations of Pattern Hits - Motif finder program"
+LICENSE="Artistic"
+HOMEPAGE="http://cbcb.umd.edu/software/ELPH/"
+SRC_URI="ftp://ftp.cbcb.umd.edu/pub/software/elph/ELPH-${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="x86"
+
+S="${WORKDIR}/ELPH/sources"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-usage.patch
+ sed -i -e "s/CC := g++/CC := $(tc-getCXX)/" \
+ -e "s/-fno-exceptions -fno-rtti -D_REENTRANT -g/${CXXFLAGS}/" \
+ -e "s/LINKER := g++/LINKER := $(tc-getCXX)/" \
+ Makefile || die "Failed to patch Makefile."
+}
+
+src_compile() {
+ make || die "Compilation failed."
+}
+
+src_install() {
+ dobin elph || die "Failed to install program."
+ cd "${WORKDIR}"/ELPH
+ dodoc VERSION || die "Documentation installation failed."
+ newdoc Readme.ELPH README || die "Readme installation failed."
+}
diff --git a/sci-biology/elph/elph-1.0.1.ebuild b/sci-biology/elph/elph-1.0.1.ebuild
new file mode 100644
index 000000000000..78476added83
--- /dev/null
+++ b/sci-biology/elph/elph-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Estimated Locations of Pattern Hits - Motif finder program"
+LICENSE="Artistic"
+HOMEPAGE="http://cbcb.umd.edu/software/ELPH/"
+SRC_URI="ftp://ftp.cbcb.umd.edu/pub/software/elph/ELPH-${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+S=${WORKDIR}/ELPH/sources
+
+src_compile() {
+ emake CC="$(tc-getCXX)" LINKER="$(tc-getCXX)" \
+ CFLAGS="${CXXFLAGS} -D_REENTRANT" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin elph || die "Failed to install program."
+ cd "${WORKDIR}"/ELPH
+ dodoc VERSION || die "Documentation installation failed."
+ newdoc Readme.ELPH README || die "Readme installation failed."
+}
diff --git a/sci-biology/elph/files/elph-0.1.4-usage.patch b/sci-biology/elph/files/elph-0.1.4-usage.patch
new file mode 100644
index 000000000000..be49e2d1ebb8
--- /dev/null
+++ b/sci-biology/elph/files/elph-0.1.4-usage.patch
@@ -0,0 +1,133 @@
+--- elph.cc~ 2003-06-03 14:45:22.000000000 -0400
++++ elph.cc 2004-10-30 10:14:49.220415168 -0400
+@@ -26,11 +26,11 @@
+ period variable\n\
+ -x : print maximum positions within sequences\n\
+ -g : find significance of motif\n\
+- -t <matrix> : test if there is significant difference between the two
+- input files for a given motif matrix; <matrix> is the file
++ -t <matrix> : test if there is significant difference between the two\n\
++ input files for a given motif matrix; <matrix> is the file\n\
+ containing the motif matrix\n\
+- -l : compute Least Likely Consensus (LLC) for given motif
+- -c : in conjunction with -m option: motif is not necessarily in
++ -l : compute Least Likely Consensus (LLC) for given motif\n\
++ -c : in conjunction with -m option: motif is not necessarily in\n\
+ the closest edit distance from input motif\n\
+ LEN=n : n = length of motif\n\
+ ITERNO=n : n = no of iterations to compute the global maximum;\n\
+@@ -41,7 +41,7 @@
+ default = 1000\n\
+ "
+
+-// global variables:
++// global variables:
+ int ITER_NO=10;
+ int MAX_LOOP=500;
+ int printmax=0;
+@@ -66,7 +66,7 @@
+ seqType t;
+
+ GArgs args(argc, argv, "ho:abglvdxt:p:s:m:n:LEN=ITERNO=MAXLOOP=SGFNO=");
+-
++
+ // == Process arguments.
+
+ int e;
+@@ -83,7 +83,7 @@
+
+ if(!testfile.is_empty()) { // if testfile is defined then only compute significance between the two files
+
+- M = new Motif(infile,outf,t,matrixfile,pattern,motiflen,ITER_NO,MAX_LOOP,inlocmax,mdet);
++ M = new Motif(infile,outf,t,matrixfile,pattern,motiflen,ITER_NO,MAX_LOOP,inlocmax,mdet);
+ M->twofilesignif(gdet,testfile,SignifNo,print,pattern);
+
+ }
+@@ -93,11 +93,11 @@
+ // given motif
+
+ M = new Motif(infile,outf,t,pattern);
+- if(defLLC) {
++ if(defLLC) {
+ double llc=M->computeLLC(pattern,print);
+ fprintf(outf,"LLC = %f\n",llc);
+ }
+-
++
+ }
+ else {
+
+@@ -108,7 +108,7 @@
+ }
+
+ double globAlignProb;
+-
++
+ globAlignProb=M->findMotif(ITER_NO,MAX_LOOP,inlocmax,1,mdet);
+
+
+@@ -116,13 +116,13 @@
+ /*info=M->InfoPar(globAlignProb);
+ fprintf(outf,"MAP for motif: %.3f InfoPar=%.3f\n\n",globAlignProb,info);
+ M->printMotif();*/
+-
++
+ // optimizing
+ fprintf(stderr,"Optimizing...\n");
+ globAlignProb=M->optimize(globAlignProb,info,closest);
+ fprintf(outf,"\n\n**********************\n\nMotif after optimizing\n");
+ fprintf(outf,"MAP for motif: %.3f InfoPar=%.3f\n\n",globAlignProb,M->InfoPar(globAlignProb));
+-
++
+ if(runsignif) {
+ M->runforsignif(SignifNo,print,gdet,pattern);
+ }
+@@ -134,17 +134,17 @@
+
+ seqType Process_Options(GArgs* args)
+ {
+-
+- if (args->startNonOpt()) { //parse the non-options arguments
++
++ if (args->startNonOpt()) { //parse the non-options arguments
+ //(usually filenames)
+ infile=args->nextNonOpt();
+ }
+
+- if (infile.is_empty() || args->getOpt('h')!=NULL)
++ if (infile.is_empty() || args->getOpt('h')!=NULL)
+ GError("%s",usage); // the empty test is optional you can ignore it if you accept stdin input
+
+ testfile=args->nextNonOpt();
+-
++
+ GString outfile=args->getOpt('o');
+ if (!outfile.is_empty()) {
+ outf=fopen(outfile, "w");
+@@ -156,7 +156,7 @@
+ matrixfile=args->getOpt('t');
+
+ GString param;
+-
++
+ pattern=args->getOpt('m');
+ if(pattern.is_empty()) {
+ param=args->getOpt("LEN");
+@@ -200,7 +200,7 @@
+
+ seqType t;
+ if(args->getOpt('a')!=NULL) t=aac; else t=nucl;
+-
++
+ return(t);
+
+ }
+@@ -210,7 +210,7 @@
+ Motif *M;
+
+ double llcmax=-HUGE_VAL;
+- GString seed;
++ GString seed;
+ for(int i1=0;i1<4;i1++)
+ for(int i2=0;i2<4;i2++)
+ for(int i3=0;i3<4;i3++)
diff --git a/sci-biology/elph/files/elph-0.1.5-usage.patch b/sci-biology/elph/files/elph-0.1.5-usage.patch
new file mode 100644
index 000000000000..139b83c1c1c6
--- /dev/null
+++ b/sci-biology/elph/files/elph-0.1.5-usage.patch
@@ -0,0 +1,133 @@
+--- elph.cc.old 2005-01-11 14:17:47.000000000 -0500
++++ elph.cc 2005-01-27 19:42:30.218350552 -0500
+@@ -26,11 +26,11 @@
+ period variable\n\
+ -x : print maximum positions within sequences\n\
+ -g : find significance of motif\n\
+- -t <matrix> : test if there is significant difference between the two
+- input files for a given motif matrix; <matrix> is the file
++ -t <matrix> : test if there is significant difference between the two\n\
++ input files for a given motif matrix; <matrix> is the file\n\
+ containing the motif matrix\n\
+- -l : compute Least Likely Consensus (LLC) for given motif
+- -c : in conjunction with -m option: motif is not necessarily in
++ -l : compute Least Likely Consensus (LLC) for given motif\n\
++ -c : in conjunction with -m option: motif is not necessarily in\n\
+ the closest edit distance from input motif\n\
+ LEN=n : n = length of motif\n\
+ ITERNO=n : n = no of iterations to compute the global maximum;\n\
+@@ -41,7 +41,7 @@
+ default = 1000\n\
+ "
+
+-// global variables:
++// global variables:
+ int ITER_NO=10;
+ int MAX_LOOP=500;
+ int printmax=0;
+@@ -66,7 +66,7 @@
+ seqType t;
+
+ GArgs args(argc, argv, "ho:abcglvdxt:p:s:m:n:LEN=ITERNO=MAXLOOP=SGFNO=");
+-
++
+ // == Process arguments.
+
+ int e;
+@@ -83,7 +83,7 @@
+
+ if(!testfile.is_empty()) { // if testfile is defined then only compute significance between the two files
+
+- M = new Motif(infile,outf,t,matrixfile,pattern,motiflen,ITER_NO,MAX_LOOP,inlocmax,mdet);
++ M = new Motif(infile,outf,t,matrixfile,pattern,motiflen,ITER_NO,MAX_LOOP,inlocmax,mdet);
+ M->twofilesignif(gdet,testfile,SignifNo,print,pattern);
+
+ }
+@@ -93,11 +93,11 @@
+ // given motif
+
+ M = new Motif(infile,outf,t,pattern);
+- if(defLLC) {
++ if(defLLC) {
+ double llc=M->computeLLC(pattern,print);
+ fprintf(outf,"LLC = %f\n",llc);
+ }
+-
++
+ }
+ else {
+
+@@ -108,7 +108,7 @@
+ }
+
+ double globAlignProb;
+-
++
+ globAlignProb=M->findMotif(ITER_NO,MAX_LOOP,inlocmax,1,mdet);
+
+
+@@ -116,13 +116,13 @@
+ /*info=M->InfoPar(globAlignProb);
+ fprintf(outf,"MAP for motif: %.3f InfoPar=%.3f\n\n",globAlignProb,info);
+ M->printMotif();*/
+-
++
+ // optimizing
+ fprintf(stderr,"Optimizing...\n");
+ globAlignProb=M->optimize(globAlignProb,info,closest);
+ fprintf(outf,"\n\n**********************\n\nMotif after optimizing\n");
+ fprintf(outf,"MAP for motif: %.3f InfoPar=%.3f\n\n",globAlignProb,M->InfoPar(globAlignProb));
+-
++
+ if(runsignif) {
+ M->runforsignif(SignifNo,print,gdet,pattern);
+ }
+@@ -134,17 +134,17 @@
+
+ seqType Process_Options(GArgs* args)
+ {
+-
+- if (args->startNonOpt()) { //parse the non-options arguments
++
++ if (args->startNonOpt()) { //parse the non-options arguments
+ //(usually filenames)
+ infile=args->nextNonOpt();
+ }
+
+- if (infile.is_empty() || args->getOpt('h')!=NULL)
++ if (infile.is_empty() || args->getOpt('h')!=NULL)
+ GError("%s",usage); // the empty test is optional you can ignore it if you accept stdin input
+
+ testfile=args->nextNonOpt();
+-
++
+ GString outfile=args->getOpt('o');
+ if (!outfile.is_empty()) {
+ outf=fopen(outfile, "w");
+@@ -156,7 +156,7 @@
+ matrixfile=args->getOpt('t');
+
+ GString param;
+-
++
+ pattern=args->getOpt('m');
+ if(pattern.is_empty()) {
+ param=args->getOpt("LEN");
+@@ -200,7 +200,7 @@
+
+ seqType t;
+ if(args->getOpt('a')!=NULL) t=aac; else t=nucl;
+-
++
+ return(t);
+
+ }
+@@ -210,7 +210,7 @@
+ Motif *M;
+
+ double llcmax=-HUGE_VAL;
+- GString seed;
++ GString seed;
+ for(int i1=0;i1<4;i1++)
+ for(int i2=0;i2<4;i2++)
+ for(int i3=0;i3<4;i3++)
diff --git a/sci-biology/elph/metadata.xml b/sci-biology/elph/metadata.xml
new file mode 100644
index 000000000000..469879ba8f5b
--- /dev/null
+++ b/sci-biology/elph/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ ELPH is a general-purpose Gibbs sampler for finding motifs in a set of
+ DNA or protein sequences. The program takes as input a set containing
+ anywhere from a few dozen to thousands of sequences, and searches
+ through them for the most common motif, assuming that each sequence
+ contains one copy of the motif.
+ </longdescription>
+</pkgmetadata>