summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/eugene
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/eugene')
-rw-r--r--sci-biology/eugene/Manifest1
-rw-r--r--sci-biology/eugene/eugene-4.1.ebuild37
-rw-r--r--sci-biology/eugene/files/eugene-3.6-overflow.patch13
-rw-r--r--sci-biology/eugene/files/eugene-3.6-plugins.patch43
-rw-r--r--sci-biology/eugene/files/eugene-4.1-format-security.patch16
-rw-r--r--sci-biology/eugene/metadata.xml5
6 files changed, 115 insertions, 0 deletions
diff --git a/sci-biology/eugene/Manifest b/sci-biology/eugene/Manifest
new file mode 100644
index 000000000000..015da1fb031b
--- /dev/null
+++ b/sci-biology/eugene/Manifest
@@ -0,0 +1 @@
+DIST eugene-4.1.tar.gz 7393361 SHA256 faff769f68e1ab1fdec61be34ec7fef3c73805734199765ba11cf1ea9c02f800 SHA512 f4bcf63103754f8fb577d311d181375732411fa926fb0cef86fcd00c373ed5cc5637f1b55fa375a4bb14c5181f7de1dc244570f74cdd1887b6107d5c6cea37b3 WHIRLPOOL 32f4539456c243dd3c6a9d5a986fea210e53e5566aaa0849a26f34832957100623570a0814193059420d53e553247584360635706844ed0ec55c4cc65e235ad4
diff --git a/sci-biology/eugene/eugene-4.1.ebuild b/sci-biology/eugene/eugene-4.1.ebuild
new file mode 100644
index 000000000000..088ecc7a1a8b
--- /dev/null
+++ b/sci-biology/eugene/eugene-4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Eukaryotic gene predictor"
+HOMEPAGE="http://www.inra.fr/mia/T/EuGene/"
+SRC_URI="https://mulcyber.toulouse.inra.fr/frs/download.php/1157/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ media-libs/gd[png]
+ media-libs/libpng:0=
+ "
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ # https://mulcyber.toulouse.inra.fr/tracker/index.php?func=detail&aid=1170
+ epatch \
+ "${FILESDIR}"/${PN}-3.6-overflow.patch \
+ "${FILESDIR}"/${PN}-3.6-plugins.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+ sed \
+ -e '/SUBDIRS/ s/doc//' \
+ -e '/INSTALL.*doc/ s/\(.*\)//' \
+ -i Makefile.am || die
+ eautoreconf
+}
diff --git a/sci-biology/eugene/files/eugene-3.6-overflow.patch b/sci-biology/eugene/files/eugene-3.6-overflow.patch
new file mode 100644
index 000000000000..7222530ad771
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-overflow.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=336607
+
+--- eugene-3.6/src/Sensor.cc
++++ eugene-3.6/src/Sensor.cc
+@@ -224,7 +224,7 @@
+ //--------------------------
+ void Signals :: PrintS ()
+ {
+- char t[7];
++ char t[10];
+ char s = '+';
+
+ switch (type) {
diff --git a/sci-biology/eugene/files/eugene-3.6-plugins.patch b/sci-biology/eugene/files/eugene-3.6-plugins.patch
new file mode 100644
index 000000000000..1e910a13d5b1
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-plugins.patch
@@ -0,0 +1,43 @@
+http://bugs.gentoo.org/show_bug.cgi?id=297536
+
+--- eugene-3.6/src/Makefile.am
++++ eugene-3.6/src/Makefile.am
+@@ -20,7 +20,7 @@
+
+ SUBDIRS = Parametrization GDIF . SensorPlugins
+
+-AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\"
++AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\" -DLIB_DIR=\"${libdir}\"
+ AM_CFLAGS =
+
+ bin_PROGRAMS = eugene
+--- eugene-3.6/src/MSensor.cc
++++ eugene-3.6/src/MSensor.cc
+@@ -97,7 +97,7 @@
+ std::string use_name;
+
+ if (!IsInitialized) {
+- PluginsDir = (std::string)PAR.getC("eugene_dir")+"/"+PLUGINS_DIR+"/";
++ PluginsDir = (std::string)LIB_DIR+"/eugene/"+PLUGINS_DIR+"/";
+
+ // On récupère les couples nom de sensor/priorité du .par
+ PAR.ResetIter();
+--- eugene-3.6/Makefile.am
++++ eugene-3.6/Makefile.am
+@@ -125,7 +125,7 @@
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Style
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Javascripts
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Images
+- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) -d $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models/WAM
+@@ -144,6 +144,6 @@
+ $(INSTALL) -m 644 $(srcdir)/web/Images/*jpg $(DESTDIR)/$(pkgdatadir)/web/Images
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.obo $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.par $(DESTDIR)/$(pkgdatadir)/cfg
+- $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) $(srcdir)/Procedures/Eval/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Eval
+ $(INSTALL) $(srcdir)/Procedures/Get/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Get
diff --git a/sci-biology/eugene/files/eugene-4.1-format-security.patch b/sci-biology/eugene/files/eugene-4.1-format-security.patch
new file mode 100644
index 000000000000..e6e4a6cc8bd7
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-4.1-format-security.patch
@@ -0,0 +1,16 @@
+ src/Hits.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Hits.cc b/src/Hits.cc
+index edfe178..b228be6 100755
+--- a/src/Hits.cc
++++ b/src/Hits.cc
+@@ -166,7 +166,7 @@ Hits* Hits::ReadFromFile(FILE* HitFile, int *NumHits, int level, int margin, int
+ while ((read=fscanf(HitFile,"%d %d %d %lf %d %s %d %d %as\n", &deb, &fin,
+ &poids, &evalue, &phase, HitId, &HSPDeb, &HSPFin,HSP)) >= 8)
+ {
+- if (HSP) fprintf(stderr,HSP);
++ if (HSP) fprintf(stderr, "%s", HSP);
+ if (phase < 0 && deb > fin)
+ {
+ int tmp = deb;
diff --git a/sci-biology/eugene/metadata.xml b/sci-biology/eugene/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/eugene/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>