summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/yass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/yass')
-rw-r--r--sci-biology/yass/Manifest1
-rw-r--r--sci-biology/yass/files/1.14-as-needed.patch207
-rw-r--r--sci-biology/yass/metadata.xml9
-rw-r--r--sci-biology/yass/yass-1.14-r1.ebuild36
-rw-r--r--sci-biology/yass/yass-1.14.ebuild22
5 files changed, 275 insertions, 0 deletions
diff --git a/sci-biology/yass/Manifest b/sci-biology/yass/Manifest
new file mode 100644
index 000000000000..d2e3a2dba99c
--- /dev/null
+++ b/sci-biology/yass/Manifest
@@ -0,0 +1 @@
+DIST yass-1.14.tar.gz 235530 SHA256 f23da1c16cf98317ad11c085feede9790401e888a95d486b550f0c081d4c9018
diff --git a/sci-biology/yass/files/1.14-as-needed.patch b/sci-biology/yass/files/1.14-as-needed.patch
new file mode 100644
index 000000000000..e57503801c7a
--- /dev/null
+++ b/sci-biology/yass/files/1.14-as-needed.patch
@@ -0,0 +1,207 @@
+diff --git a/configure.ac b/configure.ac
+index 68453ef..3ecfd21 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,13 +28,11 @@ AC_CHECK_FUNCS([floor memset clock pow sqrt strchr strdup strtol strtoul])
+ dnl 1) threads options
+
+ dnl abc) : with-threads option
+-AC_ARG_WITH(
+- threads,
+- [ --with-threads compile with all threads],
+- [threads="yes"],
+- [threads="no"])
++AC_ARG_ENABLE(
++ [threads],
++ AS_HELP_STRING([--enable-threads], [compile with all threads]))
+
+-if test "$threads" = "yes"; then
++AS_IF([test "x$enable_threads" = "xyes"], [
+ AC_MSG_RESULT(detected cpu parameter: threads);
+
+ dnl pthread library here ? (UNIX system)
+@@ -46,167 +44,25 @@ if test "$threads" = "yes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_PTHREAD],[1],[pthread available on the computer])
+ CFLAGS=" $CFLAGS -DTHREAD_ASSEMBLE_ALIGN -DTHREAD_FORWARD_REVERSE -DTHREAD_QUERY_CHUNK "
+- LDFLAGS="$LDFLAGS -lpthread"
++ LIBS="$LIBS -lpthread"
+ else
+ AC_MSG_RESULT(no : disabling \"--with-threads\" parameter)
+ fi
+-
+-else
+- if test -s /proc/cpuinfo; then
+- AC_MSG_CHECKING(for multi-processor)
+- dnl Multithread advice
+- if test `grep -c '^processor' /proc/cpuinfo` -gt 2; then
+- AC_MSG_RESULT(yes)
+- AC_MSG_RESULT(- try \"configure --with-threads\")
+- else
+- AC_MSG_RESULT(no)
+- fi;
+- fi;
+-fi
+-
+-
+-
+-
+-
+-dnl a) : with-thread-fr option
+-AC_ARG_WITH(
+- thread-fr,
+- [ --with-thread-fr compile with two separate threads for Forward and Reverse sequence],
+- [thread_forward_reverse="yes"],
+- [thread_forward_reverse="no"])
+-
+-if test "$thread_forward_reverse" = "yes"; then
+- AC_MSG_RESULT(detected cpu parameter: thread-fr);
+-
+- dnl pthread library here ? (UNIX system)
+- AC_MSG_CHECKING(for pthread lib)
+- AC_CHECK_LIB(pthread, pthread_create,
+- [have_pthread="yes"],
+- [have_pthread="no"])
+- if test "$have_pthread" = "yes"; then
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_PTHREAD],[1],[pthread available on the computer])
+- CFLAGS=" $CFLAGS -DTHREAD_FORWARD_REVERSE "
+- LDFLAGS="$LDFLAGS -lpthread"
+- else
+- AC_MSG_RESULT(no : disabling \"--with-thread-fr\" parameter)
+- fi
+-
+-else
+- if test -s /proc/cpuinfo; then
+- AC_MSG_CHECKING(for multi-processor)
+- dnl Multithread advice
+- if test `grep -c '^processor' /proc/cpuinfo` -gt 1; then
+- AC_MSG_RESULT(yes)
+- AC_MSG_RESULT(- try \"configure --with-thread-fr\")
+- else
+- AC_MSG_RESULT(no)
+- fi;
+- fi;
+-fi
+-
+-
+-
+-
+-
+-dnl b) : with-thread-aa option
+-AC_ARG_WITH(
+- thread-aa,
+- [ --with-thread-aa compile with two separate threads for Assemble and Align steps],
+- [thread_assemble_align="yes"],
+- [thread_assemble_align="no"])
+-
+-if test "$thread_assemble_align" = "yes"; then
+- AC_MSG_RESULT(detected cpu parameter: thread-aa);
+-
+- dnl pthread library here ? (UNIX system)
+- AC_MSG_CHECKING(for pthread lib)
+- AC_CHECK_LIB(pthread, pthread_create,
+- [have_pthread="yes"],
+- [have_pthread="no"])
+- if test "$have_pthread" = "yes"; then
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_PTHREAD],[1],[pthread available on the computer])
+- CFLAGS=" $CFLAGS -DTHREAD_ASSEMBLE_ALIGN "
+- LDFLAGS="$LDFLAGS -lpthread"
+- else
+- AC_MSG_RESULT(no : disabling \"--with-thread-aa\" parameter)
+- fi
+-
+-else
+- if test -s /proc/cpuinfo; then
+- AC_MSG_CHECKING(for multi-processor)
+- dnl Multithread advice
+- if test `grep -c '^processor' /proc/cpuinfo` -gt 1; then
+- AC_MSG_RESULT(yes)
+- AC_MSG_RESULT(- try \"configure --with-thread-aa\")
+- else
+- AC_MSG_RESULT(no)
+- fi;
+- fi;
+-fi
+-
+-
+-dnl c) : with-thread-qc option
+-AC_ARG_WITH(
+- thread-qc,
+- [ --with-thread-qc compile with threads for the query chunks],
+- [thread_query_chunk="yes"],
+- [thread_query_chunk="no"])
+-
+-if test "$thread_query_chunk" = "yes"; then
+- AC_MSG_RESULT(detected cpu parameter: thread-qc);
+-
+- dnl pthread library here ? (UNIX system)
+- AC_MSG_CHECKING(for pthread lib)
+- AC_CHECK_LIB(pthread, pthread_create,
+- [have_pthread="yes"],
+- [have_pthread="no"])
+- if test "$have_pthread" = "yes"; then
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_PTHREAD],[1],[pthread available on the computer])
+- CFLAGS=" $CFLAGS -DTHREAD_QUERY_CHUNK "
+- LDFLAGS="$LDFLAGS -lpthread"
+- else
+- AC_MSG_RESULT(no : disabling \"--with-thread-qc\" parameter)
+- fi
+-
+-else
+- if test -s /proc/cpuinfo; then
+- AC_MSG_CHECKING(for multi-processor)
+- dnl Multithread advice
+- if test `grep -c '^processor' /proc/cpuinfo` -gt 1; then
+- AC_MSG_RESULT(yes)
+- AC_MSG_RESULT(- try \"configure --with-thread-qc\")
+- else
+- AC_MSG_RESULT(no)
+- fi;
+- fi;
+-fi
+-
+-
+-
++])
+
+ dnl 2) : low-memory option
+-AC_ARG_WITH(
+- low-memory,
+- [ --with-low-memory use less memory, but can miss some repeats],
+- [low_memory="yes"],
+- [low_memory="no"])
++AC_ARG_ENABLE(
++ [lowmemory],
++ AS_HELP_STRING([--enable-lowmemory], [use less memory, but can miss some repeats]))
+
+-if test "$low_memory" = "yes"; then
++AS_IF([test "x$enable_lowmemory" = "xyes"], [
+ AC_MSG_RESULT(detected memory parameter: low memory);
+ CFLAGS=" $CFLAGS -DLOW_MEMORY "
+-else
+- AC_MSG_RESULT(detected memory parameter : plain memory)
+-fi
+-
+-
+-CFLAGS="$CFLAGS -O3 -Wall -ansi -pedantic -funroll-loops -pipe -fomit-frame-pointer "
+-LDFLAGS="$LDFLAGS -lm"
++])
+
+ AC_SUBST(CFLAGS)
+ AC_SUBST(LDFLAGS)
++
+ AM_WITH_DMALLOC
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_FILES([Makefile
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e456f94..8d90ca9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -6,3 +6,4 @@
+ bin_PROGRAMS = yass
+ yass_SOURCES = align.c assemble.c avl.c display.c global_var.c hash.c kword.c list.c main.c prdyn.c proba.c red_black.c regroup.c threads.c tuple.c util.c \
+ align.h assemble.h avl.h display.h global_var.h hash.h kword.h list.h prdyn.h proba.h red_black.h regroup.h threads.h tuple.h util.h
++yass_LDADD = -lm
diff --git a/sci-biology/yass/metadata.xml b/sci-biology/yass/metadata.xml
new file mode 100644
index 000000000000..e4a717e691b2
--- /dev/null
+++ b/sci-biology/yass/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <use>
+ <flag name="dmalloc">Enable debugging with the dmalloc library</flag>
+ <flag name="lowmem">Build for environments with low amounts of memory</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-biology/yass/yass-1.14-r1.ebuild b/sci-biology/yass/yass-1.14-r1.ebuild
new file mode 100644
index 000000000000..6476a839c935
--- /dev/null
+++ b/sci-biology/yass/yass-1.14-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Genomic similarity search with multiple transition constrained spaced seeds"
+HOMEPAGE="http://bioinfo.lifl.fr/yass/"
+SRC_URI="http://bioinfo.lifl.fr/yass/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dmalloc lowmem threads"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dmalloc? ( dev-libs/dmalloc )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ $(use_enable lowmem lowmemory) \
+ $(use_with dmalloc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS || die
+}
diff --git a/sci-biology/yass/yass-1.14.ebuild b/sci-biology/yass/yass-1.14.ebuild
new file mode 100644
index 000000000000..c0d6242a201d
--- /dev/null
+++ b/sci-biology/yass/yass-1.14.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="Genomic similarity search with multiple transition constrained spaced seeds"
+HOMEPAGE="http://bioinfo.lifl.fr/yass/"
+SRC_URI="http://bioinfo.lifl.fr/yass/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS README NEWS
+}