summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-01 18:40:42 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-01 18:40:42 +0200
commitb3c6b97c03059d44b801c71c3ccf7a6165593149 (patch)
tree95d0f1e1aeb45338008245b4957b59e2dd3cfcca /sci-biology
parentsci-biology/bowtie: add 2.4.4 (diff)
downloadgentoo-b3c6b97c03059d44b801c71c3ccf7a6165593149.tar.gz
gentoo-b3c6b97c03059d44b801c71c3ccf7a6165593149.tar.bz2
gentoo-b3c6b97c03059d44b801c71c3ccf7a6165593149.zip
sci-biology/bowtie: drop 2.2.9
Closes: https://bugs.gentoo.org/722870 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bowtie/Manifest1
-rw-r--r--sci-biology/bowtie/bowtie-2.2.9.ebuild61
-rw-r--r--sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch29
3 files changed, 0 insertions, 91 deletions
diff --git a/sci-biology/bowtie/Manifest b/sci-biology/bowtie/Manifest
index 96d35e2bfd23..e62703395825 100644
--- a/sci-biology/bowtie/Manifest
+++ b/sci-biology/bowtie/Manifest
@@ -1,2 +1 @@
-DIST bowtie2-2.2.9-source.zip 5734235 BLAKE2B ec48e09fe05403d1085bb4e0c6ef1325b8912da0a8c942061c34f3381c6dd7ccdcc64c4bcdbb18c1da84ac57e1e34cc866fe79809c33c2769a8d75ecde7d0846 SHA512 ead8f7641f3231638d986f9e500bc4ec7afe1e542048465bfcc2e93e2b2d2e499f0dd8aa5c1e3e21df285c9d195b187682eb7e12be4a408f6c50fb97c0e0a205
DIST bowtie2-2.4.4-source.zip 10515984 BLAKE2B be4ceb9d3155d2a9a1f580e5032251b04b89ce0c8c9c89fc3551b34fe3bd71a683362488be7aad6daef24734c6f95c19223f20e67f198f745c4432381243039c SHA512 1b5dadd7e41b90bb9b05f50bfa171fe219cfd03aa8bb6f800de4baaffeb975eef6efc4fb8b49cb0d18833f74a1741cbe1556b87388f59188e04a55dcee6a02da
diff --git a/sci-biology/bowtie/bowtie-2.2.9.ebuild b/sci-biology/bowtie/bowtie-2.2.9.ebuild
deleted file mode 100644
index 0bacb8ca25d7..000000000000
--- a/sci-biology/bowtie/bowtie-2.2.9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/bowtie2/"
-SRC_URI="mirror://sourceforge/project/${PN}-bio/${PN}2/${PV}/${PN}2-${PV}-source.zip"
-
-LICENSE="GPL-3"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="examples cpu_flags_x86_sse2 +tbb"
-
-RDEPEND="dev-lang/perl
- tbb? ( dev-cpp/tbb )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${PN}2-${PV}"
-
-DOCS=( AUTHORS NEWS TUTORIAL )
-HTML_DOCS=( doc/{manual.html,style.css} )
-PATCHES=( "${FILESDIR}/${PN}-2.2.9-fix-c++14.patch" )
-
-pkg_pretend() {
- if ! use cpu_flags_x86_sse2 ; then
- eerror "This package requires a CPU supporting the SSE2 instruction set."
- die "SSE2 support missing"
- fi
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CXX="$(tc-getCXX)" \
- CFLAGS="" \
- CXXFLAGS="" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS="${CXXFLAGS} -msse2" \
- WITH_TBB="$(usex tbb 1 0)"
-}
-
-src_install() {
- dobin ${PN}2 ${PN}2-*
-
- exeinto /usr/libexec/${PN}2
- doexe scripts/*
-
- newman MANUAL ${PN}2.1
- einstalldocs
-
- if use examples; then
- insinto /usr/share/${PN}2
- doins -r example
- fi
-}
diff --git a/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch b/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch
deleted file mode 100644
index cd2a67b6a52b..000000000000
--- a/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Fix building with C++14, which errors out due to differing semantics between C++98
-and C++14 with regards to allowing destructors to throw exceptions.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=593966
-
---- a/blockwise_sa.h
-+++ b/blockwise_sa.h
-@@ -87,7 +87,11 @@
- _logger(__logger)
- { }
-
-- virtual ~BlockwiseSA() { }
-+ virtual ~BlockwiseSA()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ { }
-
- /**
- * Get the next suffix; compute the next bucket if necessary.
-@@ -216,6 +220,9 @@
- { _randomSrc.init(__seed); reset(); }
-
- ~KarkkainenBlockwiseSA()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- #ifdef WITH_TBB
- tbb_grp.wait();