summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-08-14 12:13:20 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-14 12:13:20 +0200
commit0c455c0a3c92832ef8f651c83cdf4baa1c9b714f (patch)
tree1808aaf7cb1089a9213944ab1918872d9a81fa65 /sci-chemistry
parentsci-chemistry/mopac7: Port to EAPI 8 (diff)
downloadgentoo-0c455c0a3c92832ef8f651c83cdf4baa1c9b714f.tar.gz
gentoo-0c455c0a3c92832ef8f651c83cdf4baa1c9b714f.tar.bz2
gentoo-0c455c0a3c92832ef8f651c83cdf4baa1c9b714f.zip
sci-chemistry/mustang: Port to EAPI 8
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch5
-rw-r--r--sci-chemistry/mustang/mustang-3.2.2.ebuild10
2 files changed, 5 insertions, 10 deletions
diff --git a/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch b/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
index 9e5dea85afeb..20bd300db89e 100644
--- a/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
+++ b/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
@@ -1,8 +1,3 @@
- src/superpose_on_core_2.cpp | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/src/superpose_on_core_2.cpp b/src/superpose_on_core_2.cpp
-index ae137de..059dfe3 100644
--- a/src/superpose_on_core_2.cpp
+++ b/src/superpose_on_core_2.cpp
@@ -55,6 +55,8 @@ using std::ofstream ;
diff --git a/sci-chemistry/mustang/mustang-3.2.2.ebuild b/sci-chemistry/mustang/mustang-3.2.2.ebuild
index c82add5410d0..d15a60e83945 100644
--- a/sci-chemistry/mustang/mustang-3.2.2.ebuild
+++ b/sci-chemistry/mustang/mustang-3.2.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
MY_PN="MUSTANG"
SRC_P="${PN}_v${PV}"
@@ -12,16 +12,16 @@ MY_P="${MY_PN}_v${PV}"
DESCRIPTION="MUltiple STructural AligNment AlGorithm"
HOMEPAGE="http://www.csse.monash.edu.au/~karun/Site/mustang.html"
SRC_URI="http://www.csse.monash.edu.au/~karun/${PN}/${PN}_v${PV}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-3.2.1-gcc-4.7.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2.1-gcc-4.7.patch
+ default
sed -e 's:3.2.1:3.2.2:g' -i Makefile || die
}