summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 23:31:52 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 23:33:08 +0100
commit9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75 (patch)
tree6904a8e12785bcc6f45ef49d72e6fbf9d8ef63d0 /sci-chemistry
parentsci-geosciences/gpsd: Clean old version up (diff)
downloadgentoo-9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75.tar.gz
gentoo-9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75.tar.bz2
gentoo-9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75.zip
sci-chemistry/p3d: distutils-r1, git-r3, EAPI=6
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/p3d/p3d-0.4.3-r1.ebuild (renamed from sci-chemistry/p3d/p3d-0.4.3.ebuild)19
-rw-r--r--sci-chemistry/p3d/p3d-9999.ebuild16
2 files changed, 14 insertions, 21 deletions
diff --git a/sci-chemistry/p3d/p3d-0.4.3.ebuild b/sci-chemistry/p3d/p3d-0.4.3-r1.ebuild
index 294acb075860..6961e1e0e19b 100644
--- a/sci-chemistry/p3d/p3d-0.4.3.ebuild
+++ b/sci-chemistry/p3d/p3d-0.4.3-r1.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils versionator
+inherit distutils-r1 vcs-snapshot versionator
MY_P="${PN}-$(replace_version_separator 3 -)"
GITHUB_ID="gb8b9a75"
@@ -21,15 +20,11 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
IUSE="examples"
-src_prepare() {
- mv fu* ${P}
- distutils_src_prepare
-}
-
src_install() {
- distutils_src_install
+ distutils-r1_src_install
+
if use examples; then
insinto /usr/share/${PN}
- doins -r pdbs exampleScripts || die
+ doins -r pdbs exampleScripts
fi
}
diff --git a/sci-chemistry/p3d/p3d-9999.ebuild b/sci-chemistry/p3d/p3d-9999.ebuild
index e0f8087a0cc2..6edf6afec46b 100644
--- a/sci-chemistry/p3d/p3d-9999.ebuild
+++ b/sci-chemistry/p3d/p3d-9999.ebuild
@@ -1,28 +1,26 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python2_7 )
-inherit git-2 distutils versionator
+inherit distutils-r1 git-r3 versionator
DESCRIPTION="Python module for structural bioinformatics"
HOMEPAGE="http://p3d.fufezan.net/"
SRC_URI=""
-EGIT_REPO_URI="git://github.com/fu/p3d.git"
+EGIT_REPO_URI="https://github.com/fu/p3d.git"
SLOT="0"
KEYWORDS=""
LICENSE="GPL-3"
IUSE="examples"
-S="${WORKDIR}"/${PN}
-
src_install() {
- distutils_src_install
+ distutils-r1_src_install
+
if use examples; then
insinto /usr/share/${PN}
doins -r pdbs exampleScripts || die