summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2021-01-12 00:23:06 +0800
committerYixun Lan <dlan@gentoo.org>2021-01-13 11:06:04 +0800
commit485e8323767b896b94205807f0d09fc096fc4091 (patch)
tree009b918327545f931c177c7712b5147f3d198eca /sci-electronics
parentmedia-gfx/sane-backends: Moved PYTHON_DEPS to BDEPEND (diff)
downloadgentoo-485e8323767b896b94205807f0d09fc096fc4091.tar.gz
gentoo-485e8323767b896b94205807f0d09fc096fc4091.tar.bz2
gentoo-485e8323767b896b94205807f0d09fc096fc4091.zip
sci-electronics/systemc: fix 2.3.1 examples
Add examples and doc use, use docompress -x with examples. Revbump to 2.3.1-r1, removed DOC var because it installed by Makefile. Drop pkg_postinst() because the example already extracted by docompress -x. Closes: https://github.com/gentoo/gentoo/pull/19033 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Huang Rui <vowstar@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/systemc/systemc-2.3.4-r1.ebuild (renamed from sci-electronics/systemc/systemc-2.3.4.ebuild)24
1 files changed, 13 insertions, 11 deletions
diff --git a/sci-electronics/systemc/systemc-2.3.4.ebuild b/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
index b9efef41568a..4669cd8f6d9b 100644
--- a/sci-electronics/systemc/systemc-2.3.4.ebuild
+++ b/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
@@ -24,11 +24,10 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="debug static-libs test"
+IUSE="debug doc examples static-libs test"
+REQUIRED_USE="examples? ( doc )"
RESTRICT="!test? ( test )"
-DOCS=(AUTHORS.md CONTRIBUTING.md INSTALL.md LICENSE NOTICE README.md RELEASENOTES)
-
src_prepare() {
default
eautoconf --force
@@ -41,12 +40,15 @@ src_configure() {
--with-unix-layout
}
-pkg_postinst() {
- elog "If you want to run the examples, you need to :"
- elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
- elog " cd ${PN}-${MY_PV}"
- elog " mkdir build && cd build"
- elog " cmake .."
- elog " cd examples"
- elog " make check"
+src_install() {
+ default
+ if use doc; then
+ if use examples; then
+ docompress -x /usr/share/doc/"${PF}"/examples
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}"/examples || die
+ fi
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}" || die
+ fi
}