summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 10:11:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 11:29:09 +0100
commit81531bb2c743a288b03122d58b9abd01c6b0e27f (patch)
tree85d6d6401a46e371114c4cea4902be16692a40f5 /sci-geosciences/grass
parentsci-geosciences/gdal-grass: Drop superfluous eutils.eclass, sort (diff)
downloadgentoo-81531bb2c743a288b03122d58b9abd01c6b0e27f.tar.gz
gentoo-81531bb2c743a288b03122d58b9abd01c6b0e27f.tar.bz2
gentoo-81531bb2c743a288b03122d58b9abd01c6b0e27f.zip
sci-geosciences/grass: 7.4.4 version bump, fix USE mysql, EAPI-7 prep
Add missing desktop.eclass Drop bogus gnome2.eclass Switch to xdg.utils Use eapi7-ver Fix trailing slashes Sort IUSE and DEPENDs Fix mysql lib path Closes: https://bugs.gentoo.org/658888 Closes: https://bugs.gentoo.org/666052 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/Manifest1
-rw-r--r--sci-geosciences/grass/grass-7.4.4.ebuild278
2 files changed, 279 insertions, 0 deletions
diff --git a/sci-geosciences/grass/Manifest b/sci-geosciences/grass/Manifest
index 0f4623b3d19e..ab09e66a39fe 100644
--- a/sci-geosciences/grass/Manifest
+++ b/sci-geosciences/grass/Manifest
@@ -1,3 +1,4 @@
DIST grass-7.2.0.tar.gz 48315008 BLAKE2B 927da2119e199cee7cbf55a172141abfe9ce86499e307b355fec2cdf79ec3424acddc4410e3049e7cade5dd3da39e618af7e1003093f87de5735a981984b46c6 SHA512 b1aa17ec554c2f0473df3726993b0891df4589c60ca9362405932a4c479b5883245b0a0ba9e787ce2e9de210b6307f34883e4e63ddfbf04eb5d75e8583bc2c5b
DIST grass-7.4.0.tar.gz 56329374 BLAKE2B 924ecd9ad073dd3c59542a871780397a2516e1f0d912b4644978154ea6305ccf50229655aa7f38ab20f2bf85e4a4783cd793fff5101423dd6c212108d638d1df SHA512 b0393ec5d149e2146cc1f30cdcea00e31039bf0a2541486ab0ecd5debe260d267d74e60761b45ce306ad9942264cce9134dbafbf3c75a55df1c610499877d321
DIST grass-7.4.1.tar.gz 57969640 BLAKE2B 1d3d0fd20611971ec349bf0e26ef7d886b7047e1ec48f48584f8ba2e5562f352433c9869420d7e030e66fb5a9e60de20e6a78d1fd5142380fbcab51f700766d8 SHA512 66616e495aa798cd1ad7a0284a386f7e99741918596b816a712788114e7dc491be0b5f19551f102b436518a5cabcdedbc61042acf0a9b06b9d8df12b4de26c90
+DIST grass-7.4.4.tar.gz 58454921 BLAKE2B bf8f85e4dad800a32ac0c23025b0844dde17c806aeec7d150d3263ff8fae80deab7b7052cfb664e138b2af1e5fbe3282db087d7545d42710db6d9890f0b285ee SHA512 9971bd1184c4b2eb38ecf5efafd28094c2d05d22e9ae53a8b074a15e26c029dd13c4627b442a428bca4030fd9118e49422863515cf0fc58dd46e70d2923a9f83
diff --git a/sci-geosciences/grass/grass-7.4.4.ebuild b/sci-geosciences/grass/grass-7.4.4.ebuild
new file mode 100644
index 000000000000..e067fbf0aaa6
--- /dev/null
+++ b/sci-geosciences/grass/grass-7.4.4.ebuild
@@ -0,0 +1,278 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite" # bug 572440
+WANT_AUTOCONF="2.1"
+WX_GTK_VER=3.0
+
+inherit autotools desktop eapi7-ver python-single-r1 wxwidgets xdg
+
+MY_PM=${PN}$(ver_cut 1-2 ${PV})
+MY_PM=${MY_PM/.}
+MY_P=${P/_rc/RC}
+
+DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
+HOMEPAGE="https://grass.osgeo.org/"
+SRC_URI="https://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7.4.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-admin/eselect-1.2
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libprojectm
+ sci-libs/gdal
+ sys-libs/gdbm
+ sys-libs/ncurses:0=
+ sci-libs/proj
+ sci-libs/xdrfile
+ sys-libs/zlib
+ blas? (
+ sci-libs/cblas-reference
+ virtual/blas
+ )
+ fftw? ( sci-libs/fftw:3.0= )
+ geos? ( sci-libs/geos )
+ lapack? ( virtual/lapack )
+ liblas? ( sci-geosciences/liblas )
+ mysql? ( dev-db/mysql-connector-c:= )
+ netcdf? ( sci-libs/netcdf )
+ odbc? ( dev-db/unixODBC )
+ opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
+ png? ( media-libs/libpng:0= )
+ postgres? ( >=dev-db/postgresql-8.4:= )
+ readline? ( sys-libs/readline:0= )
+ sqlite? ( dev-db/sqlite:3 )
+ tiff? ( media-libs/tiff:0= )
+ truetype? ( media-libs/freetype:2 )
+ X? (
+ dev-python/wxpython:3.0[cairo,opengl?]
+ x11-libs/cairo[X,opengl?]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? (
+ dev-lang/swig
+ x11-base/xorg-proto
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ opengl? ( X )"
+
+PATCHES=( "${FILESDIR}/${PN}"-7.0.1-declare-inespg.patch )
+
+pkg_setup() {
+ if use lapack; then
+ local mylapack
+ mylapack=$(eselect lapack show) || die
+ if [[ -z "${mylapack/.*reference.*/}" ]] && \
+ [[ -z "${mylapack/.*atlas.*/}" ]]; then
+ ewarn "You need to set lapack to atlas or reference. Do:"
+ ewarn " eselect lapack set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ if use blas; then
+ local myblas
+ myblas=$(eselect blas show) || die
+ if [[ -z "${myblas/.*reference.*/}" ]] && \
+ [[ -z "${myblas/.*atlas.*/}" ]]; then
+ ewarn "You need to set blas to atlas or reference. Do:"
+ ewarn " eselect blas set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix unversioned python calls
+ local pyver=${EPYTHON/python/}
+ sed -e "s:GRASS_PYTHON=.*:&${pyver}:" -i "${S}/lib/init/grass.sh" || die
+ sed -e "s:= python:&${pyver}:" -i "${S}/include/Make/Platform.make.in" || die
+
+ # fix header being unconditionally included
+ # see upstream https://trac.osgeo.org/grass/ticket/2779
+ sed -e 's:\(#include <ogr_api.h>\):#ifdef HAVE_OGR\n\1\n#endif:' \
+ -i "${S}/vector/v.external/main.c" || die "failed to sed main.c"
+
+ default
+ eautoconf
+
+ ebegin "Fixing python shebangs"
+ python_fix_shebang -q "${S}"
+ eend $?
+
+ # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+ shopt -s nullglob
+ mesa_cards=$(echo -n /dev/dri/card* /dev/dri/render* | sed 's/ /:/g')
+ if test -n "${mesa_cards}"; then
+ addpredict "${mesa_cards}"
+ fi
+ ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+ if test -n "${ati_cards}"; then
+ addpredict "${ati_cards}"
+ fi
+ shopt -u nullglob
+ addpredict /dev/nvidiactl
+
+}
+
+src_configure() {
+ if use X; then
+ WX_BUILD=yes
+ setup-wxwidgets
+ fi
+
+ addwrite "${EPREFIX%/}/dev/dri/renderD128"
+
+ local myeconfargs=(
+ --enable-shared
+ --disable-w11
+ --without-opendwg
+ --with-regex
+ --with-gdal="${EPREFIX%/}/usr/bin/gdal-config"
+ --with-proj-includes="${EPREFIX%/}/usr/include/libprojectM"
+ --with-proj-libs="${EPREFIX%/}/usr/$(get_libdir)"
+ --with-proj-share="${EPREFIX%/}/usr/share/proj/"
+ $(use_with cxx)
+ $(use_with tiff)
+ $(use_with png)
+ $(use_with postgres)
+ $(use_with mysql)
+ $(use_with mysql mysql-includes "${EPREFIX%/}/usr/include/mysql")
+ $(use_with sqlite)
+ $(use_with opengl)
+ $(use_with odbc)
+ $(use_with fftw)
+ $(use_with blas)
+ $(use_with lapack)
+ $(use_with X cairo)
+ $(use_with truetype freetype)
+ $(use_with truetype freetype-includes "${EPREFIX%/}/usr/include/freetype2")
+ $(use_with nls)
+ $(use_with readline)
+ $(use_with threads pthread)
+ $(use_with openmp)
+ $(use_with opencl)
+ $(use_with liblas liblas "${EPREFIX%/}/usr/bin/liblas-config")
+ $(use_with X wxwidgets "${WX_CONFIG}")
+ $(use_with netcdf netcdf "${EPREFIX%/}/usr/bin/nc-config")
+ $(use_with geos geos "${EPREFIX%/}/usr/bin/geos-config")
+ $(use_with X x)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # we don't want to link against embedded mysql lib
+ emake CC="$(tc-getCC)" MYSQLDLIB=""
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ INST_DIR="${D}/usr/$(get_libdir)/${MY_PM}" \
+ prefix="${D}/usr/" BINDIR="${D}/usr/bin" \
+ PREFIX="${D}/usr/" \
+ install
+
+ pushd "${D}/usr/$(get_libdir)/${MY_PM}" &> /dev/null || die
+
+ local HTML_DOCS=( docs/html/. )
+ einstalldocs
+
+ # manuals
+ dodir /usr/share/man/man1
+ rm -rf man/ || die
+
+ # translations
+ if use nls; then
+ dodir /usr/share/locale/
+ mv locale/* "${D}/usr/share/locale/" || die
+ fi
+
+ popd &> /dev/null || die
+
+ # link libraries in the ~standard~ place
+ for fLib in $(ls "${D}/usr/$(get_libdir)/${MY_PM}/lib/"); do
+ dosym "${MY_PM}/lib/${fLib}" "/usr/$(get_libdir)/${fLib}"
+ done
+
+ # link headers in the ~standard~ place
+ dodir "/usr/include/"
+ dosym "../$(get_libdir)/${MY_PM}/include/grass" "/usr/include/grass"
+
+ # fix paths in addons makefile includes
+ local scriptMakeDir
+ scriptMakeDir="${D}/usr/$(get_libdir)/${MY_PM}/include/Make/"
+ for mkFile in $(ls "${scriptMakeDir}"); do
+ echo sed -i "s|${D}|/|g" "${scriptMakeDir}/${mkFile}" || die
+ sed -i "s|${D}|/|g" "${scriptMakeDir}/${mkFile}" || die
+ done
+
+ # get proper folder for grass path in script
+ local gisbase
+ gisbase="${ROOT}/usr/$(get_libdir)/${MY_PM}"
+ sed -e "s:gisbase = \".*:gisbase = \"${gisbase}\":" \
+ -i "${D}/usr/bin/${MY_PM}" || die
+
+ # get proper fonts path for fontcap
+ sed -i \
+ -e "s|${D}/usr/${MY_PM}|${EPREFIX%/}/usr/$(get_libdir)/${MY_PM}|" \
+ "${D}/usr/$(get_libdir)/${MY_PM}/etc/fontcap" || die
+
+ # set proper python interpreter
+ sed -e "s:= \"python\":= \"${EPYTHON}\":" -i "${D}/usr/bin/${MY_PM}" || die
+
+ if use X; then
+ local GUI="-gui"
+ [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ make_desktop_entry "/usr/bin/${MY_PM} ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
+ doicon -s 48 gui/icons/${PN}-48x48.png
+ fi
+
+ # install .pc file so other apps know where to look for grass
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins grass.pc
+
+ # fix weird +x on tcl scripts
+ find "${D}" -name "*.tcl" -exec chmod +r-x '{}' \;
+}
+
+pkg_postinst() {
+ use X && xdg_pkg_postinst
+
+ ewarn "GRASS addons may fail due to Python 3 incompatibility."
+ ewarn "If that is tha case you can change the shebang a the beginning of"
+ ewarn "the script to enforce Python 2 usage."
+ ewarn "#!/usr/bin/env python"
+ ewarn "Should be changed into"
+ ewarn "#!/usr/bin/env python2"
+}
+
+pkg_postrm() {
+ use X && xdg_pkg_postrm
+}