summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 22:18:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 22:20:11 +0100
commit74e63cac3705cd9efb3add3e787d4073bc6ee046 (patch)
tree575aa2094c41ad39db3208141a358c5dfc70de0c /sci-geosciences
parentsci-geosciences/gpsd: Fix install with USE=-X,python (diff)
downloadgentoo-74e63cac3705cd9efb3add3e787d4073bc6ee046.tar.gz
gentoo-74e63cac3705cd9efb3add3e787d4073bc6ee046.tar.bz2
gentoo-74e63cac3705cd9efb3add3e787d4073bc6ee046.zip
sci-geosciences/gpsd: Sync live
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index cb88e5860ea5..98fba863a5a6 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -30,7 +30,7 @@ GPSD_PROTOCOLS=(
tripmate tsip ublox
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 latency_timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth dbus debug ipv6 latency_timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
REQUIRED_USE="X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -115,11 +115,10 @@ src_configure() {
gpsd_group=uucp
nostrip=True
python=False
- qt_versioned=5
+ libgpsmm=True
manbuild=False
shared=$(usex !static True False)
$(use_scons bluetooth bluez)
- $(use_scons cxx libgpsmm)
$(use_scons debug clientdebug)
$(use_scons dbus dbus_export)
$(use_scons ipv6)
@@ -127,12 +126,14 @@ src_configure() {
$(use_scons ncurses)
$(use_scons ntp ntpshm)
$(use_scons ntp pps)
+ $(use_scons qt5 libQgpsmm)
$(use_scons shm shm_export)
$(use_scons sockets socket_export)
- $(use_scons qt5 libQgpsmm)
$(use_scons usb)
)
+ use qt5 && myesconsargs+=( qt_versioned=5 )
+
# enable specified protocols
local protocol
for protocol in ${GPSD_PROTOCOLS[@]} ; do
@@ -158,7 +159,7 @@ src_install() {
if use python ; then
distutils-r1_src_install
# Delete all X related packages if user doesn't want them
- if ! use X ; then
+ if ! use X && [[ -f "${ED%/}"/usr/bin/xgps ]]; then
rm "${ED%/}"/usr/bin/xgps* || die
fi
fi