summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-14 20:30:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-15 04:30:29 +0200
commit8c8a721d03d422f634eb0442e92da6a2a9ef58ba (patch)
tree4fbd81feda61475626184043f88deaa60b89a60b /sci-libs
parentmedia-sound/fluidsynth: Drop old, de-stabilise hppa (diff)
downloadgentoo-8c8a721d03d422f634eb0442e92da6a2a9ef58ba.tar.gz
gentoo-8c8a721d03d422f634eb0442e92da6a2a9ef58ba.tar.bz2
gentoo-8c8a721d03d422f634eb0442e92da6a2a9ef58ba.zip
sci-libs/alglib: Drop 3.8.2-r1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/alglib/Manifest1
-rw-r--r--sci-libs/alglib/alglib-3.8.2-r1.ebuild27
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt32
3 files changed, 0 insertions, 60 deletions
diff --git a/sci-libs/alglib/Manifest b/sci-libs/alglib/Manifest
index 216674af28c3..acfb3c58921c 100644
--- a/sci-libs/alglib/Manifest
+++ b/sci-libs/alglib/Manifest
@@ -1,2 +1 @@
DIST alglib-3.10.0.cpp.gpl.tgz 1991101 BLAKE2B 884b80becce676285b7bc1f26ed8917c4c82f53b41c0350dfc8bff6573e2e6f12183e82fc317b54a8021b1f931eb7d5b55944902d0816f7097fdc05632128bdc SHA512 f02b3db5ab8dee841f27186b6693997c4e6876e75310b0a31a04593dbcb41d300920404e32e7aecb39c8dd15e54cfee05b725caa27397a67b453f6e64cd1ef5e
-DIST alglib-3.8.2.cpp.tgz 1674260 BLAKE2B 85379da805abe27b86025bddafab775fbcb132b74db07abb204c6677b4fe75bd392d2bacb01b26510e1a6f1086b062902f598c9f13892b46e3dca938e73d1ea7 SHA512 3d7b6e3b5a29f25aee476bdd69e583d7504a2e06d390822b4aa2792eeb500e08c13477176be348a9dd560bad358e423465c9086f0c7c12f73dc88024364aed50
diff --git a/sci-libs/alglib/alglib-3.8.2-r1.ebuild b/sci-libs/alglib/alglib-3.8.2-r1.ebuild
deleted file mode 100644
index 6e725a2cd3d1..000000000000
--- a/sci-libs/alglib/alglib-3.8.2-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="Numerical analysis and data processing library"
-HOMEPAGE="http://www.alglib.net/"
-SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.tgz"
-
-SLOT="0/3.7"
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-S="${WORKDIR}"/cpp/
-
-src_prepare() {
- cp "${FILESDIR}"/CMakeLists.txt-${PV} CMakeLists.txt || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=( $(cmake-utils_use_build test) )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/alglib/files/CMakeLists.txt b/sci-libs/alglib/files/CMakeLists.txt
deleted file mode 100644
index 6455423b0fe9..000000000000
--- a/sci-libs/alglib/files/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
-project(alglib CXX)
-cmake_minimum_required(VERSION 2.8)
-
-INCLUDE(GNUInstallDirs)
-INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
-SET(VERSION 3.7.0)
-SET(SOVERSION 3.7)
-
-FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
-FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
-
-ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
-SET_TARGET_PROPERTIES(alglib PROPERTIES
- VERSION ${VERSION}
- SOVERSION ${SOVERSION})
-
-INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
-INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-
-#===========================================================
-ADD_EXECUTABLE(test_c tests/test_c.cpp)
-TARGET_LINK_LIBRARIES(test_c alglib)
-#INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
-#===========================================================
-ADD_EXECUTABLE(test_i tests/test_i.cpp)
-TARGET_LINK_LIBRARIES(test_i alglib)
-#INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
-#===========================================================
-
-enable_testing()
-add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
-add_test( test_i ${CMAKE_BUILD_DIR}/test_i)