summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-11 23:34:11 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-11 23:34:41 +0100
commitebdd2a9c7d597d29d1efa38f8bac6b3e68a8adb7 (patch)
tree0efcc39a9fb24a3466978d1c9130a4248fdf3069 /sci-mathematics/cvc4
parentsys-apps/bubblewrap: 0.7.0 version bump. (diff)
downloadgentoo-ebdd2a9c7d597d29d1efa38f8bac6b3e68a8adb7.tar.gz
gentoo-ebdd2a9c7d597d29d1efa38f8bac6b3e68a8adb7.tar.bz2
gentoo-ebdd2a9c7d597d29d1efa38f8bac6b3e68a8adb7.zip
sci-mathematics/cvc4: drop toml usage
Closes: https://bugs.gentoo.org/878679 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-mathematics/cvc4')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.8-r2.ebuild (renamed from sci-mathematics/cvc4/cvc4-1.8-r1.ebuild)9
-rw-r--r--sci-mathematics/cvc4/files/cvc4-1.8-toml.patch46
2 files changed, 52 insertions, 3 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.8-r1.ebuild b/sci-mathematics/cvc4/cvc4-1.8-r2.ebuild
index c013d2a2ed33..5757f85d54c2 100644
--- a/sci-mathematics/cvc4/cvc4-1.8-r1.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.8-r2.ebuild
@@ -24,16 +24,19 @@ RDEPEND="dev-libs/antlr-c
!cln? ( dev-libs/gmp:= )"
DEPEND="${RDEPEND}"
BDEPEND="$(python_gen_any_dep '
- dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
')
"
S="${WORKDIR}"/${PN^^}-archived-${PV}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-toml.patch
+)
python_check_deps() {
- python_has_version "dev-python/toml[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/tomli[${PYTHON_USEDEP}]"
}
src_configure() {
diff --git a/sci-mathematics/cvc4/files/cvc4-1.8-toml.patch b/sci-mathematics/cvc4/files/cvc4-1.8-toml.patch
new file mode 100644
index 000000000000..f2ac73bf25c3
--- /dev/null
+++ b/sci-mathematics/cvc4/files/cvc4-1.8-toml.patch
@@ -0,0 +1,46 @@
+--- a/src/options/CMakeLists.txt 2022-11-11 23:12:59.874087267 +0100
++++ b/src/options/CMakeLists.txt 2022-11-11 23:13:11.974894643 +0100
+@@ -1,17 +1,3 @@
+-# Check if the toml Python module is installed.
+-execute_process(
+- COMMAND
+- ${PYTHON_EXECUTABLE} -c "import toml"
+- RESULT_VARIABLE
+- RET_TOML
+- ERROR_QUIET
+-)
+-
+-if(RET_TOML)
+- message(FATAL_ERROR
+- "Could not find Python module toml. Install via `pip install toml'.")
+-endif()
+-
+ libcvc4_add_sources(
+ base_handlers.h
+ decision_weight.h
+--- a/src/options/mkoptions.py 2022-11-11 23:16:22.577858012 +0100
++++ b/src/options/mkoptions.py 2022-11-11 23:23:12.014320054 +0100
+@@ -46,7 +46,11 @@
+ import re
+ import sys
+ import textwrap
+-import toml
++
++if sys.version_info >= (3, 11):
++ import tomllib
++else:
++ import tomli as tomllib
+
+ ### Allowed attributes for module/option/alias
+
+@@ -1309,7 +1313,9 @@
+ # Parse files, check attributes and create module/option objects
+ modules = []
+ for filename in filenames:
+- module = parse_module(filename, toml.load(filename))
++ with open(filename, "rb") as f:
++ d1 = tomllib.load(f)
++ module = parse_module(filename, d1)
+
+ # Check if long options are valid and unique. First populate
+ # g_long_cache with option.long and --no- alternatives if