summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-09-24 21:17:22 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-09-24 21:17:38 +0200
commit78913ef011e8aaf88033f9ad8cdc235d118fccf7 (patch)
tree58855e2e357bc7751bf15862c1541d7d5c7cb237 /sci-mathematics/flint
parentsci-mathematics/flint: Fix compilation with >=sys-devel/binutils-2.25.1 (diff)
downloadgentoo-78913ef011e8aaf88033f9ad8cdc235d118fccf7.tar.gz
gentoo-78913ef011e8aaf88033f9ad8cdc235d118fccf7.tar.bz2
gentoo-78913ef011e8aaf88033f9ad8cdc235d118fccf7.zip
sci-mathematics/flint: Fix FTBFS with PIE enabled
Closes: https://bugs.gentoo.org/608704 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sci-mathematics/flint')
-rw-r--r--sci-mathematics/flint/files/flint-2.4.4-PIE-FTBFS.patch17
-rw-r--r--sci-mathematics/flint/flint-2.4.4-r1.ebuild3
-rw-r--r--sci-mathematics/flint/flint-2.4.5.ebuild3
-rw-r--r--sci-mathematics/flint/flint-2.5.2.ebuild2
4 files changed, 23 insertions, 2 deletions
diff --git a/sci-mathematics/flint/files/flint-2.4.4-PIE-FTBFS.patch b/sci-mathematics/flint/files/flint-2.4.4-PIE-FTBFS.patch
new file mode 100644
index 000000000000..5689e3633ee4
--- /dev/null
+++ b/sci-mathematics/flint/files/flint-2.4.4-PIE-FTBFS.patch
@@ -0,0 +1,17 @@
+Description: invoke $(CC) with -r and not -Wl,-r to fix FTBFS with PIE enabled
+Author: Logan Rosen <logan@ubuntu.com>
+Forwarded: yes
+
+diff --git a/Makefile.subdirs b/Makefile.subdirs
+index ec05fb0..f2d8b37 100644
+--- a/Makefile.subdirs
++++ b/Makefile.subdirs
+@@ -59,7 +59,7 @@ $(BUILD_DIR)/$(MOD_DIR)_%.o: %.c
+ $(QUIET_CC) $(CC) $(CFLAGS) $(INCS) -c $< -o $@ -MMD -MP -MF "$(BUILD_DIR)/$(MOD_DIR)_$*.d" -MT "$(BUILD_DIR)/$(MOD_DIR)_$*.d" -MT "$@"
+
+ $(MOD_LOBJ): $(LOBJS)
+- $(QUIET_CC) $(CC) $(ABI_FLAG) -Wl,-r $^ -o $@ -nostdlib
++ $(QUIET_CC) $(CC) $(ABI_FLAG) -r $^ -o $@ -nostdlib
+
+ -include $(LOBJS:.lo=.d)
+
diff --git a/sci-mathematics/flint/flint-2.4.4-r1.ebuild b/sci-mathematics/flint/flint-2.4.4-r1.ebuild
index aca6c9be9410..1068395a40c3 100644
--- a/sci-mathematics/flint/flint-2.4.4-r1.ebuild
+++ b/sci-mathematics/flint/flint-2.4.4-r1.ebuild
@@ -30,7 +30,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.4.3-libdir.patch \
"${FILESDIR}"/${PN}-2.4.3-whitespaces.patch \
"${FILESDIR}"/${PN}-2.4.3-cflags-ldflags.patch \
- "${FILESDIR}"/${PN}-2.4.4-test.patch
+ "${FILESDIR}"/${PN}-2.4.4-test.patch \
+ "${FILESDIR}"/${PN}-2.4.4-PIE-FTBFS.patch
sed -i \
-e '/echo "DLPATH_ADD=/s/\$DLPATH_ADD/\\\$(CURDIR)/' \
diff --git a/sci-mathematics/flint/flint-2.4.5.ebuild b/sci-mathematics/flint/flint-2.4.5.ebuild
index a8293b9632a7..b36ea8b5f2b3 100644
--- a/sci-mathematics/flint/flint-2.4.5.ebuild
+++ b/sci-mathematics/flint/flint-2.4.5.ebuild
@@ -32,7 +32,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-2.4.3-cflags-ldflags.patch \
"${FILESDIR}"/${PN}-2.4.4-test.patch \
"${FILESDIR}"/${PN}-2.4.5-gmp6-compat.patch \
- "${FILESDIR}"/${PN}-2.4.5-ntl62.patch
+ "${FILESDIR}"/${PN}-2.4.5-ntl62.patch \
+ "${FILESDIR}"/${PN}-2.4.4-PIE-FTBFS.patch
sed -i \
-e '/echo "DLPATH_ADD=/s/\$DLPATH_ADD/\\\$(CURDIR)/' \
diff --git a/sci-mathematics/flint/flint-2.5.2.ebuild b/sci-mathematics/flint/flint-2.5.2.ebuild
index 0217ae0600ca..64f94ae79dcf 100644
--- a/sci-mathematics/flint/flint-2.5.2.ebuild
+++ b/sci-mathematics/flint/flint-2.5.2.ebuild
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
)"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.4-PIE-FTBFS.patch
+
sed -i \
-e '/echo "DLPATH_ADD=/s/\$DLPATH_ADD/\\\$(CURDIR)/' \
./configure || die