summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-04-09 12:52:50 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-04-09 13:26:34 -0500
commit91450f133366b037217d42215506f66f1df81ace (patch)
tree394977b552f9476fc8ce63efd7b76d0396ac857b /sci-mathematics/slepc
parentsci-mathematics/petsc: version bumps to 3.14.6 and 3.15.0 (diff)
downloadgentoo-91450f133366b037217d42215506f66f1df81ace.tar.gz
gentoo-91450f133366b037217d42215506f66f1df81ace.tar.bz2
gentoo-91450f133366b037217d42215506f66f1df81ace.zip
sci-mathematics/slepc: version bump to 3.14.2, 3.15.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics/slepc')
-rw-r--r--sci-mathematics/slepc/Manifest2
-rw-r--r--sci-mathematics/slepc/slepc-3.14.2.ebuild69
-rw-r--r--sci-mathematics/slepc/slepc-3.15.0.ebuild69
3 files changed, 140 insertions, 0 deletions
diff --git a/sci-mathematics/slepc/Manifest b/sci-mathematics/slepc/Manifest
index 9beac5e49658..9404459bb057 100644
--- a/sci-mathematics/slepc/Manifest
+++ b/sci-mathematics/slepc/Manifest
@@ -1 +1,3 @@
DIST slepc-3.13.1.tar.gz 4797627 BLAKE2B 29372b8a2d4c5f3b26e840df743f7aec098bfeeb29e9c108e509baa21d9697da19c737470ba4c132391d5193ebf749ef3f3c6ece600ec7527502d40a239aa0ee SHA512 620c344274808329c0a1009e7844532e03e88d38135bfd5b73bc0bc6815b17b6dfb49341d05399230ba6e06997db688aec17615429eaca3dc94fd886119bf321
+DIST slepc-3.14.2.tar.gz 4865497 BLAKE2B d6fd0b45368383fad03b17f9d7f0ef26215b7459a5566c62ab2ad758eaa5fbc626be255b0aafa29b8830eb649a7bcfb0f36d383b865b4c1baa9de6037638de84 SHA512 0727a4f1672c4eb3cf0aa20aa408b897425539ac69123001ac3b2e0bc2d1fa230ef028fa0cd5e89e7a86a98884164fd1c97a742f90f0c128fcc7066d032ee321
+DIST slepc-3.15.0.tar.gz 5191730 BLAKE2B 2fcdfbe25f59a80390478059ef0a8b066ac39b57e99fe65ab4fe4814507fdc78d1feb245df5f7542f08c151d20f2e2a6168c4bc2624f78ab5058627816bb6696 SHA512 f815f0805db3f3e329324778c172ba301ebb5d2fc8f8f4c5dd17e574a2cbed5c0f8015715bc908dfcbd4050fade8dab7ae3b312bae746c41d84c57bc5d101929
diff --git a/sci-mathematics/slepc/slepc-3.14.2.ebuild b/sci-mathematics/slepc/slepc-3.14.2.ebuild
new file mode 100644
index 000000000000..b1c64ce92031
--- /dev/null
+++ b/sci-mathematics/slepc/slepc-3.14.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit eutils flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
+HOMEPAGE="https://slepc.upv.es/"
+SRC_URI="https://slepc.upv.es/download/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="complex-scalars doc mpi"
+
+RDEPEND="
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
+ sci-libs/arpack[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+MAKEOPTS="${MAKEOPTS} V=1"
+
+src_configure() {
+ # *sigh*
+ addpredict "${PETSC_DIR}"/.nagged
+
+ # Make sure that the environment is set up correctly:
+ unset PETSC_DIR
+ unset PETSC_ARCH
+ source "${EPREFIX}"/etc/env.d/99petsc
+ export PETSC_DIR
+ export PETSC_ARCH
+ export SLEPC_DIR="${S}"
+
+ # configure is a custom python script and doesn't want to have default
+ # configure arguments that we set with econf
+ ./configure \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
+ --with-arpack=1 \
+ --with-arpack-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-arpack-lib="$(usex mpi "-lparpack,-larpack" "-larpack")"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99slepc <<- EOF
+ SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
+ EOF
+ doenvd 99slepc
+
+ if use doc ; then
+ dodoc docs/slepc.pdf
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
+ fi
+}
diff --git a/sci-mathematics/slepc/slepc-3.15.0.ebuild b/sci-mathematics/slepc/slepc-3.15.0.ebuild
new file mode 100644
index 000000000000..b1c64ce92031
--- /dev/null
+++ b/sci-mathematics/slepc/slepc-3.15.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit eutils flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
+HOMEPAGE="https://slepc.upv.es/"
+SRC_URI="https://slepc.upv.es/download/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="complex-scalars doc mpi"
+
+RDEPEND="
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
+ sci-libs/arpack[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+MAKEOPTS="${MAKEOPTS} V=1"
+
+src_configure() {
+ # *sigh*
+ addpredict "${PETSC_DIR}"/.nagged
+
+ # Make sure that the environment is set up correctly:
+ unset PETSC_DIR
+ unset PETSC_ARCH
+ source "${EPREFIX}"/etc/env.d/99petsc
+ export PETSC_DIR
+ export PETSC_ARCH
+ export SLEPC_DIR="${S}"
+
+ # configure is a custom python script and doesn't want to have default
+ # configure arguments that we set with econf
+ ./configure \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
+ --with-arpack=1 \
+ --with-arpack-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-arpack-lib="$(usex mpi "-lparpack,-larpack" "-larpack")"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99slepc <<- EOF
+ SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
+ EOF
+ doenvd 99slepc
+
+ if use doc ; then
+ dodoc docs/slepc.pdf
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
+ fi
+}