summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-04-04 00:18:05 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-04-04 00:18:05 +0600
commit110c1ec73e9452ef90d75024104c1ef5960df2ae (patch)
tree3fb8b3f096052f9660533a96652752ff754e770d /sci-mathematics/wxmaxima
parentapp-admin/collectd: Fix CGROUP kernel config check (diff)
downloadgentoo-110c1ec73e9452ef90d75024104c1ef5960df2ae.tar.gz
gentoo-110c1ec73e9452ef90d75024104c1ef5960df2ae.tar.bz2
gentoo-110c1ec73e9452ef90d75024104c1ef5960df2ae.zip
sci-mathematics/wxmaxima: bump to 16.04.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-16.04.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 58e93aca5f9a..15147d2999ce 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxMaxima-13.04.2.tar.gz 1652680 SHA256 29352db75dd3ff27393ab0971543fd0b3c3a9c330c2c8d07ebfd373741ded4eb SHA512 36d035282aca8d40d9f5950c21e8e3abe8d3a76ffbb91f6436a3588e252ca2455c4c1c4e5eed4111888f917406ac758f551198ca97acb67bcc6655e579db20aa WHIRLPOOL 7579a5d7b72e0c10f9162b92da03b2f4f51052cf8800fc0c01312718cfc31c0d8ff608aff6f873e07b46247a2c2ad7dc666e0e469dda1f1a8e8af52629a6e69d
DIST wxmaxima-15.04.0.tar.gz 4990313 SHA256 c178067a2f75d91dd378f88b4d0f87af6b2705ca32bea509d63e7347b2a1d21e SHA512 1a899259698da38f97a1859ba0526406cbc654a130dc1d18e01cf248ac4d7292c82cb00dd92ce2fac2c3cfc002788fdef0a6a4f95eca54b9096efc73c6aa45b7 WHIRLPOOL 225456c073b1aa87d2e599b9c63244ff7c97378fb6b5a60fcb8730655d193a0f032b27a1264e12eefb4abf08389f2337a11c380b6d89af2de9a4fb6e14f614dc
DIST wxmaxima-15.08.2.tar.gz 5592673 SHA256 7ad3f018e42d15d06bee5af10053edb72e441c1d1feee318dc6eb927db6a26c5 SHA512 a537c49477f54df4fd9e4e42a5e0d0d740f1ede817d807a98b7cec877a3ad77b2be0a61ae487a7fa5beb193b112eca163b8873292ecab5acf118d58a91e91af6 WHIRLPOOL a4df36704bbd33f841ddf3b9651662a092708850cdc637e6f6bfabc195c1e7e34dd66e14d92ee1cba69f3810bc74a4295837709d38bf6d6ce83b81d7776a3b9a
+DIST wxmaxima-16.04.0.tar.gz 5177673 SHA256 d49cd1ff6bfccda13f766c9f712445d0c49008dfdfabe514759f5434676fe17e SHA512 5d1884b106528e0a4be18a734ac248287c86f691ea56399c38bef35c902440f0e0b66afd4f015d9c08f47435eb150bd2daac421cd0c65119adf8590337f12aee WHIRLPOOL 2dc2c14481937c3b0589ef8a4fba9b04340250d39e0f833ae0ff65f091b989bbea0254b574ce5ea75f0aeeab37d5864d27d10e26f5acc86dbd8faafe6652e2bc
diff --git a/sci-mathematics/wxmaxima/wxmaxima-16.04.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-16.04.0.ebuild
new file mode 100644
index 000000000000..1e052291633c
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-16.04.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ local i
+
+ # consistent package names
+ sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in test/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Dirstructure.cpp src/Dirstructure.h \
+ || die "sed failed"
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/locales ; echo *.mo) ; do
+ if ! has ${i%.mo} ${LINGUAS} ; then
+ sed -i \
+ -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+ -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+ locales/Makefile.in || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+ default
+ doicon -s 128 data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}