summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-04-28 10:13:40 +0200
committerDavid Seifert <soap@gentoo.org>2016-05-05 00:00:03 +0200
commit7c683220facc3387d27c33ba6b2dc816ef3f592c (patch)
tree799e323d53ef4c1c58ccdce84a1ff8da955bb9ff /sci-misc
parentsci-misc/boinc: New r1 ebuild for boinc-7.6.31 with vsyscall fix (diff)
downloadgentoo-7c683220facc3387d27c33ba6b2dc816ef3f592c.tar.gz
gentoo-7c683220facc3387d27c33ba6b2dc816ef3f592c.tar.bz2
gentoo-7c683220facc3387d27c33ba6b2dc816ef3f592c.zip
sci-misc/boinc: Removed obsolete ebuild for boinc-7.6.31
Gentoo-Bug: 577490, 578750 Made obsolete by the 7.6.31-r1 ebuild, that has an important fix. Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/boinc-7.6.31.ebuild127
1 files changed, 0 insertions, 127 deletions
diff --git a/sci-misc/boinc/boinc-7.6.31.ebuild b/sci-misc/boinc/boinc-7.6.31.ebuild
deleted file mode 100644
index f390d9a00d34..000000000000
--- a/sci-misc/boinc/boinc-7.6.31.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-WX_GTK_VER=3.0
-
-inherit autotools flag-o-matic systemd user versionator wxwidgets
-
-MY_PV=$(get_version_component_range 1-2)
-
-DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
-HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda static-libs"
-
-RDEPEND="
- !sci-misc/boinc-bin
- !app-admin/quickswitch
- >=app-misc/ca-certificates-20080809
- dev-libs/openssl:0=
- net-misc/curl[ssl,-gnutls(-),-nss(-),curl_ssl_openssl(+)]
- sys-apps/util-linux
- sys-libs/zlib
- cuda? (
- >=dev-util/nvidia-cuda-toolkit-2.1
- >=x11-drivers/nvidia-drivers-180.22
- )
- X? (
- dev-db/sqlite:3
- media-libs/freeglut
- sys-libs/glibc:2.2
- virtual/jpeg:0=
- x11-libs/gtk+:2
- >=x11-libs/libnotify-0.7
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,webkit]
- )
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- app-text/docbook-xml-dtd:4.4
- app-text/docbook2X
-"
-
-S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
-
-src_prepare() {
- # prevent bad changes in compile flags, bug 286701
- sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
-
- eautoreconf
-
- use X && need-wxwidgets unicode
-}
-
-src_configure() {
- econf --disable-server \
- --enable-client \
- --enable-dynamic-client-linkage \
- --disable-static \
- --enable-unicode \
- --with-ssl \
- $(use_with X x) \
- $(use_enable X manager) \
- $(usex X --with-wx-config="${WX_CONFIG}" --without-wxdir)
-}
-
-src_install() {
- default
-
- keepdir /var/lib/${PN}
-
- if use X; then
- newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png
- make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
- fi
-
- # cleanup cruft
- rm -rf "${ED}"/etc || die "rm failed"
-
- newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_preinst() {
- enewgroup ${PN}
- # note this works only for first install so we have to
- # elog user about the need of being in video group
- local groups="${PN}"
- if use cuda; then
- group+=",video"
- fi
- enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
-}
-
-pkg_postinst() {
- echo
- elog "You are using the source compiled version of boinc."
- use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
- elog
- elog "You need to attach to a project to do anything useful with boinc."
- elog "You can do this by running /etc/init.d/boinc attach"
- elog "The howto for configuration is located at:"
- elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
- elog
- # Add warning about the new password for the client, bug 121896.
- if use X; then
- elog "If you need to use the graphical manager the password is in:"
- elog "/var/lib/boinc/gui_rpc_auth.cfg"
- elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/boinc"
- elog "You should change this password to something more memorable (can be even blank)."
- elog "Remember to launch init script before using manager. Or changing the password."
- elog
- fi
- if use cuda; then
- elog "To be able to use CUDA you should add boinc user to video group."
- elog "Run as root:"
- elog "gpasswd -a boinc video"
- fi
-}