summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/xfoil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/xfoil')
-rw-r--r--sci-physics/xfoil/Manifest2
-rw-r--r--sci-physics/xfoil/files/xfoil-6.96-gfortran.patch29
-rw-r--r--sci-physics/xfoil/files/xfoil-6.97-overflow.patch22
-rw-r--r--sci-physics/xfoil/metadata.xml18
-rw-r--r--sci-physics/xfoil/xfoil-6.97.ebuild71
5 files changed, 142 insertions, 0 deletions
diff --git a/sci-physics/xfoil/Manifest b/sci-physics/xfoil/Manifest
new file mode 100644
index 000000000000..35646cfc07e9
--- /dev/null
+++ b/sci-physics/xfoil/Manifest
@@ -0,0 +1,2 @@
+DIST dataflow.pdf 7654 SHA256 4596c77a3fa24cd334b35c34fcbd0b4f1d9055273c0862643e2d07b5e774aff5
+DIST xfoil6.97.tar.gz 3972497 SHA256 293e28e269bd88a62f8b6ba6bf684f16843f6776736e6b77aaa8b6bebc467a81 SHA512 02c0a123fb99fa20de1e3577ca7c6ce00d494058f2ef3ec82e3fdea48901f4346180aea3436e001c5b90401007ccdd5b7e9daa6a96794f0d6b5781a5b36e36e7 WHIRLPOOL 3de5e6c56a906a71b2be1fcf39ea031454c9192b4a649a23aaa889566fea2e92b37239fa6ed90c4b050bdb5759943d0265881f316ecd5b48a06fe4217af36ef7
diff --git a/sci-physics/xfoil/files/xfoil-6.96-gfortran.patch b/sci-physics/xfoil/files/xfoil-6.96-gfortran.patch
new file mode 100644
index 000000000000..67fc19c645f9
--- /dev/null
+++ b/sci-physics/xfoil/files/xfoil-6.96-gfortran.patch
@@ -0,0 +1,29 @@
+--- plotlib/ps_subs.f.orig 2004-08-21 19:02:44.000000000 +0100
++++ plotlib/ps_subs.f 2007-05-03 19:14:28.901490750 +0100
+@@ -559,7 +559,7 @@
+ c in the iout array (3,1,3,1,3,1,3,1)
+ c Note: the bit mask is shifted to always start counting on a '1' bit.
+ c
+-c--- Uses the library routines and() and rshift() for bit manipulation
++c--- Uses the library routines and() and ishft() for bit manipulation
+ c which are present in most fortran libraries as extensions to f77.
+ c
+ dimension iout(*)
+@@ -570,7 +570,7 @@
+ ibitold = and(1,imask)
+ if(ibitold.NE.0) go to 5
+ nshft = n
+- imask = rshift(imask,1)
++ imask = ishft(imask,-1)
+ end do
+ c
+ 5 nout = 0
+@@ -594,7 +594,7 @@
+ c
+ ibitold = ibit
+ nbits = nbits + 1
+- imask = rshift(imask,1)
++ imask = ishft(imask,-1)
+ end do
+ c--- Add final bit(s) to end of 16 bits checked
+ c--- Now append any zero bits shifted out originally
diff --git a/sci-physics/xfoil/files/xfoil-6.97-overflow.patch b/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
new file mode 100644
index 000000000000..73656f927a48
--- /dev/null
+++ b/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
@@ -0,0 +1,22 @@
+--- src/pplot.f.orig 2008-08-21 20:21:08.000000000 +0100
++++ src/pplot.f 2008-08-21 20:21:42.000000000 +0100
+@@ -36,7 +36,7 @@
+ PROGRAM PPLOT
+ INCLUDE 'PPLOT.INC'
+ C
+- LOGICAL ERROR, LGETFN
++ LOGICAL ERROR, LGETFN, LERR
+ REAL RINP(10)
+ REAL CPOLO(NAX,IPTOT,NPX), VPOLO(NAX,2,NPX)
+ C
+--- src/xoper.f.orig 2008-08-22 15:55:27.000000000 +0100
++++ src/xoper.f 2008-08-22 15:53:36.000000000 +0100
+@@ -114,7 +114,7 @@
+ C---- don't try to read integers, since might get integer overflow
+ DO I=1, NINPUT
+ IF(ABS(RINPUT(I)) .GT. 2.1E9) THEN
+- IINPUT(I) = 2**31
++ IINPUT(I) = HUGE(0)
+ ELSE
+ IINPUT(I) = INT(RINPUT(I))
+ ENDIF
diff --git a/sci-physics/xfoil/metadata.xml b/sci-physics/xfoil/metadata.xml
new file mode 100644
index 000000000000..c6130c99cea3
--- /dev/null
+++ b/sci-physics/xfoil/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ XFOIL is an interactive program for the design and analysis of subsonic isolated airfoils.
+ It consists of a collection of menu-driven routines which perform various useful functions such as:
+ * Viscous (or inviscid) analysis of an existing airfoil
+ * Airfoil design and redesign by interactive modification of surface speed distributions
+ * Airfoil redesign by interactive modification of geometric parameters
+ * Blending of airfoils
+ * Writing and reading of airfoil coordinates and polar save files
+ * Plotting of geometry, pressure distributions, and multiple polars
+</longdescription>
+</pkgmetadata>
diff --git a/sci-physics/xfoil/xfoil-6.97.ebuild b/sci-physics/xfoil/xfoil-6.97.ebuild
new file mode 100644
index 000000000000..d1679ff859bf
--- /dev/null
+++ b/sci-physics/xfoil/xfoil-6.97.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2
+
+DESCRIPTION="Design and analysis of subsonic isolated airfoils"
+HOMEPAGE="http://raphael.mit.edu/xfoil/"
+SRC_URI="
+ http://web.mit.edu/drela/Public/web/${PN}/${PN}${PV}.tar.gz
+ doc? ( http://web.mit.edu/drela/Public/web/${PN}/dataflow.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/Xfoil"
+
+src_prepare() {
+ sed \
+ -e '/^FC/d' \
+ -e '/^CC/d' \
+ -e '/^FFLAGS/d' \
+ -e '/^CFLAGS/d' \
+ -e 's/^\(FFLOPT .*\)/FFLOPT = $(FFLAGS)/g' \
+ -i {bin,plotlib,orrs/bin}/Makefile plotlib/config.make \
+ || die "sed for flags and compilers failed"
+
+ # fix bug #147033
+ [[ $(tc-getFC) == *gfortran ]] && \
+ epatch "${FILESDIR}"/${PN}-6.96-gfortran.patch
+
+ epatch "${FILESDIR}"/${P}-overflow.patch
+
+ sed \
+ -e "s:/var/local/codes/orrs/osmap.dat:${EPREFIX}/usr/share/xfoil/orrs/osmap.dat:" \
+ -i orrs/src/osmap.f || die "sed osmap.f failed"
+}
+
+src_compile() {
+ cd "${S}"/orrs/bin
+ emake FLG="${FFLAGS}" FTNLIB="${LDFLAGS}" OS
+ cd "${S}"/orrs
+ bin/osgen osmaps_ns.lst
+ cd "${S}"/plotlib
+ emake CFLAGS="${CFLAGS} -DUNDERSCORE"
+ cd "${S}"/bin
+ for i in xfoil pplot pxplot; do
+ emake \
+ PLTOBJ="../plotlib/libPlt.a" \
+ CFLAGS="${CFLAGS} -DUNDERSCORE" \
+ FTNLIB="${LDFLAGS}" \
+ ${i}
+ done
+}
+
+src_install() {
+ dobin bin/pplot bin/pxplot bin/xfoil
+ insinto /usr/share/xfoil/orrs
+ doins orrs/osm*.dat
+ dodoc *.txt README
+ insinto /usr/share/doc/${PF}/
+ use examples && doins -r runs
+ use doc && dodoc "${DISTDIR}"/dataflow.pdf
+}