summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-12-20 17:32:29 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-17 12:16:45 +0200
commitd2f24698a738cf314b5d7e003193ca10d3c9f463 (patch)
treecac0772a1c978db6e5fc8c64f9a401125b94a0c3 /sci-physics
parentdev-util/rbtools: add python3_9 (diff)
downloadgentoo-d2f24698a738cf314b5d7e003193ca10d3c9f463.tar.gz
gentoo-d2f24698a738cf314b5d7e003193ca10d3c9f463.tar.bz2
gentoo-d2f24698a738cf314b5d7e003193ca10d3c9f463.zip
sci-physics/geant-vmc: Version bump to 4.5.3.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant-vmc/Manifest1
-rw-r--r--sci-physics/geant-vmc/geant-vmc-4.5.3.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/sci-physics/geant-vmc/Manifest b/sci-physics/geant-vmc/Manifest
index 173a1bead9d4..d68add146cab 100644
--- a/sci-physics/geant-vmc/Manifest
+++ b/sci-physics/geant-vmc/Manifest
@@ -1,2 +1,3 @@
DIST geant-vmc-4.5.1_p1.tar.gz 7441504 BLAKE2B 2bcb844a8fc79c800eec50f914cd7238a68ba0c1ffa1e8d185adcded70583118e39efbac3330f7942a098fc64f990c1e9e0eeb1796f71ebd98f97d121aa6c121 SHA512 760611c1df481ea3d9f9069061678677ffc2bcf9edd7cfd44789a6359b945bc341f705da0ee85ecda7f8ac2b096cd5b7aa9ea2c44b464e3085c16eeb33ee1316
+DIST geant-vmc-4.5.3.tar.gz 7411643 BLAKE2B 31a486aa32f879093753aab09798eabf1a936f0aa246bb97c7f055eefb789c9c5a5097c14ce47b05a99f3cc2b46bea6edeba2af80ee362bb8fee039ee711eddc SHA512 918ce3ca4a4fb329f00000fce00dae3d4a4c9f348553f31bf474f727c1e67242b5ff28fe7dc5d3ab12d1174663b1dd96b654b5baf7edfa662ab3f66687792e94
DIST geant4_vmc.4.0.tar.gz 7118838 BLAKE2B 5edbd13adeeb560188deb54c1f5d52fda371dd5f3dc04d676bcaf7edad0bbf8eb573d6345e5c3626b5b64c229d49b7f02aafec77a2587e525cf3f407444391b5 SHA512 faf5fed17b317399b97f77ff1c2a1bf1cead8f0b02a3a89244f01f8ae04ce621763e52b40000e481b3826796bb4d94216368d2e3c98a62f02048c5979f4ee648
diff --git a/sci-physics/geant-vmc/geant-vmc-4.5.3.ebuild b/sci-physics/geant-vmc/geant-vmc-4.5.3.ebuild
new file mode 100644
index 000000000000..b28eff16cc8b
--- /dev/null
+++ b/sci-physics/geant-vmc/geant-vmc-4.5.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
+ KEYWORDS=""
+else
+ MY_PV=$(ver_rs 1-2 - $(ver_cut 2-))
+ SRC_URI="https://github.com/vmc-project/geant4-vmc/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/geant4_vmc-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="+c++11 c++14 c++17 doc examples geant3 +g4root +mtroot rootvmc vgm test"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND="
+ rootvmc? (
+ >=sci-physics/root-6.18:=[vmc]
+ !!sci-physics/vmc
+ )
+ !rootvmc? (
+ >=sci-physics/root-6.18:=[-vmc]
+ sci-physics/vmc:=[c++11?,c++14?,c++17?]
+ )
+ >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?,opengl,geant3?]
+ >=sci-physics/root-6.18:=[c++11?,c++14?,c++17?]
+ vgm? ( >=sci-physics/vgm-4.8:=[c++11?,c++14?,c++17?] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+RESTRICT="
+ !examples? ( test )
+ !geant3? ( test )
+ !g4root? ( test )
+ !mtroot? ( test )
+ !test? ( test )
+ !vgm? ( test )"
+
+DOCS=(history README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ local dirs=(
+ source
+ $(usev g4root)
+ $(usev mtroot)
+ $(usev examples)
+ )
+ local d
+ for d in "${dirs[@]}"; do
+ pushd "${d}" > /dev/null || die
+ doxygen || die
+ popd > /dev/null || die
+ done
+ fi
+}
+
+src_test() {
+ cd examples || die
+ ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=(doc/.)
+ einstalldocs
+}