summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-31 11:37:40 +0100
committerJeroen Roovers <jer@gentoo.org>2019-10-31 11:38:04 +0100
commitb4fd1e856700840d04a0ce75d6d339bac4f6391e (patch)
treedb410e4be16d674583916e73d25e931fe90707ca /sys-apps/conspy
parentwww-client/opera-developer: Old (diff)
downloadgentoo-b4fd1e856700840d04a0ce75d6d339bac4f6391e.tar.gz
gentoo-b4fd1e856700840d04a0ce75d6d339bac4f6391e.tar.bz2
gentoo-b4fd1e856700840d04a0ce75d6d339bac4f6391e.zip
sys-apps/conspy: Version 1.14
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Fixes: https://bugs.gentoo.org/690238 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-apps/conspy')
-rw-r--r--sys-apps/conspy/Manifest1
-rw-r--r--sys-apps/conspy/conspy-1.14.ebuild35
-rw-r--r--sys-apps/conspy/files/conspy-1.14-tinfo.patch10
3 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/conspy/Manifest b/sys-apps/conspy/Manifest
index 1ff2956ea3ed..1cf2e9873c24 100644
--- a/sys-apps/conspy/Manifest
+++ b/sys-apps/conspy/Manifest
@@ -1 +1,2 @@
DIST conspy-1.10.tar.gz 25211 BLAKE2B 2cb2d2c02bc38ab26bc2f08737c7e2f87dacb4fd04240bda63900e0b9018f98d28b2ee2fa00dba5ca931d59b823a72f2e0dd282828b081b31d91dd64c652dbef SHA512 f22ddff140935f767bff34c8c274ff088ebae049ac61c543ad37fa126bbab2e1cec72bdd93f51cb513d00368b909935491d06a36dbff215f17cdea7a658dbad2
+DIST conspy-1.14.tar.gz 26637 BLAKE2B 6fd4e3c35bf978ca7041aac0de23745a5c7cb200e4b29ec841cc195ea75194ed9a65ef46c85fc40b549ca68593ddab1af39499725880da403a602f97650982cd SHA512 46c25770e399c46de5aadcfbf4cff4ab5bc0f83771d6930b5752b9493f8c6864cc86d787ef6f297a00944e65987a56f6bf2cf99975eff689864745c0eef45b0d
diff --git a/sys-apps/conspy/conspy-1.14.ebuild b/sys-apps/conspy/conspy-1.14.ebuild
new file mode 100644
index 000000000000..1185be89bd36
--- /dev/null
+++ b/sys-apps/conspy/conspy-1.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Remote control for Linux virtual consoles"
+HOMEPAGE="http://conspy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-1/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14-tinfo.patch
+)
+DOCS=(
+ ChangeLog.txt README.txt ${PN}.html
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+}
diff --git a/sys-apps/conspy/files/conspy-1.14-tinfo.patch b/sys-apps/conspy/files/conspy-1.14-tinfo.patch
new file mode 100644
index 000000000000..55ee90b61a16
--- /dev/null
+++ b/sys-apps/conspy/files/conspy-1.14-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,6 +11,7 @@
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([fcntl.h getopt.h stdarg.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h])
+ AC_CHECK_LIB(ncurses, initscr)
++AC_SEARCH_LIBS(putp, tinfo)
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_HEADER_TIME