summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-12-13 15:59:03 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-12-13 15:59:15 -0500
commitee77ffa62e89d8715748d056132c0a4a925aa1e0 (patch)
treeef5ef286168770182678e7c4ba0b55a5a8e092aa /sys-apps/elfix
parentdev-python/pypax: version bump to 0.9.4, fixes bug #672072 (diff)
downloadgentoo-ee77ffa62e89d8715748d056132c0a4a925aa1e0.tar.gz
gentoo-ee77ffa62e89d8715748d056132c0a4a925aa1e0.tar.bz2
gentoo-ee77ffa62e89d8715748d056132c0a4a925aa1e0.zip
sys-apps/elfix: version bump to 0.9.4, fixes bug #672072
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/Manifest1
-rw-r--r--sys-apps/elfix/elfix-0.9.4.ebuild48
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild4
3 files changed, 51 insertions, 2 deletions
diff --git a/sys-apps/elfix/Manifest b/sys-apps/elfix/Manifest
index c09e6771f9f4..f94a606a8d05 100644
--- a/sys-apps/elfix/Manifest
+++ b/sys-apps/elfix/Manifest
@@ -1,2 +1,3 @@
DIST elfix-0.9.2.tar.gz 398758 BLAKE2B 22f8d9e85be2ae9bd906dfa6a1d8b7614f017686b4563ef7e97898a112a56cff59a8cb906ec957b7a111a5c9251a3de6b13dfb66ef9f732099ac610928d5321e SHA512 a7be30722abe7249ec42024d33b2bda00524cfb85da66b4511c5056efbdbfae1d3c2b42048bcf4d5cb7c0ae675f763b74a834d93a25b541ebac42fddcd2c6cf9
DIST elfix-0.9.3.tar.gz 399533 BLAKE2B 7ff2099218de3352079564971cd2e3851a95820552b9057387b78945fb1a23d7b670591b174dc974ca2b0dcf3948546578a210687cbb16625dc5d638abf83169 SHA512 3395ce2e6d5e9fc9bdd93b58751cea33b5fb8e25e0a390e6261de6804cc54d4e1f91b4b5843fc45c9178d86d23e9932bf9d0f133a6d086607bf52ce16c65fd0d
+DIST elfix-0.9.4.tar.gz 399606 BLAKE2B 51b8b2f1c3cce306c7bc0716ad351bbf446a369a353bcd1b5faa41984dec37e08dbeeea87fa2425820af9f76d36209554b8e602338d01d0ad50e6d95e6079529 SHA512 f705f63b0ca57077f56e519a22ccaeb2e07f57c5269a6e498571a1799286f12098ccc9a92d2126b51b498447a098b0ce22d54c0d97c8c98d25426fe1e00c6e07
diff --git a/sys-apps/elfix/elfix-0.9.4.ebuild b/sys-apps/elfix/elfix-0.9.4.ebuild
new file mode 100644
index 000000000000..a7a57400096c
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.9.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ https://dev.gentoo.org/~blueness/elfix/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+ptpax +xtpax"
+
+DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ cd doc && ./make.sh || die
+ fi
+}
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index 0eaa5ebdfecf..a7a57400096c 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,7 +19,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="+ptpax +xtpax"
-DOCS=( AUTHORS ChangeLog INSTALL README.md THANKS TODO )
+DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
REQUIRED_USE="|| ( ptpax xtpax )"