summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-01-04 14:53:38 +0100
committerFabian Groffen <grobian@gentoo.org>2017-01-04 14:53:38 +0100
commit5c37d89218b82c24a908c318e633f9b65ad07f17 (patch)
treea8e1c94fd0e958553324250b95cf92b557e4f195 /sys-apps/gawk
parentsci-misc/boinc: Rename desktop file to boincmgr.desktop (diff)
downloadgentoo-5c37d89218b82c24a908c318e633f9b65ad07f17.tar.gz
gentoo-5c37d89218b82c24a908c318e633f9b65ad07f17.tar.bz2
gentoo-5c37d89218b82c24a908c318e633f9b65ad07f17.zip
sys-apps/gawk: fix compilation on Solaris
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/gawk-4.1.4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/gawk/gawk-4.1.4.ebuild b/sys-apps/gawk/gawk-4.1.4.ebuild
index 7aa9f006e6e8..0d421fbc32a5 100644
--- a/sys-apps/gawk/gawk-4.1.4.ebuild
+++ b/sys-apps/gawk/gawk-4.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,6 +31,12 @@ src_prepare() {
sed -i \
-e '/check-recursive all-recursive: check-for-shared-lib-support/d' \
extension/Makefile.in || die
+ # fix standards conflict on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i \
+ -e '/\<_XOPEN_SOURCE\>/s/$/600/' \
+ extension/inplace.c || die
+ fi
}
src_configure() {