summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-09-14 21:48:49 -0400
committerMike Gilbert <floppym@gentoo.org>2015-09-14 21:52:13 -0400
commitcc2e8543906a76c98f0ca0e6fb4ceecd65f2025d (patch)
treef6628c718632913615fcc8e86ff13265e67cc478 /sys-apps/pciutils/pciutils-3.2.1.ebuild
parentapp-misc/reptyr: remove myself as maintainer (diff)
downloadgentoo-cc2e8543906a76c98f0ca0e6fb4ceecd65f2025d.tar.gz
gentoo-cc2e8543906a76c98f0ca0e6fb4ceecd65f2025d.tar.bz2
gentoo-cc2e8543906a76c98f0ca0e6fb4ceecd65f2025d.zip
Revert "sys-apps/pciutils: Removed old."
This reverts commit f4e5f102a6b5d8d1807c195e741c6fc6b160c2bc. This commit broke the stable depgraph on sparc.
Diffstat (limited to 'sys-apps/pciutils/pciutils-3.2.1.ebuild')
-rw-r--r--sys-apps/pciutils/pciutils-3.2.1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/sys-apps/pciutils/pciutils-3.2.1.ebuild b/sys-apps/pciutils/pciutils-3.2.1.ebuild
new file mode 100644
index 000000000000..7eecf09f13a5
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.2.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://mj.ucw.cz/sw/pciutils/ https://git.kernel.org/?p=utils/pciutils/pciutils.git"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dns +kmod static-libs zlib"
+
+# Have the sub-libs in RDEPEND with [static-libs] since, logically,
+# our libssl.a depends on libz.a/etc... at runtime.
+LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )"
+DEPEND="kmod? ( sys-apps/kmod )
+ static-libs? ( ${LIB_DEPEND} )
+ !static-libs? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+RDEPEND="${DEPEND}
+ sys-apps/hwids"
+DEPEND="${DEPEND}
+ kmod? ( virtual/pkgconfig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.9-static-pc.patch
+
+ if use static-libs ; then
+ cp -pPR "${S}" "${S}.static" || die
+ fi
+}
+
+pemake() {
+ emake \
+ HOST="${CHOST}" \
+ CROSS_COMPILE="${CHOST}-" \
+ CC="$(tc-getCC)" \
+ DNS=$(usex dns) \
+ IDSDIR='$(SHAREDIR)/misc' \
+ MANDIR='$(SHAREDIR)/man' \
+ PREFIX="${EPREFIX}/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(usex zlib) \
+ PCI_COMPRESSED_IDS=0 \
+ PCI_IDS=pci.ids \
+ LIBDIR="\${PREFIX}/$(get_libdir)" \
+ LIBKMOD=$(usex kmod) \
+ "$@"
+}
+
+src_compile() {
+ pemake OPT="${CFLAGS}" all
+ if use static-libs ; then
+ pemake \
+ -C "${S}.static" \
+ OPT="${CFLAGS}" \
+ SHARED="no" \
+ lib/libpci.a
+ fi
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install install-lib
+ use static-libs && dolib.a "${S}.static/lib/libpci.a"
+ dodoc ChangeLog README TODO
+
+ rm "${ED}"/usr/sbin/update-pciids "${ED}"/usr/share/misc/pci.ids \
+ "${ED}"/usr/share/man/man8/update-pciids.8*
+
+ newinitd "${FILESDIR}"/init.d-pciparm pciparm
+ newconfd "${FILESDIR}"/conf.d-pciparm pciparm
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 3.2.0 ]]; then
+ elog "The 'network-cron' USE flag is gone; if you want a more up-to-date"
+ elog "pci.ids file, you should use sys-apps/hwids-99999999 (live ebuild)."
+ fi
+}