summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-04-04 13:18:38 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-04-04 13:35:14 -0500
commit4f609de06a4fbf23b475c4c68e24c870f4f149d2 (patch)
treec56ae1b14afdd0bf81b0c9e13865fbd02839c736 /sys-apps/usbredir
parentsys-apps/usbredir: drop old (diff)
downloadgentoo-4f609de06a4fbf23b475c4c68e24c870f4f149d2.tar.gz
gentoo-4f609de06a4fbf23b475c4c68e24c870f4f149d2.tar.bz2
gentoo-4f609de06a4fbf23b475c4c68e24c870f4f149d2.zip
sys-apps/usbredir: sync live ebuild
Closes: https://bugs.gentoo.org/773148 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sys-apps/usbredir')
-rw-r--r--sys-apps/usbredir/usbredir-0.9.0.ebuild39
-rw-r--r--sys-apps/usbredir/usbredir-9999.ebuild12
2 files changed, 45 insertions, 6 deletions
diff --git a/sys-apps/usbredir/usbredir-0.9.0.ebuild b/sys-apps/usbredir/usbredir-0.9.0.ebuild
new file mode 100644
index 000000000000..0f05f9cc5063
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils flag-o-matic
+
+MY_PV=${PV/_p*/}
+
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="https://www.spice-space.org/usbredir.html"
+SRC_URI="https://www.spice-space.org/download/usbredir/usbredir-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_configure() {
+ # https://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ # noinst_PROGRAMS
+ dobin usbredirtestclient/.libs/usbredirtestclient
+}
diff --git a/sys-apps/usbredir/usbredir-9999.ebuild b/sys-apps/usbredir/usbredir-9999.ebuild
index 86a0a057b70d..ccb3efd6fe2f 100644
--- a/sys-apps/usbredir/usbredir-9999.ebuild
+++ b/sys-apps/usbredir/usbredir-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils flag-o-matic autotools git-r3 ltprune
+inherit eutils flag-o-matic autotools git-r3
DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
HOMEPAGE="https://www.spice-space.org/usbredir.html"
@@ -18,7 +18,7 @@ RDEPEND="virtual/libusb:1"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-DOCS="ChangeLog README* TODO *.txt"
+DOCS="README* TODO *.txt"
src_prepare() {
default
@@ -34,8 +34,8 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -delete || die
# noinst_PROGRAMS
- dobin usbredirtestclient/usbredirtestclient
+ dobin usbredirtestclient/.libs/usbredirtestclient
}