summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-23 05:26:43 +0100
committerSam James <sam@gentoo.org>2022-09-23 06:17:13 +0100
commitb552db48cdea96b6c2179b56469ef052ac28b410 (patch)
tree495eed2158e15229430e83b1993b66905efdbf98 /sys-apps/usbredir
parentwww-client/firefox-bin: add 105.0.1, drop 105.0 (diff)
downloadgentoo-b552db48cdea96b6c2179b56469ef052ac28b410.tar.gz
gentoo-b552db48cdea96b6c2179b56469ef052ac28b410.tar.bz2
gentoo-b552db48cdea96b6c2179b56469ef052ac28b410.zip
sys-apps/usbredir: add 0.13.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/usbredir')
-rw-r--r--sys-apps/usbredir/Manifest1
-rw-r--r--sys-apps/usbredir/metadata.xml16
-rw-r--r--sys-apps/usbredir/usbredir-0.13.0.ebuild25
3 files changed, 34 insertions, 8 deletions
diff --git a/sys-apps/usbredir/Manifest b/sys-apps/usbredir/Manifest
index 7682a1717955..c0d7e4a516ed 100644
--- a/sys-apps/usbredir/Manifest
+++ b/sys-apps/usbredir/Manifest
@@ -1 +1,2 @@
DIST usbredir-0.12.0.tar.bz2 70102 BLAKE2B c6891e14a7951520066fdc7e8095c905599aa3186c72ff378d25e46335843df6daa746937619f8bcb9e60447f19ce671317e9b21e6ce127d2b977d82cb39a337 SHA512 586465d3a18c3bbf621e6b7d1dc24edb333e00491dbd0d0dc781a9e0640f3483a8abf73c55d4ad76b3be0a27a4b1801d08dffb77db3f9aab2234039a60a605ca
+DIST usbredir-usbredir-0.13.0.tar.bz2 68836 BLAKE2B c0efabd12dec51bffa6e639db0a82547ec5c93ca649de823a6240373154d0929df599924ab3868d24ad74c7795202ad92ff1221589f37799944e34424acadf2d SHA512 b71eb1814ef456bebf62bac2e273f9a41b1451ae50941018c36d79298d74ac29c1137b66a4a928fd46c1fcd2905b83d3774fab703d88f9ea7e3e4e14420958ca
diff --git a/sys-apps/usbredir/metadata.xml b/sys-apps/usbredir/metadata.xml
index c2084eae798c..54f0ca7606da 100644
--- a/sys-apps/usbredir/metadata.xml
+++ b/sys-apps/usbredir/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
-<maintainer type="project">
- <email>virtualization@gentoo.org</email>
- <name>Gentoo Virtualization Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-apps/usbredir/usbredir-0.13.0.ebuild b/sys-apps/usbredir/usbredir-0.13.0.ebuild
new file mode 100644
index 000000000000..b7868dee014e
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.13.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="https://www.spice-space.org/usbredir.html https://gitlab.freedesktop.org/spice/usbredir"
+SRC_URI="https://gitlab.freedesktop.org/spice/usbredir/-/archive/${P}/${PN}-${P}.tar.bz2"
+S="${WORKDIR}"/usbredir-${P}
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="dev-libs/glib:2
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ meson_src_install
+ dodoc -r docs/.
+}