summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-10 12:21:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-10 12:21:49 +0100
commitc84572164618637ab7528a9a95946b6bc39d0eb5 (patch)
treeba7ed7f14375447d78610280d44ebd7eae7fbf60 /sys-apps/util-linux
parentsys-fs/btrfs-progs: Removed old (diff)
downloadgentoo-c84572164618637ab7528a9a95946b6bc39d0eb5.tar.gz
gentoo-c84572164618637ab7528a9a95946b6bc39d0eb5.tar.bz2
gentoo-c84572164618637ab7528a9a95946b6bc39d0eb5.zip
sys-apps/util-linux: Fixed cross-compilation
Closes: https://bugs.gentoo.org/654034 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.33.2.ebuild10
-rw-r--r--sys-apps/util-linux/util-linux-2.34-r3.ebuild10
-rw-r--r--sys-apps/util-linux/util-linux-2.35_rc2.ebuild10
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild10
4 files changed, 16 insertions, 24 deletions
diff --git a/sys-apps/util-linux/util-linux-2.33.2.ebuild b/sys-apps/util-linux/util-linux-2.33.2.ebuild
index 1a720970cc0e..8e0e60b9c32c 100644
--- a/sys-apps/util-linux/util-linux-2.33.2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.33.2.ebuild
@@ -92,12 +92,6 @@ src_prepare() {
eautoreconf
fi
- # Undo bad ncurses handling by upstream. #601530
- sed -i -E \
- -e '/NCURSES_/s:(ncursesw?)[56]-config:$PKG_CONFIG \1:' \
- -e 's:(ncursesw?)[56]-config --version:$PKG_CONFIG --exists --print-errors \1:' \
- configure || die
-
elibtoolize
}
@@ -143,6 +137,10 @@ multilib_src_configure() {
export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
+ # Undo bad ncurses handling by upstream. Fall back to pkg-config. #601530
+ export NCURSES6_CONFIG=false NCURSES5_CONFIG=false
+ export NCURSESW6_CONFIG=false NCURSESW5_CONFIG=false
+
local myeconfargs=(
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"
--with-bashcompletiondir="$(get_bashcompdir)"
diff --git a/sys-apps/util-linux/util-linux-2.34-r3.ebuild b/sys-apps/util-linux/util-linux-2.34-r3.ebuild
index 695600399139..18ce20510634 100644
--- a/sys-apps/util-linux/util-linux-2.34-r3.ebuild
+++ b/sys-apps/util-linux/util-linux-2.34-r3.ebuild
@@ -91,12 +91,6 @@ src_prepare() {
eautoreconf
fi
- # Undo bad ncurses handling by upstream. #601530
- sed -i -E \
- -e '/NCURSES_/s:(ncursesw?)[56]-config:$PKG_CONFIG \1:' \
- -e 's:(ncursesw?)[56]-config --version:$PKG_CONFIG --exists --print-errors \1:' \
- configure || die
-
elibtoolize
}
@@ -143,6 +137,10 @@ multilib_src_configure() {
export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
+ # Undo bad ncurses handling by upstream. Fall back to pkg-config. #601530
+ export NCURSES6_CONFIG=false NCURSES5_CONFIG=false
+ export NCURSESW6_CONFIG=false NCURSESW5_CONFIG=false
+
# configure args shared by python and non-python builds
local commonargs=(
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"
diff --git a/sys-apps/util-linux/util-linux-2.35_rc2.ebuild b/sys-apps/util-linux/util-linux-2.35_rc2.ebuild
index cfaef7723246..f1759d4eb6c3 100644
--- a/sys-apps/util-linux/util-linux-2.35_rc2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.35_rc2.ebuild
@@ -92,12 +92,6 @@ src_prepare() {
eautoreconf
fi
- # Undo bad ncurses handling by upstream. #601530
- sed -i -E \
- -e '/NCURSES_/s:(ncursesw?)[56]-config:$PKG_CONFIG \1:' \
- -e 's:(ncursesw?)[56]-config --version:$PKG_CONFIG --exists --print-errors \1:' \
- configure || die
-
elibtoolize
}
@@ -144,6 +138,10 @@ multilib_src_configure() {
export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
+ # Undo bad ncurses handling by upstream. Fall back to pkg-config. #601530
+ export NCURSES6_CONFIG=false NCURSES5_CONFIG=false
+ export NCURSESW6_CONFIG=false NCURSESW5_CONFIG=false
+
# configure args shared by python and non-python builds
local commonargs=(
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index cfaef7723246..f1759d4eb6c3 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -92,12 +92,6 @@ src_prepare() {
eautoreconf
fi
- # Undo bad ncurses handling by upstream. #601530
- sed -i -E \
- -e '/NCURSES_/s:(ncursesw?)[56]-config:$PKG_CONFIG \1:' \
- -e 's:(ncursesw?)[56]-config --version:$PKG_CONFIG --exists --print-errors \1:' \
- configure || die
-
elibtoolize
}
@@ -144,6 +138,10 @@ multilib_src_configure() {
export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
+ # Undo bad ncurses handling by upstream. Fall back to pkg-config. #601530
+ export NCURSES6_CONFIG=false NCURSES5_CONFIG=false
+ export NCURSESW6_CONFIG=false NCURSESW5_CONFIG=false
+
# configure args shared by python and non-python builds
local commonargs=(
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"