summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-27 21:55:58 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-27 22:15:50 +0100
commit7fc8e22c72d9b9956bcc639b0ef6aa31cf36dacf (patch)
tree5e9c3f3268cea11b08afdd348a31f2f80cc180ec /sys-apps
parentsci-electronics/ngspice: correct the logic in autoconf fftw patch (diff)
downloadgentoo-7fc8e22c72d9b9956bcc639b0ef6aa31cf36dacf.tar.gz
gentoo-7fc8e22c72d9b9956bcc639b0ef6aa31cf36dacf.tar.bz2
gentoo-7fc8e22c72d9b9956bcc639b0ef6aa31cf36dacf.zip
sys-apps/isapnptools: Port to EAPI 6
Closes: https://bugs.gentoo.org/622768 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/isapnptools/files/isapnptools-1.27-include.patch4
-rw-r--r--sys-apps/isapnptools/isapnptools-1.27.ebuild18
2 files changed, 9 insertions, 13 deletions
diff --git a/sys-apps/isapnptools/files/isapnptools-1.27-include.patch b/sys-apps/isapnptools/files/isapnptools-1.27-include.patch
index a736ccc1eb9d..016490eba449 100644
--- a/sys-apps/isapnptools/files/isapnptools-1.27-include.patch
+++ b/sys-apps/isapnptools/files/isapnptools-1.27-include.patch
@@ -1,5 +1,5 @@
---- src/callbacks.c.org 2001-05-15 22:37:04.000000000 +0200
-+++ src/callbacks.c 2011-06-15 05:21:32.292819557 +0200
+--- a/src/callbacks.c
++++ b/src/callbacks.c
@@ -51,6 +51,7 @@
#include <stdio.h>
#include <errno.h>
diff --git a/sys-apps/isapnptools/isapnptools-1.27.ebuild b/sys-apps/isapnptools/isapnptools-1.27.ebuild
index 47812b883bf9..c95092405332 100644
--- a/sys-apps/isapnptools/isapnptools-1.27.ebuild
+++ b/sys-apps/isapnptools/isapnptools-1.27.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
-
-inherit eutils
+EAPI=6
DESCRIPTION="Tools for configuring ISA PnP devices"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -14,18 +12,16 @@ SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-include.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-include.patch )
src_install() {
- emake DESTDIR="${D}" install || die
+ default
+
dodir /sbin
- mv "${D}"/usr/sbin/isapnp "${D}"/sbin/ || die
+ mv "${ED%/}"/{usr/sbin/isapnp,sbin/} || die
- dodoc AUTHORS ChangeLog README NEWS
docinto txt
- dodoc doc/README* doc/*.txt test/*.txt
+ dodoc doc/{README*,*.txt} test/*.txt
dodoc etc/isapnp.*
newinitd "${FILESDIR}"/isapnp.rc isapnp