summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-07-09 17:45:57 +0100
committerJustin Lecher <jlec@gentoo.org>2017-07-09 19:48:30 +0100
commit714a00a60e76f99149e3728448325aff52842da9 (patch)
treee31338a670b8e464a0eb5352bd19aabba8fb76e4 /sys-auth/munge/munge-0.5.12.ebuild
parentsys-cluster/slurm: Version Bump (diff)
downloadgentoo-714a00a60e76f99149e3728448325aff52842da9.tar.gz
gentoo-714a00a60e76f99149e3728448325aff52842da9.tar.bz2
gentoo-714a00a60e76f99149e3728448325aff52842da9.zip
sys-auth/munge: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=622298 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-auth/munge/munge-0.5.12.ebuild')
-rw-r--r--sys-auth/munge/munge-0.5.12.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-auth/munge/munge-0.5.12.ebuild b/sys-auth/munge/munge-0.5.12.ebuild
new file mode 100644
index 000000000000..be4d2881ee1f
--- /dev/null
+++ b/sys-auth/munge/munge-0.5.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools user prefix
+
+DESCRIPTION="An authentication service for creating and validating credentials"
+HOMEPAGE="https://github.com/dun/munge"
+SRC_URI="https://github.com/dun/munge/releases/download/munge-${PV}/munge-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gcrypt"
+
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ !gcrypt? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup munge
+ enewuser munge -1 -1 /var/lib/munge munge
+}
+
+src_prepare() {
+ default
+
+ hprefixify config/x_ac_path_openssl.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --with-crypto-lib=$(usex gcrypt libgcrypt openssl)
+}
+
+src_install() {
+ local d
+
+ default
+
+ # 450830
+ if [ -d "${ED}"/var/run ]; then
+ rm -rf "${ED}"/var/run || die
+ fi
+
+ dodir /etc/munge
+
+ for d in "init.d" "default" "sysconfig"; do
+ if [ -d "${ED}"/etc/${d} ]; then
+ rm -r "${ED}"/etc/${d} || die
+ fi
+ done
+
+ newconfd "$(prefixify_ro "${FILESDIR}"/${PN}d.confd)" ${PN}d
+ newinitd "$(prefixify_ro "${FILESDIR}"/${PN}d.initd)" ${PN}d
+}