summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-01-19 22:16:13 +0100
committerDavid Seifert <soap@gentoo.org>2019-01-19 22:18:45 +0100
commit9a761e22a1a360e1578d0a6f70115e823fcd93c5 (patch)
tree8fc23fb1af8043e87d4dc727f5b3b7518ed40cea /sys-auth/pam_ssh
parentnet-analyzer/nagios-core: new revision to fix CGI install path. (diff)
downloadgentoo-9a761e22a1a360e1578d0a6f70115e823fcd93c5.tar.gz
gentoo-9a761e22a1a360e1578d0a6f70115e823fcd93c5.tar.bz2
gentoo-9a761e22a1a360e1578d0a6f70115e823fcd93c5.zip
sys-auth/pam_ssh: Version bump to 2.3
Bug: https://bugs.gentoo.org/674194 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-auth/pam_ssh')
-rw-r--r--sys-auth/pam_ssh/Manifest1
-rw-r--r--sys-auth/pam_ssh/pam_ssh-2.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-auth/pam_ssh/Manifest b/sys-auth/pam_ssh/Manifest
index 84a053bb6ba6..36a20f3eb30e 100644
--- a/sys-auth/pam_ssh/Manifest
+++ b/sys-auth/pam_ssh/Manifest
@@ -1,3 +1,4 @@
DIST pam_ssh-1.98.tar.bz2 292989 BLAKE2B 08744c6649aa58c7221e5ec07e0c6aefa8d045cf30df01b941962d29f3abdae902b0fbad37923e3ff05536e422a1062732a6998e4b58d978d369df3d866ec1aa SHA512 bf6da4ced0619549d56516c6b24e899664e0948da7a0cc04ff1b536d06cc8c26242c83eb36ed835668c824b777e270aa293162ac77e3c479311386e6e5da39ff
DIST pam_ssh-2.1.tar.xz 361000 BLAKE2B f22836af20b41ae7254f816c33793bb3a128b604ec36a20b207610deebf61f4d5dd070fd6f5093c6f7b6eb9e14f85cd81ddbbed7e97ee581124e5335722d036b SHA512 8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640
DIST pam_ssh-2.2.tar.xz 382244 BLAKE2B b3e6122530244add64400a6c4ea9811eb6feb0309b11d9ad17d800c3ced555f5459a8dc55ec58b0649017bcce9fb12417d4ba52ab2acd3acdf5e4a0cfe956e57 SHA512 b3caeb6065b2ac925cfd1a12107902f8474badfa1770d6499508d00bf41b54497fa17080f84af9dde0b6b7692d4bd58d33d94257c3106dac7eee79ebcf3b4692
+DIST pam_ssh-2.3.tar.xz 380396 BLAKE2B e228e30c6f353f631c0a1c41e82e31e7a8c573b04ab1cad4038a245b500666b42c0efa9f686d28f2386688596de761085afb1318b94fef5541f8c0ffc1e18b25 SHA512 e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895
diff --git a/sys-auth/pam_ssh/pam_ssh-2.3.ebuild b/sys-auth/pam_ssh/pam_ssh-2.3.ebuild
new file mode 100644
index 000000000000..43bb29b987aa
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-2.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.xz"
+
+LICENSE="BSD-2 BSD ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# Only supports OpenSSH via `ssh-agent` #282993
+DEPEND="virtual/pam
+ dev-libs/openssl:0="
+RDEPEND="${DEPEND}
+ net-misc/openssh"
+
+PATCHES=(
+ # 503424#c5
+ "${FILESDIR}"/${PN}-2.1-dot-ssh-check.patch
+)
+
+src_configure() {
+ # hide all the otherwise-exported symbols that may clash with
+ # other software loading the PAM modules (see bug #274924 as an
+ # example).
+ append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
+
+ # Set the cache var so the configure script doesn't go probing hardcoded
+ # file system paths and picking up the wrong thing.
+ export ac_cv_openssldir=''
+
+ # Avoid cross-compiling funkiness and requiring openssh at build time.
+ export PATH_SSH_AGENT="${EPREFIX}/usr/bin/ssh-agent"
+
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)"
+}
+
+src_install() {
+ default
+
+ # pam_ssh only builds plugins
+ find "${D}" -name '*.la' -delete || die
+
+ local DOC_CONTENTS="
+ You can enable pam_ssh for system authentication by enabling
+ the pam_ssh USE flag on sys-auth/pambase.
+ "
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ local i
+ for i in "${REPLACING_VERSIONS}"; do
+ if [[ ${i} == 1.* ]]; then #554150
+ ewarn "Upstream pam_ssh has changed where ssh keys live. Only keys in your"
+ ewarn "~/.ssh/login-keys.d/ will be accepted for authentication."
+ return
+ fi
+ done
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}