summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-12-02 14:48:25 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-12-02 16:07:25 -0500
commit6044543a51420f5567e9871d23eb4c72082b1443 (patch)
tree9162a569506cf20b65e0fb30232b79a0d79266dc /sys-auth/ykpers
parentapp-text/pdftk: Version bump (diff)
downloadgentoo-6044543a51420f5567e9871d23eb4c72082b1443.tar.gz
gentoo-6044543a51420f5567e9871d23eb4c72082b1443.tar.bz2
gentoo-6044543a51420f5567e9871d23eb4c72082b1443.zip
sys-auth/ykpers: bump to 1.20.0
Package-Manager: Portage-2.3.69, Repoman-2.3.14 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'sys-auth/ykpers')
-rw-r--r--sys-auth/ykpers/Manifest1
-rw-r--r--sys-auth/ykpers/ykpers-1.20.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/ykpers/Manifest b/sys-auth/ykpers/Manifest
index 5d485cb92028..1b43a48213f0 100644
--- a/sys-auth/ykpers/Manifest
+++ b/sys-auth/ykpers/Manifest
@@ -2,3 +2,4 @@ DIST ykpers-1.18.0.tar.gz 124932 BLAKE2B 48e7045429081c1e577ca560b3a10a4cc380820
DIST ykpers-1.18.1.tar.gz 125397 BLAKE2B 7393373414f9f2f9474408c86b8abba0f2034f5908ab8c14fd1dbf9acab40994b43b19031a58f5e889acaf289869b82bd429199237da173e3fa19154b4424374 SHA512 faf9c98fc41a64ae17e2002cd22e89fa2f51de9941aa6eb10c49aa78fd2e2867a5d47fc91fd91ab8e916117cba08629f3f1b076d91698ac2fee6e43366d948a8
DIST ykpers-1.19.0.tar.gz 125960 BLAKE2B 8b0ce106ec0c6e390f13e960f26d64bf17e4f481f8bf4cdfb29f050bdbcc9f73750993caa00c46f6bc0c59a8cef0891d2d4fa97cea96084b0c9a762adfc3f81a SHA512 413f81325782f0d71501d3dbf5aaaf646bd5dc02d87308a7f650044dfe860dc13b7cef11afa8794df3049c729e10da33ffad86e3f148ac429ee64685bf0fe56e
DIST ykpers-1.19.3.tar.gz 127789 BLAKE2B 8dfc2751be92e69fcf98f5dc75d87eb170a4f70ff13faa321a85d4a04e27818823acbf02284ba23cb78ea758111513457ced4cdaa6961621a91f68b059eff378 SHA512 436c9807e488f7b324b892da7bfc7ea93e2b746cc3ae075822e9e8bfe478ef8e61c194127e5d4f50f6c1d9512292640d033464cceb6b8a18069411ff7993cc52
+DIST ykpers-1.20.0.tar.gz 127975 BLAKE2B 8753332be4df3eeb6ef0489782037fca12883a263d5697cfaee901763e4698ca5415953da1c2f8b3512de041c1e78735c03a5e6ea2101c71ada36d4e6d5d3d2d SHA512 a38b26700793f0a801e5f5889bbbce4a3f728d22aaecf8d0890f1b5135e67bed16a78b7a36dbc323c5d296901f6dd420fa658a982492a0cd9f0bbf95a5fbc823
diff --git a/sys-auth/ykpers/ykpers-1.20.0.ebuild b/sys-auth/ykpers/ykpers-1.20.0.ebuild
new file mode 100644
index 000000000000..4db6dbd05bb2
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.20.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="consolekit static-libs"
+
+DEPEND="
+ dev-libs/json-c:=
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )
+"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)
+ --localstatedir=/var
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ udev_dorules 69-yubikey.rules
+ if use consolekit ; then
+ udev_dorules 70-yubikey.rules
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}