summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-auth
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/authenticator/authenticator-0.2.4.ebuild3
-rw-r--r--sys-auth/authenticator/authenticator-9999.ebuild3
-rw-r--r--sys-auth/consolekit/consolekit-0.4.6.ebuild1
-rw-r--r--sys-auth/consolekit/consolekit-1.1.0-r1.ebuild1
-rw-r--r--sys-auth/consolekit/consolekit-1.1.2.ebuild1
-rw-r--r--sys-auth/consolekit/consolekit-1.2.0.ebuild1
-rw-r--r--sys-auth/consolekit/consolekit-1.2.1.ebuild1
-rw-r--r--sys-auth/consolekit/consolekit-9999.ebuild1
-rw-r--r--sys-auth/keystone/keystone-14.1.0-r1.ebuild1
-rw-r--r--sys-auth/keystone/keystone-15.0.0.ebuild1
-rw-r--r--sys-auth/keystone/keystone-16.0.0.ebuild1
-rw-r--r--sys-auth/keystone/keystone-2018.2.9999.ebuild1
-rw-r--r--sys-auth/keystone/keystone-2019.1.9999.ebuild1
-rw-r--r--sys-auth/keystone/keystone-2019.2.9999.ebuild1
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.13.ebuild3
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.10.ebuild1
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11.ebuild1
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild1
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild1
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.26.ebuild1
-rw-r--r--sys-auth/polkit/polkit-0.115-r3.ebuild1
-rw-r--r--sys-auth/polkit/polkit-0.115-r4.ebuild1
-rw-r--r--sys-auth/polkit/polkit-0.116-r1.ebuild1
-rw-r--r--sys-auth/sssd/sssd-1.16.3-r3.ebuild1
-rw-r--r--sys-auth/sssd/sssd-2.1.0-r1.ebuild1
-rw-r--r--sys-auth/sssd/sssd-2.2.0-r1.ebuild1
-rw-r--r--sys-auth/sssd/sssd-2.2.2.ebuild1
-rw-r--r--sys-auth/sssd/sssd-2.2.3.ebuild1
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild3
-rw-r--r--sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.25.ebuild3
30 files changed, 35 insertions, 5 deletions
diff --git a/sys-auth/authenticator/authenticator-0.2.4.ebuild b/sys-auth/authenticator/authenticator-0.2.4.ebuild
index f3d4d2cdf2b4..4370f05ea9f1 100644
--- a/sys-auth/authenticator/authenticator-0.2.4.ebuild
+++ b/sys-auth/authenticator/authenticator-0.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ LICENSE="GPL-2+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
app-crypt/libsecret
diff --git a/sys-auth/authenticator/authenticator-9999.ebuild b/sys-auth/authenticator/authenticator-9999.ebuild
index 5d876f945946..6420c495fd1d 100644
--- a/sys-auth/authenticator/authenticator-9999.ebuild
+++ b/sys-auth/authenticator/authenticator-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ LICENSE="GPL-2+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
app-crypt/libsecret
diff --git a/sys-auth/consolekit/consolekit-0.4.6.ebuild b/sys-auth/consolekit/consolekit-0.4.6.ebuild
index 6ca3d9403a79..33e76611a7d4 100644
--- a/sys-auth/consolekit/consolekit-0.4.6.ebuild
+++ b/sys-auth/consolekit/consolekit-0.4.6.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="acl debug doc kernel_linux pam policykit selinux systemd-units test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.38.2-r1:2=
diff --git a/sys-auth/consolekit/consolekit-1.1.0-r1.ebuild b/sys-auth/consolekit/consolekit-1.1.0-r1.ebuild
index 70804b8097fe..10e8664dc1ea 100644
--- a/sys-auth/consolekit/consolekit-1.1.0-r1.ebuild
+++ b/sys-auth/consolekit/consolekit-1.1.0-r1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="acl cgroups debug doc kernel_linux pam pm-utils policykit selinux test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
>=sys-devel/gettext-0.19
diff --git a/sys-auth/consolekit/consolekit-1.1.2.ebuild b/sys-auth/consolekit/consolekit-1.1.2.ebuild
index 93fe492add30..8f79f9dc4eb9 100644
--- a/sys-auth/consolekit/consolekit-1.1.2.ebuild
+++ b/sys-auth/consolekit/consolekit-1.1.2.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="acl cgroups debug doc evdev kernel_linux pam pm-utils policykit selinux test udev"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
>=sys-devel/gettext-0.19
diff --git a/sys-auth/consolekit/consolekit-1.2.0.ebuild b/sys-auth/consolekit/consolekit-1.2.0.ebuild
index 5590380a4de4..e6537287196d 100644
--- a/sys-auth/consolekit/consolekit-1.2.0.ebuild
+++ b/sys-auth/consolekit/consolekit-1.2.0.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 s390 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="acl cgroups debug doc evdev kernel_linux pam pm-utils policykit selinux test udev"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
>=sys-devel/gettext-0.19
diff --git a/sys-auth/consolekit/consolekit-1.2.1.ebuild b/sys-auth/consolekit/consolekit-1.2.1.ebuild
index 3abe3b1223e3..7524606bce9c 100644
--- a/sys-auth/consolekit/consolekit-1.2.1.ebuild
+++ b/sys-auth/consolekit/consolekit-1.2.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="acl cgroups debug doc evdev kernel_linux pam pm-utils policykit selinux test udev"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
>=sys-devel/gettext-0.19
diff --git a/sys-auth/consolekit/consolekit-9999.ebuild b/sys-auth/consolekit/consolekit-9999.ebuild
index 1a117950fc20..f1eae0723ce0 100644
--- a/sys-auth/consolekit/consolekit-9999.ebuild
+++ b/sys-auth/consolekit/consolekit-9999.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="acl cgroups debug doc evdev kernel_linux pam pm-utils policykit selinux test udev"
+RESTRICT="!test? ( test )"
COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
>=sys-devel/gettext-0.19
diff --git a/sys-auth/keystone/keystone-14.1.0-r1.ebuild b/sys-auth/keystone/keystone-14.1.0-r1.ebuild
index 90bcda615c90..c3b08efde1bf 100644
--- a/sys-auth/keystone/keystone-14.1.0-r1.ebuild
+++ b/sys-auth/keystone/keystone-14.1.0-r1.ebuild
@@ -24,6 +24,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-15.0.0.ebuild b/sys-auth/keystone/keystone-15.0.0.ebuild
index 20b6563cf0f8..c8e8e9254931 100644
--- a/sys-auth/keystone/keystone-15.0.0.ebuild
+++ b/sys-auth/keystone/keystone-15.0.0.ebuild
@@ -24,6 +24,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-16.0.0.ebuild b/sys-auth/keystone/keystone-16.0.0.ebuild
index 0faa948d08ee..56e6a6a487a0 100644
--- a/sys-auth/keystone/keystone-16.0.0.ebuild
+++ b/sys-auth/keystone/keystone-16.0.0.ebuild
@@ -22,6 +22,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-2018.2.9999.ebuild b/sys-auth/keystone/keystone-2018.2.9999.ebuild
index 310ce876be82..f8dc6fe7f83f 100644
--- a/sys-auth/keystone/keystone-2018.2.9999.ebuild
+++ b/sys-auth/keystone/keystone-2018.2.9999.ebuild
@@ -24,6 +24,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-2019.1.9999.ebuild b/sys-auth/keystone/keystone-2019.1.9999.ebuild
index a553b77a52c0..91c67d50268d 100644
--- a/sys-auth/keystone/keystone-2019.1.9999.ebuild
+++ b/sys-auth/keystone/keystone-2019.1.9999.ebuild
@@ -24,6 +24,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-2019.2.9999.ebuild b/sys-auth/keystone/keystone-2019.2.9999.ebuild
index d46c5c4329c3..df89d7fcb7cc 100644
--- a/sys-auth/keystone/keystone-2019.2.9999.ebuild
+++ b/sys-auth/keystone/keystone-2019.2.9999.ebuild
@@ -22,6 +22,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-auth/nss-mdns/nss-mdns-0.13.ebuild b/sys-auth/nss-mdns/nss-mdns-0.13.ebuild
index dc8347e21d45..ab553653c84e 100644
--- a/sys-auth/nss-mdns/nss-mdns-0.13.ebuild
+++ b/sys-auth/nss-mdns/nss-mdns-0.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~mips ppc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.10.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.10.ebuild
index d228d7658e4e..cd3b7304b1d2 100644
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.10.ebuild
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.10.ebuild
@@ -14,6 +14,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug kerberos +pam pynslcd sasl test +utils"
+RESTRICT="!test? ( test )"
COMMON_DEP="
net-nds/openldap[${MULTILIB_USEDEP}]
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11.ebuild
index 3baa31da0728..ac134db85497 100644
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11.ebuild
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11.ebuild
@@ -14,6 +14,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug kerberos +pam pynslcd sasl test +utils"
+RESTRICT="!test? ( test )"
COMMON_DEP="
net-nds/openldap[${MULTILIB_USEDEP}]
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild
index 6d03d4f004a2..12e5caf3e61b 100644
--- a/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild
@@ -12,6 +12,7 @@ LICENSE="GPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="pam pskc test"
+RESTRICT="!test? ( test )"
RDEPEND="
pam? ( sys-libs/pam )
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
index 516a4c43627f..00237b0bc4e0 100644
--- a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
@@ -12,6 +12,7 @@ LICENSE="GPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
IUSE="pam pskc test"
+RESTRICT="!test? ( test )"
RDEPEND="
pam? ( sys-libs/pam )
diff --git a/sys-auth/pam_yubico/pam_yubico-2.26.ebuild b/sys-auth/pam_yubico/pam_yubico-2.26.ebuild
index 3e76d513cb70..d02d30e11751 100644
--- a/sys-auth/pam_yubico/pam_yubico-2.26.ebuild
+++ b/sys-auth/pam_yubico/pam_yubico-2.26.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ldap test"
+RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/pam
diff --git a/sys-auth/polkit/polkit-0.115-r3.ebuild b/sys-auth/polkit/polkit-0.115-r3.ebuild
index e4523a579013..26a30167b91b 100644
--- a/sys-auth/polkit/polkit-0.115-r3.ebuild
+++ b/sys-auth/polkit/polkit-0.115-r3.ebuild
@@ -13,6 +13,7 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 s390 ~sh x86"
IUSE="consolekit elogind examples gtk +introspection jit kde nls pam selinux systemd test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="^^ ( consolekit elogind systemd )"
diff --git a/sys-auth/polkit/polkit-0.115-r4.ebuild b/sys-auth/polkit/polkit-0.115-r4.ebuild
index a9431f5df265..13c3a9edf1b5 100644
--- a/sys-auth/polkit/polkit-0.115-r4.ebuild
+++ b/sys-auth/polkit/polkit-0.115-r4.ebuild
@@ -13,6 +13,7 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
IUSE="consolekit elogind examples gtk +introspection jit kde nls pam selinux systemd test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="^^ ( consolekit elogind systemd )"
diff --git a/sys-auth/polkit/polkit-0.116-r1.ebuild b/sys-auth/polkit/polkit-0.116-r1.ebuild
index 542b784f5825..4de2acf495fc 100644
--- a/sys-auth/polkit/polkit-0.116-r1.ebuild
+++ b/sys-auth/polkit/polkit-0.116-r1.ebuild
@@ -13,6 +13,7 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="consolekit elogind examples gtk +introspection jit kde nls pam selinux systemd test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="^^ ( consolekit elogind systemd )"
diff --git a/sys-auth/sssd/sssd-1.16.3-r3.ebuild b/sys-auth/sssd/sssd-1.16.3-r3.ebuild
index 80746e164106..cc419dffd97a 100644
--- a/sys-auth/sssd/sssd-1.16.3-r3.ebuild
+++ b/sys-auth/sssd/sssd-1.16.3-r3.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
LICENSE="GPL-3"
SLOT="0"
IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
+RESTRICT="!test? ( test )"
COMMON_DEP="
>=sys-libs/pam-0-r1[${MULTILIB_USEDEP}]
diff --git a/sys-auth/sssd/sssd-2.1.0-r1.ebuild b/sys-auth/sssd/sssd-2.1.0-r1.ebuild
index e89158a50907..1e5fa63b4082 100644
--- a/sys-auth/sssd/sssd-2.1.0-r1.ebuild
+++ b/sys-auth/sssd/sssd-2.1.0-r1.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
LICENSE="GPL-3"
SLOT="0"
IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
+RESTRICT="!test? ( test )"
COMMON_DEP="
>=sys-libs/pam-0-r1[${MULTILIB_USEDEP}]
diff --git a/sys-auth/sssd/sssd-2.2.0-r1.ebuild b/sys-auth/sssd/sssd-2.2.0-r1.ebuild
index e89158a50907..1e5fa63b4082 100644
--- a/sys-auth/sssd/sssd-2.2.0-r1.ebuild
+++ b/sys-auth/sssd/sssd-2.2.0-r1.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
LICENSE="GPL-3"
SLOT="0"
IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
+RESTRICT="!test? ( test )"
COMMON_DEP="
>=sys-libs/pam-0-r1[${MULTILIB_USEDEP}]
diff --git a/sys-auth/sssd/sssd-2.2.2.ebuild b/sys-auth/sssd/sssd-2.2.2.ebuild
index e89158a50907..1e5fa63b4082 100644
--- a/sys-auth/sssd/sssd-2.2.2.ebuild
+++ b/sys-auth/sssd/sssd-2.2.2.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
LICENSE="GPL-3"
SLOT="0"
IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
+RESTRICT="!test? ( test )"
COMMON_DEP="
>=sys-libs/pam-0-r1[${MULTILIB_USEDEP}]
diff --git a/sys-auth/sssd/sssd-2.2.3.ebuild b/sys-auth/sssd/sssd-2.2.3.ebuild
index e89158a50907..1e5fa63b4082 100644
--- a/sys-auth/sssd/sssd-2.2.3.ebuild
+++ b/sys-auth/sssd/sssd-2.2.3.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
LICENSE="GPL-3"
SLOT="0"
IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
+RESTRICT="!test? ( test )"
COMMON_DEP="
>=sys-libs/pam-0-r1[${MULTILIB_USEDEP}]
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild
index 5bbb1bafd01d..64ebd5a99bb2 100644
--- a/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="BSD-2"
SLOT="0/1"
KEYWORDS="~amd64"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/openssl:0=[-bindist]
diff --git a/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.25.ebuild b/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.25.ebuild
index e3c1da150af0..d539535d1491 100644
--- a/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.25.ebuild
+++ b/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ KEYWORDS="~amd64"
SLOT="0"
LICENSE="BSD-2"
IUSE="debug test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/glib:2