summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-31 14:00:33 -0400
committerSam James <sam@gentoo.org>2024-04-01 00:33:46 +0100
commit0cb85923dadaa502397f9df19c57d83421675934 (patch)
tree2669c07710b67c83beaae8423fa8e5d26cc45025 /sys-boot/vboot-utils
parentsys-devel/gcc: add 14.0.1_pre20240331 (diff)
downloadgentoo-0cb85923dadaa502397f9df19c57d83421675934.tar.gz
gentoo-0cb85923dadaa502397f9df19c57d83421675934.tar.bz2
gentoo-0cb85923dadaa502397f9df19c57d83421675934.zip
sys-boot/vboot-utils: mark as LTO-unsafe
Cannot be tested, because tests fail LTO. Not reporting since this is ancient chromiumOS code from years and years ago, and frankly it seems like shouting into a void. Closes: https://bugs.gentoo.org/880175 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot/vboot-utils')
-rw-r--r--sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild b/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild
index 67f272d57fa0..e409d0298875 100644
--- a/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild
+++ b/sys-boot/vboot-utils/vboot-utils-80_p20200108.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
# Can't use gitiles directly until b/19710536 is fixed.
# This is the name of the latest release branch.
@@ -69,6 +69,7 @@ src_prepare() {
}
_emake() {
+
local arch=$(tc-arch)
emake \
V=1 \
@@ -85,6 +86,10 @@ _emake() {
}
src_compile() {
+ # -Werror=lto-type-mismatch in tests
+ # https://bugs.gentoo.org/880175
+ filter-lto
+
tc-export CC AR CXX PKG_CONFIG
_emake FUZZ_TEST_BINS= TEST_BINS= all
}