summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-11 18:54:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-11 19:30:05 +0100
commit47b470781ecebce0eaff91f6f057f10b98639537 (patch)
treecf3045213e4198cf583929c28edd32568fcd631d /sys-boot
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.243,4.9.243,4.14.2... (diff)
downloadgentoo-47b470781ecebce0eaff91f6f057f10b98639537.tar.gz
gentoo-47b470781ecebce0eaff91f6f057f10b98639537.tar.bz2
gentoo-47b470781ecebce0eaff91f6f057f10b98639537.zip
sys-boot/unetbootin: 700 version bump
Bug: https://bugs.gentoo.org/699312 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/Manifest1
-rw-r--r--sys-boot/unetbootin/unetbootin-700.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index 27e5e95bad9d..948784c33dc1 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -4,3 +4,4 @@ DIST unetbootin-675-qt5.patch.xz 7636 BLAKE2B f8c475491e6cf0557a192380726376c1da
DIST unetbootin-675.tar.gz 23221792 BLAKE2B fb3a6fce9d2a47b83e2e4c1a579d20594a637215b7c6456d6b0a59a592da660b13bdbea52aa5a4f902e410e9d0e2d447d085f040d321029a96b7ff957a59d11e SHA512 7cb5da4a876125ff010fc6a5aab2b5bb6eeec0f1ac6f2dd86efa2c3eaebaedff8c2167f9dc77053936955703cd2a98dd11a84b8de930dcfc1c2b0f6aeaf7ee61
DIST unetbootin-677.tar.gz 23479226 BLAKE2B b5a5b111c5f96cc603975f535b55dd8e6191cc92972f54591ae6673394abae15e2652f737b8dc02f8b26a1247a9663cbda3b0d2d7b8b8dfe9eb117711f08d053 SHA512 f86b25dabc27f12bdb65a590c4ffa25aa509a78aa29cecde73918d8bc36dc3e6597b2b7e1803f7fa86a884347506e9c25b361ce89c26e0f6449e0c1ef29355d1
DIST unetbootin-681.tar.gz 23481527 BLAKE2B b8c75156539a07bdacf1185ed898867b1e3df91a87486b7291e4bffc0c754c1ea3fe8a13a2ade5507a886e05904daa90877d29bd72ae1c353cb20dd64264e391 SHA512 9ac8c51f3b65bd6f051caa0270c239ec8aaabb2d3b92bec7b18803d3dcfdbe2bbca4e25124477f4e7b83ee10ba2aa08cdf055e8c9bb042cbebcd3ff6a96315b9
+DIST unetbootin-700.tar.gz 16694955 BLAKE2B d8c00b56c5ae2daac696b62ef207c62dc91f67699c8823e2a751eff536d03fd0a50a931e9a4598b05d99be968b7e895ab521f605b4e0080d591a34c9e67f685e SHA512 0d1b23dddf0e0e3eca81f8ef07fe375f0867ee3fa631c3a3cfe33a846b8d704b36e0efe4c947d7c68e5c1bff370ba87c34aa52c5bf8fc414cd89777f9f1858b7
diff --git a/sys-boot/unetbootin/unetbootin-700.ebuild b/sys-boot/unetbootin/unetbootin-700.ebuild
new file mode 100644
index 000000000000..b5809cfc55d5
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-700.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils xdg-utils toolchain-funcs
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="https://github.com/unetbootin/unetbootin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-675-desktop.patch )
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ append-cflags -DNOSTATIC
+ append-cxxflags -DNOSTATIC
+}
+
+src_configure() {
+ export QMAKE_CXX="$(tc-getCXX)"
+
+ "$(qt5_get_bindir)/"lrelease ${PN}.pro || die
+
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}