summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-10 18:29:50 +0000
committerSam James <sam@gentoo.org>2021-01-10 18:30:00 +0000
commit8ea14599e99ef09450ea4abd40a1a4de598ce109 (patch)
tree2a1a4fff42e1f193c42014870663c2f0f5b61cdf /sys-boot
parentsys-fs/avfs: bump to 1.1.3 (diff)
downloadgentoo-8ea14599e99ef09450ea4abd40a1a4de598ce109.tar.gz
gentoo-8ea14599e99ef09450ea4abd40a1a4de598ce109.tar.bz2
gentoo-8ea14599e99ef09450ea4abd40a1a4de598ce109.zip
sys-boot/refind: fix build with Bash 5.1
Reported-by: Greg Turner <gmt@be-evil.net> Closes: https://bugs.gentoo.org/762379 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/refind-0.11.4.ebuild8
-rw-r--r--sys-boot/refind/refind-0.12.0-r1.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-boot/refind/refind-0.11.4.ebuild b/sys-boot/refind/refind-0.11.4.ebuild
index 139bf622501d..37ad051eba4d 100644
--- a/sys-boot/refind/refind-0.11.4.ebuild
+++ b/sys-boot/refind/refind-0.11.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -99,9 +99,9 @@ src_compile() {
EFILIB="/usr/$(get_libdir)"
EFICRT0="/usr/$(get_libdir)"
EDK2BASE="${UDK_WORKSPACE}"
- EDK2_DRIVER_BASENAMES="${fs_names[@]}"
- FILESYSTEMS="${fs_names[@]}"
- FILESYSTEMS_GNUEFI="${fs_names[@]}"
+ EDK2_DRIVER_BASENAMES="${fs_names[*]}"
+ FILESYSTEMS="${fs_names[*]}"
+ FILESYSTEMS_GNUEFI="${fs_names[*]}"
)
if use custom-cflags; then
make_flags=(CFLAGS="${CFLAGS}" "${make_flags[@]}")
diff --git a/sys-boot/refind/refind-0.12.0-r1.ebuild b/sys-boot/refind/refind-0.12.0-r1.ebuild
index f63a0cbd3243..c1d166f0b4d8 100644
--- a/sys-boot/refind/refind-0.12.0-r1.ebuild
+++ b/sys-boot/refind/refind-0.12.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -77,9 +77,9 @@ src_compile() {
EFILIB="/usr/$(get_libdir)"
EFICRT0="/usr/$(get_libdir)"
EDK2BASE="${UDK_WORKSPACE}"
- EDK2_DRIVER_BASENAMES="${fs_names[@]}"
- FILESYSTEMS="${fs_names[@]}"
- FILESYSTEMS_GNUEFI="${fs_names[@]}"
+ EDK2_DRIVER_BASENAMES="${fs_names[*]}"
+ FILESYSTEMS="${fs_names[*]}"
+ FILESYSTEMS_GNUEFI="${fs_names[*]}"
)
if use custom-cflags; then
make_flags=(CFLAGS="${CFLAGS} -fno-tree-loop-distribute-patterns" "${make_flags[@]}")