summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/feedbackd-agent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/feedbackd-agent')
-rw-r--r--sys-cluster/feedbackd-agent/Manifest1
-rw-r--r--sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild40
-rw-r--r--sys-cluster/feedbackd-agent/files/feedbackd-agent-0.4-asneeded.patch40
-rw-r--r--sys-cluster/feedbackd-agent/metadata.xml8
4 files changed, 89 insertions, 0 deletions
diff --git a/sys-cluster/feedbackd-agent/Manifest b/sys-cluster/feedbackd-agent/Manifest
new file mode 100644
index 000000000000..ffe75d010012
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/Manifest
@@ -0,0 +1 @@
+DIST feedbackd-agent-0.4.tar.gz 69078 SHA256 0e1cf74d26387e5ce2591f29b92a19dfcd29b005585d363baa717c03705e49c8
diff --git a/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild b/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild
new file mode 100644
index 000000000000..c75714ee74f5
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="system for dynamic feedback of server loads in a Linux Virtual Server (LVS)-based cluster"
+HOMEPAGE="http://ozlabs.org/~jk/projects/feedbackd/"
+SRC_URI="mirror://sourceforge/feedbackd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xml-config=/usr/bin/xml2-config \
+ --with-perl=/usr/bin/perl \
+ || die "bad ./configure"
+
+ emake || die
+}
+
+src_install() {
+ #make DESTDIR=${D} install || die
+ einstall || die
+ dodoc ChangeLog NEWS README
+}
diff --git a/sys-cluster/feedbackd-agent/files/feedbackd-agent-0.4-asneeded.patch b/sys-cluster/feedbackd-agent/files/feedbackd-agent-0.4-asneeded.patch
new file mode 100644
index 000000000000..9a29a3fa59eb
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/files/feedbackd-agent-0.4-asneeded.patch
@@ -0,0 +1,40 @@
+--- Makefile.in
++++ Makefile.in
+@@ -34,13 +34,16 @@
+ # build flags
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@ @DEFS@ -I.
+-LDFLAGS = @LDFLAGS@ @LIBS@
++LDFLAGS = @LDFLAGS@
++LIBS = @LIBS@
+
+ XML_CFLAGS = @XML_CFLAGS@
+-XML_LDFLAGS = @XML_LDFLAGS@ @XML_LIBS@
++XML_LDFLAGS = @XML_LDFLAGS@
++LIBS += @XML_LIBS@
+
+ PERL_CFLAGS = @PERL_CFLAGS@
+-PERL_LDFLAGS = @PERL_LDFLAGS@ @PERL_LIBS@
++PERL_LDFLAGS = @PERL_LDFLAGS@
++LIBS += @PERL_LIBS@
+
+ # build targets
+ PLUGINS = @PLUGINS@
+@@ -63,7 +66,7 @@
+ # feedbackd-agent main program
+ $(AGENT): src/feedbackd-agent
+
+-src/feedbackd-agent: $(foreach f, $($(AGENT)_objs), src/$(f).o)
++src/feedbackd-agent: $(foreach f, $($(AGENT)_objs), src/$(f).o) $(LIBS)
+
+ src/feedbackd-agent: CFLAGS += $(XML_CFLAGS)
+ src/feedbackd-agent: LDFLAGS += $(XML_LDFLAGS)
+@@ -75,7 +78,7 @@
+ $(PLUGINS) : % : src/plugins/%.so
+
+ src/plugins/%.so: src/plugins/%.o
+- $(CC) -shared -nostartfiles $(LDFLAGS) -o $@ $^
++ $(CC) -shared -nostartfiles $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ src/plugins/%.so: CFLAGS+=-fPIC $(XML_CFLAGS)
+ src/plugins/%.so: LDFLAGS+=$(XML_LDFLAGS)
diff --git a/sys-cluster/feedbackd-agent/metadata.xml b/sys-cluster/feedbackd-agent/metadata.xml
new file mode 100644
index 000000000000..dfc0fe502816
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <upstream>
+ <remote-id type="sourceforge">feedbackd</remote-id>
+ </upstream>
+</pkgmetadata>