summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-01 10:41:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-01 11:07:03 +0200
commit99f5bced17f4d40cc97cbcb548be8a9cc33b41af (patch)
tree0a15383377d5e70607674a8b6180477d1fe39077 /sys-cluster
parentdev-python/kazoo: Fix passing zookeeper version to tests (diff)
downloadgentoo-99f5bced17f4d40cc97cbcb548be8a9cc33b41af.tar.gz
gentoo-99f5bced17f4d40cc97cbcb548be8a9cc33b41af.tar.bz2
gentoo-99f5bced17f4d40cc97cbcb548be8a9cc33b41af.zip
sys-cluster/zookeeper-bin: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/zookeeper-bin/Manifest3
-rw-r--r--sys-cluster/zookeeper-bin/zookeeper-bin-3.4.10.ebuild90
-rw-r--r--sys-cluster/zookeeper-bin/zookeeper-bin-3.4.11.ebuild90
-rw-r--r--sys-cluster/zookeeper-bin/zookeeper-bin-3.4.12.ebuild90
4 files changed, 0 insertions, 273 deletions
diff --git a/sys-cluster/zookeeper-bin/Manifest b/sys-cluster/zookeeper-bin/Manifest
index 0fdfe7b35059..bc25b58e05cd 100644
--- a/sys-cluster/zookeeper-bin/Manifest
+++ b/sys-cluster/zookeeper-bin/Manifest
@@ -1,4 +1 @@
-DIST zookeeper-3.4.10.tar.gz 35042811 BLAKE2B c17100d2179688665cfc9efededd378543492e2a839df9da7ab72097b954200c527375cadae1d7b30d83c511c21c1470d0b86a4a19df5abe0c82980920cad92f SHA512 4c54e40ac8d0b267db4a188a30e39ed0ac2c3e8a8fadaf244be45ff5adee956df28f6cb9f1eb56f175e924fa3629b64f98286a090c46764c91c017613c80a51b
-DIST zookeeper-3.4.11.tar.gz 36668066 BLAKE2B 4bf963d41280bd6227b4e81721576bf1f973a765c7049e78c5fae4d9dbc7e4d034304208af0f68b894bd4624e1945c9e4492b3217ff7f0e05d9b822c1843d96d SHA512 1ed2df11dbff2fbbb70d992d02427c4f694ccb4fe493db10a087b04d934b132b970956099edbdf1c2c636d5eb248bca1528846fcb449ae8bee4b9a82f7936f9e
-DIST zookeeper-3.4.12.tar.gz 36667596 BLAKE2B e4aac98f86fc4fcc576ecfb55381fd37efe3fa56cebc1632abda59b6ba71fecca17ace29124ef9f59ca0de627ff463f9d6fc7ff7fbbe77c2bbf30ae25a9f99f8 SHA512 026c7feb4a660bf8d99b1b719fec2b7e4603c3c46f2b77bac372df15ed0ceb4d971aa9c954082d61d73929ef8dc38c31693604ae75244f746cafb4eb6e67320c
DIST zookeeper-3.4.13.tar.gz 37191810 BLAKE2B 994eecf982a19bbf3ae648c5d140746f5836f0f5d8921ed005ebccdedf0098591005b9038eb75fc660b48ae12b09b8db9dd68d3ac3b4ac9f847de214996e1efd SHA512 3481bd19945d80848f81d9dc2896a682ae8b62269b8164ffbae532e55aa4219961403e0208c8e72cf784605eae436d70ddae2b26e0deba0f1f84c74188c32c0a
diff --git a/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.10.ebuild b/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.10.ebuild
deleted file mode 100644
index 8f6e4bd484fb..000000000000
--- a/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.10.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils java-utils-2 user
-
-MY_P="zookeeper"
-MY_PN=${MY_P}-${PV}
-
-DESCRIPTION="A high-performance coordination service for distributed applications."
-HOMEPAGE="http://zookeeper.apache.org/"
-SRC_URI="mirror://apache/${MY_P}/${MY_PN}/${MY_PN}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror binchecks"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=virtual/jre-1.7"
-
-S=${WORKDIR}/${MY_PN}
-
-INSTALL_DIR=/opt/${PN}
-export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"
-
-pkg_setup() {
- enewgroup zookeeper
- enewuser zookeeper -1 /bin/sh /var/lib/zookeeper zookeeper
-}
-
-src_prepare() {
- # python
- sed -e "s|src/c/zookeeper.c|zookeeper.c|g" \
- -e "s|../../../|${S}|g" \
- -i contrib/zkpython/src/python/setup.py || die
-}
-
-src_configure() {
- cd "${S}"/src/c || die
- econf
-}
-
-src_compile() {
- cd "${S}"/src/c || die
- emake
-}
-
-src_install() {
- local DATA_DIR=/var/lib/${MY_P}
-
- # python
- cd "${S}"/contrib/zkpython/ || die
- mv src/python/setup.py .
- mv src/c/* .
- python_foreach_impl distutils-r1_src_install
- cd "${S}" || die
-
- # cleanup sources
- rm -rf src/ || die
- rm bin/*.cmd || die
-
- keepdir "${DATA_DIR}"
- sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die "sed failed"
- cp "${FILESDIR}"/log4j.properties conf/ || die "cp log4j conf failed"
-
- dodir "${INSTALL_DIR}"
- cp -a "${S}"/* "${D}${INSTALL_DIR}" || die "install failed"
-
- # data dir perms
- fowners zookeeper:zookeeper "${DATA_DIR}"
-
- # log dir
- keepdir /var/log/zookeeper
- fowners zookeeper:zookeeper /var/log/zookeeper
-
- # init script
- newinitd "${FILESDIR}"/zookeeper.initd zookeeper
- newconfd "${FILESDIR}"/zookeeper.confd zookeeper
-
- # env file
- cat > 99"${PN}" <<-EOF
- PATH=${INSTALL_DIR}/bin
- CONFIG_PROTECT=${INSTALL_DIR}/conf
- EOF
- doenvd 99"${PN}"
-}
diff --git a/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.11.ebuild b/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.11.ebuild
deleted file mode 100644
index 8f6e4bd484fb..000000000000
--- a/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.11.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils java-utils-2 user
-
-MY_P="zookeeper"
-MY_PN=${MY_P}-${PV}
-
-DESCRIPTION="A high-performance coordination service for distributed applications."
-HOMEPAGE="http://zookeeper.apache.org/"
-SRC_URI="mirror://apache/${MY_P}/${MY_PN}/${MY_PN}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror binchecks"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=virtual/jre-1.7"
-
-S=${WORKDIR}/${MY_PN}
-
-INSTALL_DIR=/opt/${PN}
-export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"
-
-pkg_setup() {
- enewgroup zookeeper
- enewuser zookeeper -1 /bin/sh /var/lib/zookeeper zookeeper
-}
-
-src_prepare() {
- # python
- sed -e "s|src/c/zookeeper.c|zookeeper.c|g" \
- -e "s|../../../|${S}|g" \
- -i contrib/zkpython/src/python/setup.py || die
-}
-
-src_configure() {
- cd "${S}"/src/c || die
- econf
-}
-
-src_compile() {
- cd "${S}"/src/c || die
- emake
-}
-
-src_install() {
- local DATA_DIR=/var/lib/${MY_P}
-
- # python
- cd "${S}"/contrib/zkpython/ || die
- mv src/python/setup.py .
- mv src/c/* .
- python_foreach_impl distutils-r1_src_install
- cd "${S}" || die
-
- # cleanup sources
- rm -rf src/ || die
- rm bin/*.cmd || die
-
- keepdir "${DATA_DIR}"
- sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die "sed failed"
- cp "${FILESDIR}"/log4j.properties conf/ || die "cp log4j conf failed"
-
- dodir "${INSTALL_DIR}"
- cp -a "${S}"/* "${D}${INSTALL_DIR}" || die "install failed"
-
- # data dir perms
- fowners zookeeper:zookeeper "${DATA_DIR}"
-
- # log dir
- keepdir /var/log/zookeeper
- fowners zookeeper:zookeeper /var/log/zookeeper
-
- # init script
- newinitd "${FILESDIR}"/zookeeper.initd zookeeper
- newconfd "${FILESDIR}"/zookeeper.confd zookeeper
-
- # env file
- cat > 99"${PN}" <<-EOF
- PATH=${INSTALL_DIR}/bin
- CONFIG_PROTECT=${INSTALL_DIR}/conf
- EOF
- doenvd 99"${PN}"
-}
diff --git a/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.12.ebuild b/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.12.ebuild
deleted file mode 100644
index a68eac797592..000000000000
--- a/sys-cluster/zookeeper-bin/zookeeper-bin-3.4.12.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils java-utils-2 user
-
-MY_P="zookeeper"
-MY_PN=${MY_P}-${PV}
-
-DESCRIPTION="A high-performance coordination service for distributed applications."
-HOMEPAGE="http://zookeeper.apache.org/"
-SRC_URI="mirror://apache/${MY_P}/${MY_PN}/${MY_PN}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror binchecks"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=virtual/jre-1.7"
-
-S=${WORKDIR}/${MY_PN}
-
-INSTALL_DIR=/opt/${PN}
-export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"
-
-pkg_setup() {
- enewgroup zookeeper
- enewuser zookeeper -1 /bin/sh /var/lib/zookeeper zookeeper
-}
-
-src_prepare() {
- # python
- sed -e "s|src/c/zookeeper.c|zookeeper.c|g" \
- -e "s|../../../|${S}|g" \
- -i contrib/zkpython/src/python/setup.py || die
-}
-
-src_configure() {
- cd "${S}"/src/c || die
- econf
-}
-
-src_compile() {
- cd "${S}"/src/c || die
- emake
-}
-
-src_install() {
- local DATA_DIR=/var/lib/${MY_P}
-
- # python
- cd "${S}"/contrib/zkpython/ || die
- mv src/python/setup.py .
- mv src/c/* .
- python_foreach_impl distutils-r1_src_install
- cd "${S}" || die
-
- # cleanup sources
- rm -rf src/ || die
- rm bin/*.cmd || die
-
- keepdir "${DATA_DIR}"
- sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die "sed failed"
- cp "${FILESDIR}"/log4j.properties conf/ || die "cp log4j conf failed"
-
- dodir "${INSTALL_DIR}"
- cp -a "${S}"/* "${D}${INSTALL_DIR}" || die "install failed"
-
- # data dir perms
- fowners zookeeper:zookeeper "${DATA_DIR}"
-
- # log dir
- keepdir /var/log/zookeeper
- fowners zookeeper:zookeeper /var/log/zookeeper
-
- # init script
- newinitd "${FILESDIR}"/zookeeper.initd zookeeper
- newconfd "${FILESDIR}"/zookeeper.confd zookeeper
-
- # env file
- cat > 99"${PN}" <<-EOF
- PATH=${INSTALL_DIR}/bin
- CONFIG_PROTECT=${INSTALL_DIR}/conf
- EOF
- doenvd 99"${PN}"
-}