summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-12-01 17:25:16 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-12-01 17:29:49 -0600
commitd2fb6ab2ccb2014a466fc5e1082751690cdf329f (patch)
tree14fed056a74ffc942f564b2eb63022cec8bfa330 /sys-cluster
parentapp-text/tree: Stabilize 2.0.4 x86, #883931 (diff)
downloadgentoo-d2fb6ab2ccb2014a466fc5e1082751690cdf329f.tar.gz
gentoo-d2fb6ab2ccb2014a466fc5e1082751690cdf329f.tar.bz2
gentoo-d2fb6ab2ccb2014a466fc5e1082751690cdf329f.zip
sys-cluster/rocm-k8s-device-plugin: add 0.5.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/Manifest1
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-cluster/rocm-k8s-device-plugin/Manifest b/sys-cluster/rocm-k8s-device-plugin/Manifest
index 3753aa1967a9..6c8a57db1eb2 100644
--- a/sys-cluster/rocm-k8s-device-plugin/Manifest
+++ b/sys-cluster/rocm-k8s-device-plugin/Manifest
@@ -1 +1,2 @@
DIST rocm-k8s-device-plugin-0.3.0.tar.gz 5188051 BLAKE2B cff5a5eefea521fc398a3b9199375f8a4ed875688fc06bc6a097cdef017d1ef102eea096a8e37aa2d962afc2fc0a8153c26e36b226a31a1913ae2de97d632650 SHA512 d5c9c590aeb5fb744917662c9bc8a88a95c7b4478c614808c86ecb6caaf4f20c81a0013e6352d701c29c9c10810231ab142859ee95923e31d9267206209e4948
+DIST rocm-k8s-device-plugin-0.5.0.tar.gz 6297528 BLAKE2B 8fed4af34e2639eecbcd6e8b238a9a964203693e9f7458486a4e36d61b83908ebcb72f7d582b0fe240518a6e3eed5e38403be265a600af01383b860075097ea2 SHA512 56b38d9f1c516bfcc735dbcf1128ab9f7967871295c214ebb474d7fc3ed18822b6389dc5fae08e54a3735fd0704b67d71e9beba6066f313ed69c1d7c9c8fad2a
diff --git a/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.5.0.ebuild b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.5.0.ebuild
new file mode 100644
index 000000000000..ab99d6d76c8c
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# update these on every bump
+VERSION=v1.18.1-12-g939a8a0
+TAG="amd-gpu-helm-${PV}"
+
+DESCRIPTION="AMD GPU device plugin for kubernetes"
+HOMEPAGE="https://github.com/RadeonOpenCompute/k8s-device-plugin"
+SRC_URI="https://github.com/RadeonOpenCompute/k8s-device-plugin/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-apps/hwloc
+ x11-libs/libdrm[video_cards_amdgpu]"
+RDEPEND="${DEPEND}
+ sys-cluster/kubelet"
+
+S="${WORKDIR}/k8s-device-plugin-${TAG}"
+
+src_compile() {
+ GOBIN="${S}/bin" \
+ ego install \
+ -ldflags="-X main.gitDescribe=${VERSION}" \
+ ./cmd/k8s-device-plugin
+}
+
+src_install() {
+ exeinto /var/lib/kubelet/device-plugins
+ doexe bin/k8s-device-plugin
+ einstalldocs
+}